Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox still keeps search and form history when I tell it not to.

  • 7 replies
  • 4 have this problem
  • 98 views
  • Last reply by cor-el

more options

I've updated the security and privacy settings to where Firefox does not remember search and form history, but it still does it...do I have to clear that history every day after I use Firefox?

I've updated the security and privacy settings to where Firefox does not remember search and form history, but it still does it...do I have to clear that history every day after I use Firefox?

Chosen solution

You're welcome Helen.

Read this answer in context 👍 0

All Replies (7)

more options

Do you mean that even after you uncheck the box for "Remember search and form history" Firefox just goes on storing or displaying form history entries? That definitely seems wrong. When you check the preferences again, is it still unchecked or did it get turned back on, either immediately or after quitting and starting Firefox again?

more options

If the change just isn't taking...

A few others users have said that some aspects of the new "in tab" preferences page do not work for them.

As a diagnostic, if you don't mind, could you test the Preferences page in Firefox's Safe Mode? This will help assess whether this problem is caused by one of your extensions. Here's how:

If Firefox is not running: Hold down the option key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement with the in-tab preferences page?


Or you might need to switch back to the old pop-up style Preferences dialog. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste pref and pause while the list is filtered

(3) Double-click the browser.preferences.inContent preference to switch it from true to false

(Note: I don't know whether the old dialog will be in Firefox forever or is a transitional feature. As you've probably noticed, the long-term trend is to remove things that pop up.)

Does that make any difference?

more options

You can check for problems with the formhistory.sqlite file and delete the formhistory.sqlite file in the Firefox profile folder to see if that helps.

You can use this button to go to the currently used Firefox profile folder:

more options

I have this same problem. The above suggestions do not work because I can't locate browser.preferences.inContent (it is NOT there). And I can't get to the Profile Directory to delete the sqlite file.

more options

Hi Helen

You need to delete items that are already stored as saved form data.

Use these steps to remove saved (form) data from a drop-down list:

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with the mouse or cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

You can use this button to go to the current Firefox profile folder:

The browser.preferences.inContent is no longer supported in Firefox 42 and later (bug 1140495), so it is not possible to open a standalone window by setting this pref to false.

You can possibly create a button on the Bookmarks Toolbar to the about:preferences page and hold the Shift key and left-click to open the page in a new window or tear off the tab with the about:preferences page (Tab bar: Move to New Window).

You can look at the Classic Theme Restorer extension.

  • General UI (1): Open options page (about:preferences) in a window

If that isn't working or the choice is missing then you might be using a theme that isn't supported. You can check that by switching to the default theme.

more options

Oh, I get it! The saved data that was in there previously has to be gotten rid of. Firefox is actually not searching anymore, but the old stuff keeps popping up. I was able to follow the 3-step solution above and now everything is great. THANK YOU cor-el! You have no idea how relieved I am. I had almost decided to switch to Chrome, but thanks to you I will stay with Firefox (in spite of the ridiculous hoops it makes me jump through).

THANK YOU AGAIN.

more options

Chosen Solution

You're welcome Helen.