Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Earthlink - Connection is Untrusted

  • 17 replies
  • 1 has this problem
  • 82 views
  • Last reply by tknutsen1

more options

I have tried the "This Connection is Untrusted" error message appears - What to do" article for the 'issuer certificate is unknown' error which is 'The file cert8.db in your profile folder may have become corrupted. Delete this file while Firefox is closed. ' Unfortunately this did not solve my issue. So I use the Add Exception button in an attempt to have FF store a permanent exception for 'https://my.Earthlink.net'. Problem is in using the Get Certificate button does not work. FF attempts to retrieve the EL certificate but is not successful. Hence the option to Permanently Store the certificate is not available and I have to do is every time I start FF. This seems to be the only website I encounter this with. System: Win7 64 bit, Home Premium, FF 38.0.1, HP Pavilion dv7. Hopefully I have provided sufficient details for someone to assist with this.

All Replies (17)

more options

The good news is, this site actually does have a legit certificate. Unfortunately, the page isn't fully designed to be used with HTTPS, there is some "mixed content" in the page as shown by the warning icons in the address bar in the attached screen shot.

Is this the only site where you get a certificate error? If you are noticing this issue on multiple sites, it could be that Firefox is not fully set up to work with your security software that filters secure connections (e.g., avast! 2015, BitDefender, ESET, Kaspsersky). Do you use any of those programs? Unfortunately, it also can indicate a malware infection in some cases.

To try to track down that issue, could you load the page in a different browser and click the padlock in the address bar there, view the certificate, and compare the "Issued by" or Issuer section of the certificate with the one attached? If you see something different, what is it?

more options

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

You can use this button to go to the currently used Firefox profile folder:

more options

jscher2000 said

The good news is, this site actually does have a legit certificate. Unfortunately, the page isn't fully designed to be used with HTTPS, there is some "mixed content" in the page as shown by the warning icons in the address bar in the attached screen shot. Is this the only site where you get a certificate error? If you are noticing this issue on multiple sites, it could be that Firefox is not fully set up to work with your security software that filters secure connections (e.g., avast! 2015, BitDefender, ESET, Kaspsersky). Do you use any of those programs? Unfortunately, it also can indicate a malware infection in some cases. To try to track down that issue, could you load the page in a different browser and click the padlock in the address bar there, view the certificate, and compare the "Issued by" or Issuer section of the certificate with the one attached? If you see something different, what is it?

Thanks for the reply. Yes I assumed Earthlink did have a legit certificate as it is my ISP for several years. And this is the only site I have encountered this notice and BTW it is only when I login to my EL account. If I simply pull up the page I have no issue.

more options

Do you mean this login page is not secure for you?

https://my.earthlink.net/channel/edit/signin

Or does the error occur after you submit the form?

The form should submit to the same server, so it would be suspicious if you get a different issue when submitting.

more options

jscher2000 said

Do you mean this login page is not secure for you? https://my.earthlink.net/channel/edit/signin Or does the error occur after you submit the form? The form should submit to the same server, so it would be suspicious if you get a different issue when submitting.

This Page: https://my.earthlink.net/channel/START is what returns the error. And FF is the only browser where I encounter this issue.

more options

tknutsen1 said

This Page: https://my.earthlink.net/channel/START is what returns the error. And FF is the only browser where I encounter this issue.

I can't tell what the issue is, probably because without an account I am seeing a more generic version of the page that isn't customized for you.

more options

Could you try these general things? Apologies for not suggesting these earlier.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, earthlink.net should be filled in at the top to filter the list. You can remove the site's cookies individually.

Then try reloading the main page and logging in again. Does that help?

more options

Sorry but none of the solutions have helped yet. This is most likely the same as this issue: https://support.mozilla.org/en-US/questions/1055961#answer-733242 Thanks

more options

Do you get that same error page which has a Technical Details section? If so, please copy/paste the contents of that section into a reply.

more options

jscher2000 said

Do you get that same error page which has a Technical Details section? If so, please copy/paste the contents of that section into a reply.


Yes I do get this error page - as I stated in the opening for this issue I get 'The certificate is not trusted because the issuer certificate is unknown.' error. The common suggestions for fixing this error in the common solutions error do not work (similar to the suggestion posted by cor-el.

more options

That section usually ends with a specific code in parentheses. Could you paste that, too? It may or may not help identify a more specific issue.

more options

jscher2000 said

Do you get that same error page which has a Technical Details section? If so, please copy/paste the contents of that section into a reply.

(Error code: sec_error_unknown_issuer) is the error

more options

Okay, the mystery continues. Firefox gets a complete chain of trust one page before, for the login form, but then the certificate appears to be changing in some fashion after the login.

Perhaps Earthlink uses multiple servers and one of them has a bad certificate or bad chain of trust? But it is difficult to evaluate if the Exception dialog won't load the certificate to check how it compares with the one from the login page -- is the View button grayed out, or can you access it to check the issuer and chain info?


Other than a glitch caused by switching servers, I would be suspicious of a hijacked connection, but with very puzzling behavior.

Or maybe during your last update the Firefox program files got corrupted? To address that possibility, please try this:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

jscher2000 said

Okay, the mystery continues. Firefox gets a complete chain of trust one page before, for the login form, but then the certificate appears to be changing in some fashion after the login. Perhaps Earthlink uses multiple servers and one of them has a bad certificate or bad chain of trust? But it is difficult to evaluate if the Exception dialog won't load the certificate to check how it compares with the one from the login page -- is the View button grayed out, or can you access it to check the issuer and chain info?

Other than a glitch caused by switching servers, I would be suspicious of a hijacked connection, but with very puzzling behavior.

Or maybe during your last update the Firefox program files got corrupted? To address that possibility, please try this:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

I will attempt to attached the View of the technical details And I will try your suggestion also. Thanks for the assistance, it is much appreciated. While I can accept the override, the Get Certificate button tries to work but fails so I cannot store 'Permanently Store Exception' and have to due this if I want to log-in to my account on EL

more options

Do you see the "COMODO RSA Organization Validation Secure Server CA" under "COMODO CA Limited" in the certificate manager?

  • Tools > Options > Advanced > Certificates: View Certificates

I notice that the current release has the "COMODO RSA Certification Authority" as a built-in root certificate. In older Firefox versions this certificate was an intermediate certificate issued by AddTrust External CA Root and appeared under AddTrust AB.

more options

cor-el said

Do you see the "COMODO RSA Organization Validation Secure Server CA" under "COMODO CA Limited" in the certificate manager?
  • Tools > Options > Advanced > Certificates: View Certificates
I notice that the current release has the "COMODO RSA Certification Authority" as a built-in root certificate. In older Firefox versions this certificate was an intermediate certificate issued by AddTrust External CA Root and appeared under AddTrust AB. </blockq Do not see this particular cert listed. </blockquote>
more options

Do not see this particular cert listed