X
Tap here to go to the mobile version of the site.

Support Forum

My firefox automatically delete my web history after I close FF. I use the option remember history. But it keep delete my history everytime i close

Posted

My firefox automatically deletes my web history. I don't use auto clear history option and this annoying me when i need find website I visited few day earlier

My firefox automatically deletes my web history. I don't use auto clear history option and this annoying me when i need find website I visited few day earlier

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • BlackBerry WebSL Browser Plug-In
  • Shockwave Flash 16.0 r0
  • Unity Player 4.5.2f1
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

Microrobot 29 solutions 278 answers

Hello!

Make sure your settings match mine

Image: http://prntscr.com/799ans

To enter settings in the URL bar enter about:preferences#privacy

Hello! Make sure your settings match mine '''Image: '''http://prntscr.com/799ans To enter settings in the URL bar enter '''about:preferences#privacy'''
FredMcD
  • Top 10 Contributor
4261 solutions 59657 answers

History and cookies can be removed or not recorded several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings
    (Type about:preferences#privacy<enter> in the address bar.)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.

Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the places.sqlite file. Then rename or delete it. Restart Firefox.

History and cookies can be removed or not recorded several ways; * 1) Running Firefox in Private Mode (nothing is recorded) * 2) Privacy settings<br>(Type '''about:preferences#privacy'''<enter> in the address bar.) * 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone. * 4) Mal-ware. -------------------------- Problems with bookmarks and history not working properly can be caused by a corrupted '''places.sqlite''' database file. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the '''places.sqlite''' file. Then rename or delete it. Restart Firefox.
ideato 893 solutions 6250 answers
Hi, see also : https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ thank you