X
Tap here to go to the mobile version of the site.

Support Forum

On a few sites, there are no scroll bars and my wirelesss mouse won't scroll either

Posted

Firefox 38.0.1 is installed on an iMac running OSX 10.9.5 my Apple wireless mouse works on 75% of the sites I visit, but will not scroll on others. Also there are no scroll bars or a back button.

Firefox 38.0.1 is installed on an iMac running OSX 10.9.5 my Apple wireless mouse works on 75% of the sites I visit, but will not scroll on others. Also there are no scroll bars or a back button.

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.14
  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • iPhoto6

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/Darwin/en-US/

Extensions

  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6740
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- AMD Radeon HD 6770M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4308 solutions 60500 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

I finally solved my problem of some web sites not scrolling or showing a back button on any of their links, using Firefox 38.0.1 on my Mac!

I downloaded a previous version (37.0.2) and installed it, replacing v 38.

All the sites worked/scroll bars returned/back arrows returned!

There must have some undiscovered anomaly in v 38 for Mac users. I did not try it on a PC. I hope Mozilla finds it and fixes the new update.

I finally solved my problem of some web sites not scrolling or showing a back button on any of their links, using Firefox 38.0.1 on my Mac! I downloaded a previous version (37.0.2) and installed it, replacing v 38. All the sites worked/scroll bars returned/back arrows returned! There must have some undiscovered anomaly in v 38 for Mac users. I did not try it on a PC. I hope Mozilla finds it and fixes the new update.
FredMcD
  • Top 10 Contributor
4308 solutions 60500 answers

Well, not a solution, but what works, works.

Safe Surfing.

Well, not a solution, but what works, works. Safe Surfing.
cor-el
  • Top 10 Contributor
  • Moderator
17689 solutions 160034 answers

You might experience this bug that happens when you are running Firefox in Private Browsing mode and you open links in a new window.

  • bug 1166066 - Firefox 38 regression: link in private window with target="_blank" opens window with no tabs/toolbars/menus (bug1166066)

Possible workarounds: (1) use Options/Preferences > General: "Open new windows in a new tab instead" (2) Shift+click links to open in a new window with the standard features or use the right-click context menu.

You might experience this bug that happens when you are running Firefox in Private Browsing mode and you open links in a new window. *[https://bugzilla.mozilla.org/show_bug.cgi?id=1166066 bug 1166066] - Firefox 38 regression: link in private window with target="_blank" opens window with no tabs/toolbars/menus (bug1166066) Possible workarounds: (1) use Options/Preferences > General: "Open new windows in a new tab instead" (2) Shift+click links to open in a new window with the standard features or use the right-click context menu.
jscher2000
  • Top 10 Contributor
8837 solutions 72232 answers

The developers are working on a fix for this problem. Meanwhile, here is a third workaround:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows. On the other hand, if a site displays a tiny window, you may need to enlarge it now that it will have toolbars.

The developers are working on a fix for this problem. Meanwhile, here is a third workaround: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''feat''' and pause while the list is filtered (C) For every preference that starts with '''dom.disable_window_open_feature.''' if it is not "true", double-click it to switch it to true. You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows. On the other hand, if a site displays a tiny window, you may need to enlarge it now that it will have toolbars.