X
Tap here to go to the mobile version of the site.

Support Forum

Private Browsing issues: New window is a "pop-up" & Right-clicking bookmarks shows grayed-out options

Posted

When I'm in private browsing mode in Firefox 38.0.1 for Windows 8.1, I cannot do the following things.

1. When I click on a link to open a new window, that new window is like a pop-up window (no menus, no scroll-bars). But I have pop-up windows blocked, so it acts like but is not technically a pop-up window since it's not being blocked.

2. When I choose a bookmark and then right-click on it to choose another bookmark either in a new window or new tab (or any of the other options that appear), the text is grayed out so that I cannot choose it.

Are these "issues" normal for Firefox 38.0.1?

When I'm in private browsing mode in Firefox 38.0.1 for Windows 8.1, I cannot do the following things. 1. When I click on a link to open a new window, that new window is like a pop-up window (no menus, no scroll-bars). But I have pop-up windows blocked, so it acts like but is not technically a pop-up window since it's not being blocked. 2. When I choose a bookmark and then right-click on it to choose another bookmark either in a new window or new tab (or any of the other options that appear), the text is grayed out so that I cannot choose it. Are these "issues" normal for Firefox 38.0.1?

Chosen solution

My suggestions for settings were meant to be carried out in about:config. Type that into the address bar, press the return key, then change those settings. That will affect popup windows. Does it also affect the private windows?

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Exent® AOD Gecko Plugin
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_45 for Mozilla browsers
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Nitro PDF plugin for Firefox and Chrome
  • npapicomadapter
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • 5.1.40416.0
  • iTunes Detector Plug-in

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • CheckPlaces 2.6.2 (checkplaces@andyhalford.com)
  • FireFTP 2.0.23 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • IE View 1.5.6 ({6e84150a-d526-41f1-a480-a67d3fed910d})
  • Long URL Please 0.5.1 (longurlplease@darragh.curran)
  • Lost Friends Notifier 0.3 (jid1-s0hS918atYzRdw@jetpack)
  • McAfee Security Scan Plus 1.0 ({e4f94d1e-2f53-401e-8885-681602c0ddd8})
  • Remote XUL Manager 1.2.4.1-signed (remotexulmanager@xulforge.com)
  • SortPlaces 1.9.2 (sortplaces@andyhalford.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0152
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 20118086
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17795
  • driverDate: 9-30-2014
  • driverDate2:
  • driverVersion: 10.18.10.3958
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
finitarry 251 solutions 3421 answers

If you force pop-up windows to have extra features, does that cure the problem with them being missing in the private windows? The settings: dom.disable_window_open_feature.directories = true dom.disable_window_open_feature.location = true dom.disable_window_open_feature.menubar = true dom.disable_window_open_feature.personalbar = true dom.disable_window_open_feature.scrollbars = true dom.disable_window_open_feature.titlebar = true dom.disable_window_open_feature.toolbar = true

If you force pop-up windows to have extra features, does that cure the problem with them being missing in the private windows? The settings: dom.disable_window_open_feature.directories = true dom.disable_window_open_feature.location = true dom.disable_window_open_feature.menubar = true dom.disable_window_open_feature.personalbar = true dom.disable_window_open_feature.scrollbars = true dom.disable_window_open_feature.titlebar = true dom.disable_window_open_feature.toolbar = true
cor-el
  • Top 10 Contributor
  • Moderator
17472 solutions 157915 answers

See also;


The setting in Tools > Options > Tabs: "New pages should be opened in": "a new tab/window" is for links that specify a target window for opening a link. The browser.link.open_newwindow pref only affects links that specify a target window. You can use the browser.link.open_newwindow pref to divert links that specify a target to the current tab or a new tab. The browser.link.open_newwindow.restriction pref allows to divert (onclick) JavaScript window.open() links. Links that do not specify a target always open in the current tab unless you override that with a middle-click or Ctrl (Mac: Cmd) left-click (new tab) or Shift left-click (new window).


See also; *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features ----- The setting in Tools > Options > Tabs: "New pages should be opened in": "a new tab/window" is for links that specify a target window for opening a link. The browser.link.open_newwindow pref only affects links that specify a target window. You can use the browser.link.open_newwindow pref to divert links that specify a target to the current tab or a new tab. The browser.link.open_newwindow.restriction pref allows to divert (onclick) JavaScript window.open() links. Links that do not specify a target always open in the current tab unless you override that with a middle-click or Ctrl (Mac: Cmd) left-click (new tab) or Shift left-click (new window). ---- * http://kb.mozillazine.org/browser.link.open_newwindow * http://kb.mozillazine.org/browser.link.open_newwindow.restriction

Question owner

Thanks for your responses. I neglected to mention that - as a regular user - many of the tech jargon language/text is not understandable by me.

I also don't know if my description was clear enough. Maybe I don't understand the responses.

I don't mind if links opened up a new window; I did not want them to open in a new tab.

However, after the new update to 38.0.1, the browser is forcing links to open in a new window (which I don't mind) but (this is my issue) those windows don't have scroll-bars or menu bars. If a new window opens up, I want another normal browser window to open up.

I do not want the "Open new windows in a new tab instead" option to be checked in Tools>Options.

Thanks for your responses. I neglected to mention that - as a regular user - many of the tech jargon language/text is not understandable by me. I also don't know if my description was clear enough. Maybe I don't understand the responses. I don't mind if links opened up a new window; I did not want them to open in a new tab. However, after the new update to 38.0.1, the browser is forcing links to open in a new window (which I don't mind) but (this is my issue) those windows don't have scroll-bars or menu bars. If a new window opens up, I want another normal browser window to open up. I do not want the "Open new windows in a new tab instead" option to be checked in Tools>Options.

Modified by Field of Stones

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Field of Stones said

I do not want the "Open new windows in a new tab instead" option to be checked in Tools>Options.

Is this setting not being saved?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

''Field of Stones [[#answer-729294|said]]'' <blockquote> I do not want the "Open new windows in a new tab instead" option to be checked in Tools>Options. </blockquote> Is this setting not being saved? '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save'''

Question owner

That's not my issue. I don't want it to be checked. I want links to open up in a new window.

My issue is that when I click on a link on a webpage or an e-mail, the new window opens up without menu bar and scroll-bars (much like a pop-up window, but it isn't really a pop-up window because I have the option to block pop-up windows enabled).

I could just browse without using private browsing (and clear history, etc.). But since it used to work, why not enable it so that I don't have to worry about removing all the history left behind.

That's not my issue. I don't want it to be checked. I want links to open up in a new window. My issue is that when I click on a link on a webpage or an e-mail, the new window opens up without menu bar and scroll-bars (much like a pop-up window, but it isn't really a pop-up window because I have the option to block pop-up windows enabled). I could just browse without using private browsing (and clear history, etc.). But since it used to work, why not enable it so that I don't have to worry about removing all the history left behind.

Question owner

Here is a screenshot of this page in a new window (selected from the e-mail notification that I had a response to my original post): Notice there is no menu bar and no scroll-bars. It looks like a full-screen pop-up window (I shrunk the dimensions so it would fit on my screen). I don't want that.

Here is a screenshot of this page in a new window (selected from the e-mail notification that I had a response to my original post): Notice there is no menu bar and no scroll-bars. It looks like a full-screen pop-up window (I shrunk the dimensions so it would fit on my screen). I don't want that.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

When you click a link, is Firefox already open? Is it in Private?

When that page shows up again, Type about:customizing<enter> in the address bar. Look for Show / Hide Toolbars at the bottom left.

When you click a link, is Firefox already open? Is it in Private? When that page shows up again, Type '''about:customizing'''<enter> in the address bar. Look for '''Show / Hide Toolbars''' at the bottom left.

Question owner

When I click on a link, it is from an open Firefox browser already in Private mode.

Here is something interesting I just noticed: Attempting to type about:customizing in the address bar, I can't type in it! I also cannot edit or remove the URL in the address bar.

So I went to Customizing via the Customize option from the three horizontal bars icon in the upper-right corner of my browser. The Menu Bar option is already checked.

When I click on a link, it is from an open Firefox browser already in Private mode. Here is something interesting I just noticed: Attempting to type ''about:customizing'' in the address bar, I can't type in it! I also cannot edit or remove the URL in the address bar. So I went to Customizing via the Customize option from the three horizontal bars icon in the upper-right corner of my browser. The Menu Bar option is already checked.

Modified by Field of Stones

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

As an experiment, start Firefox in normal mode. Is the problem still there?

As an experiment, start Firefox in normal mode. Is the problem still there?

Question owner

Everything is fine when browsing in normal mode. Oh, except that the new window opens up less than half the size of my screen. I have to maximize it manually.

And the grayed-out bookmark problem has returned. When I choose a bookmark and right-click on it, all the options are grayed-out so that I cannot choose any of them.

Everything is fine when browsing in normal mode. Oh, except that the new window opens up less than half the size of my screen. I have to maximize it manually. And the grayed-out bookmark problem has returned. When I choose a bookmark and right-click on it, all the options are grayed-out so that I cannot choose any of them.

Modified by Field of Stones

jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

How are you starting Private Browsing:

  • Setting Privacy options to make every window in a session private ("Never Remember History")
  • Opening a new private window in regular browsing mode (private windows distinguished with the little white/purple mask icon on the top bar)

When this happens, could you close the popup and try relaunching the page that had the link in a new window or tab? To do that:

  • Open the web console by pressing Ctrl+Shift+k
  • Type or paste the following script in the bar at the bottom of the console and press Enter to execute it:

    window.open(window.location.href, "_blank");

That should load the source page in a normal window -- although it might not be a private window if you are in a normal session. Does the link work any differently in that new window, or same behavior?

How are you starting Private Browsing: * Setting Privacy options to make every window in a session private ("Never Remember History") * Opening a new private window in regular browsing mode (private windows distinguished with the little white/purple mask icon on the top bar) ---- When this happens, could you close the popup and try relaunching the page that had the link in a new window or tab? To do that: * Open the web console by pressing Ctrl+Shift+k * Type or paste the following script in the bar at the bottom of the console and press Enter to execute it:<br><br><code>window.open(window.location.href, "_blank");</code> That should load the source page in a normal window -- although it might not be a private window if you are in a normal session. Does the link work any differently in that new window, or same behavior?
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Field of Stones said

And the grayed-out bookmark problem has returned. When I choose a bookmark and right-click on it, all the options are grayed-out so that I cannot choose any of them.

There is a glitch with the Bookmarks menu on the classic menu bar (not applicable to the Bookmarks menu button on the toolbar) related to using Customize. After using Customize one or more times, the standard items on the right-click context menu for bookmarks on the classic Bookmarks menu get grayed out for all tabs in the same window, but they are normal in other windows. I think this bug has been known since Firefox 29, but apparently it has not been solved yet.

''Field of Stones [[#answer-729566|said]]'' <blockquote> And the grayed-out bookmark problem has returned. When I choose a bookmark and right-click on it, all the options are grayed-out so that I cannot choose any of them. </blockquote> There is a glitch with the Bookmarks menu on the classic menu bar (not applicable to the Bookmarks menu button on the toolbar) related to using Customize. After using Customize one or more times, the standard items on the right-click context menu for bookmarks on the classic Bookmarks menu get grayed out for all tabs in the same window, but they are normal in other windows. I think this bug has been known since Firefox 29, but apparently it has not been solved yet.

Question owner

jscher2000 said

How are you starting Private Browsing:
  • Setting Privacy options to make every window in a session private ("Never Remember History")
  • Opening a new private window in regular browsing mode (private windows distinguished with the little white/purple mask icon on the top bar)

When this happens, could you close the popup and try relaunching the page that had the link in a new window or tab? To do that:

  • Open the web console by pressing Ctrl+Shift+k
  • Type or paste the following script in the bar at the bottom of the console and press Enter to execute it:

    window.open(window.location.href, "_blank");

That should load the source page in a normal window -- although it might not be a private window if you are in a normal session. Does the link work any differently in that new window, or same behavior?

I actually do both.

Normally, I would have the browser in "always open in Private Mode" with none of the boxes for "remember history" checked. The browser would open without the mask icon. The problem would still occur.

I would also open a new browser by right-clicking on the icon and choosing "open in a new private window". With both private mode checked or unchecked (the latter would cause the mask icon to appear), the problem would still occur.

I entered the line you provided in my console but the problem still occurs. I chose "new private window" by right-clicking on the Firefox icon, but in my Privacy settings, Private Mode is still unchecked.

''jscher2000 [[#answer-729570|said]]'' <blockquote> How are you starting Private Browsing: * Setting Privacy options to make every window in a session private ("Never Remember History") * Opening a new private window in regular browsing mode (private windows distinguished with the little white/purple mask icon on the top bar) ---- When this happens, could you close the popup and try relaunching the page that had the link in a new window or tab? To do that: * Open the web console by pressing Ctrl+Shift+k * Type or paste the following script in the bar at the bottom of the console and press Enter to execute it:<br><br><code>window.open(window.location.href, "_blank");</code> That should load the source page in a normal window -- although it might not be a private window if you are in a normal session. Does the link work any differently in that new window, or same behavior? </blockquote> I actually do both. Normally, I would have the browser in "always open in Private Mode" with none of the boxes for "remember history" checked. The browser would open without the mask icon. The problem would still occur. I would also open a new browser by right-clicking on the icon and choosing "open in a new private window". With both private mode checked or unchecked (the latter would cause the mask icon to appear), the problem would still occur. I entered the line you provided in my console but the problem still occurs. I chose "new private window" by right-clicking on the Firefox icon, but in my Privacy settings, Private Mode is still unchecked.
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Do all links do this, or only particular links/particular sites? It's definitely not typical for sites to user code that strips features from windows.

Do all links do this, or only particular links/particular sites? It's definitely not typical for sites to user code that strips features from windows.
cor-el
  • Top 10 Contributor
  • Moderator
17472 solutions 157915 answers

If you are in a pop-up window then you get a read-only location bar and some toolbar can be hidden. It is possible that you only have pop-up type windows open when you aren't able to open a bookmark because this bookmark would have to be open in a normal window.

Does Ctrl+N work in this case to open a new window?

PB mode or normal shouldn't make a difference for opening a link.

You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data. This would only affect normal windows and not PB mode windows as those aren't included.

If you are in a pop-up window then you get a read-only location bar and some toolbar can be hidden. It is possible that you only have pop-up type windows open when you aren't able to open a bookmark because this bookmark would have to be open in a normal window. Does Ctrl+N work in this case to open a new window? PB mode or normal shouldn't make a difference for opening a link. You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data. This would only affect normal windows and not PB mode windows as those aren't included. *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Multiple_profile_files_created

Question owner

jscher2000 said

Do all links do this, or only particular links/particular sites? It's definitely not typical for sites to user code that strips features from windows.

I tried clicking links from various sources (webpages, e-mails) but they all open like I describe, so it doesn't seem to be sites' user code because this never happened before the Firefox update.

''jscher2000 [[#answer-729589|said]]'' <blockquote> Do all links do this, or only particular links/particular sites? It's definitely not typical for sites to user code that strips features from windows. </blockquote> I tried clicking links from various sources (webpages, e-mails) but they all open like I describe, so it doesn't seem to be sites' user code because this never happened before the Firefox update.

Question owner

cor-el said

If you are in a pop-up window then you get a read-only location bar and some toolbar can be hidden. It is possible that you only have pop-up type windows open when you aren't able to open a bookmark because this bookmark would have to be open in a normal window. Does Ctrl+N work in this case to open a new window? PB mode or normal shouldn't make a difference for opening a link. You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data. This would only affect normal windows and not PB mode windows as those aren't included.

Crtl+N does work: It opens a normal browser window with menu bar and scroll bars (for pages taller than screen height).

My issue is for browser windows in private mode. Normal mode works fine.

I can't open bookmarks if I right-click on them to show the various options (Open, open in new tab, open in new window...) while in private mode.

''cor-el [[#answer-729594|said]]'' <blockquote> If you are in a pop-up window then you get a read-only location bar and some toolbar can be hidden. It is possible that you only have pop-up type windows open when you aren't able to open a bookmark because this bookmark would have to be open in a normal window. Does Ctrl+N work in this case to open a new window? PB mode or normal shouldn't make a difference for opening a link. You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data. This would only affect normal windows and not PB mode windows as those aren't included. *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Multiple_profile_files_created </blockquote> Crtl+N does work: It opens a normal browser window with menu bar and scroll bars (for pages taller than screen height). My issue is for browser windows in private mode. Normal mode works fine. I can't open bookmarks if I right-click on them to show the various options (Open, open in new tab, open in new window...) while in private mode.
finitarry 251 solutions 3421 answers

Chosen Solution

My suggestions for settings were meant to be carried out in about:config. Type that into the address bar, press the return key, then change those settings. That will affect popup windows. Does it also affect the private windows?

My suggestions for settings were meant to be carried out in about:config. Type that into the address bar, press the return key, then change those settings. That will affect popup windows. Does it also affect the private windows?
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Helpful Reply

Based on another thread where the user tested a bunch of things, there appears to be a bug in Firefox 38.0.1 involving this set of circumstances:

(1) Tabbed browsing turned off (2) Private window (3) Link with target="_blank" (not a scripted link)

The new window opens without menus, toolbar, scroll bars, etc.

Currently known workarounds:

(1) Use tabbed browsing (2) Shift+click links to open in a new window with the standard features

Based on another thread where the user tested a bunch of things, there appears to be a bug in Firefox 38.0.1 involving this set of circumstances: (1) Tabbed browsing turned off (2) Private window (3) Link with target="_blank" (not a scripted link) The new window opens without menus, toolbar, scroll bars, etc. Currently known workarounds: (1) Use tabbed browsing (2) Shift+click links to open in a new window with the standard features

Question owner

finitarry said

My suggestions for settings were meant to be carried out in about:config. Type that into the address bar, press the return key, then change those settings. That will affect popup windows. Does it also affect the private windows?

HEY, it works now!!! After at least 24 hours with clearing all memory/cache/etc., shutting down, then restarting, it works!

I don't know if those commands helped with the grayed-out options for right-clicking on bookmarks, but they are not grayed-out anymore.

The only "issue" (and it's a very minor one) is that the new window opens about 1/4 the size of a maximized window. So I have to maximize it manually.

MAHALO, MAHALO, MAHALO! (I'm in Hawaii)

I hope both issues don't change back...

''finitarry [[#answer-729958|said]]'' <blockquote> My suggestions for settings were meant to be carried out in about:config. Type that into the address bar, press the return key, then change those settings. That will affect popup windows. Does it also affect the private windows? </blockquote> '''HEY, it works now!!!''' After at least 24 hours with clearing all memory/cache/etc., shutting down, then restarting, it works! I don't know if those commands helped with the grayed-out options for right-clicking on bookmarks, but they are not grayed-out anymore. The only "issue" (and it's a very minor one) is that the new window opens about 1/4 the size of a maximized window. So I have to maximize it manually. '''MAHALO, MAHALO, MAHALO!''' (I'm in Hawaii) ''I hope both issues don't change back...''