Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website showing as 'Connection Partially Encryted' and we cannot see why

  • 13 replies
  • 2 have this problem
  • 28 views
  • Last reply by cor-el

more options

We have recently updated our SSL encryption cyphers and we are currently in the process of testing our website. One of the pages instead of displaying the padlock icon to show it is secure, displays an exclamation mark and when clicking this tells us that the connection is only partially encrypted. The issue is as far as we can see there is no reason for it to think it is only partially encrypted as everything on the webpage is running under SSL - the other point to mention is we have one machine running the same version of Firefox (37.0.2) which displays the padlock ok so I'm at a loss to explain why this issue is occurring on the other two machines.

Are you able to look into why this would be occurring as we cannot see the element causing the 'partially encrypted' message. I can provide further details as to the specific web page if required.

We have recently updated our SSL encryption cyphers and we are currently in the process of testing our website. One of the pages instead of displaying the padlock icon to show it is secure, displays an exclamation mark and when clicking this tells us that the connection is only partially encrypted. The issue is as far as we can see there is no reason for it to think it is only partially encrypted as everything on the webpage is running under SSL - the other point to mention is we have one machine running the same version of Firefox (37.0.2) which displays the padlock ok so I'm at a loss to explain why this issue is occurring on the other two machines. Are you able to look into why this would be occurring as we cannot see the element causing the 'partially encrypted' message. I can provide further details as to the specific web page if required.

All Replies (13)

more options

URL of your website?

more options
more options

I've installed the Firebug add-on as well but this also says all the requests are being made via https.

more options

You can use Firefox's browser console to watch for mixed content warnings. This should identify the URL of the problem content if it is a valid notification. You can launch it using either:

  • Ctrl+Shift+j
  • menu button > Developer > Browser Console

Type mix in the search box at the upper left right and the filtered view should collect any mixed content warnings.

However... Sometimes you can get false mixed content detection when Firefox redisplays a page from the fast back-forward cache. As far as I know, there isn't a server-side fix for this that doesn't involve defeating caching (See: Using Firefox 1.5 caching). You can test for this problem by changing a hidden preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and edit its value to 0 (that's a zero). (Please don't change any other sessionstore/sessionhistory settings.)

You may need to reload the media using Ctrl+Shift+r to bypass cache once and then you can test forward-back again.

Threads related to this hypothesis:

I don't know whether this has been entered into the bug tracking system.

Modified by jscher2000 - Support Volunteer

more options

Thanks for your response. The browser console doesn't show any mixed content - I have amended the session history preference but I still get an exclamation mark on the page https://test.websure.com/WebX/MortonMichel/page.aspx?pageno=4&scid=15092&id=1720af8f-4135-4861-92a1-0b52665acc46

more options

I should mention that I did not see a gray exclamation triangle visiting that page.

In case this was an issue with a "weak" cipher or obsolete protocol that I somehow configured around, I checked using https://www.ssllabs.com/ssltest/ and the site passes with flying colors.

If this can't be replicated on other systems, you may want to look into whether an add-on or AutoConfiguration file might be inserting insecure content into the page after load on your Firefox.

As a starting point, you could test in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Do you get a lock?

more options

Nope, restarted Firefox in safe mode and still get the exclamation mark...

more options

Could you try:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean -- and do not contain alien code files. As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

Note: 38.0 is known to have a problem with some Nvidia drivers, so if you find it crashing at startup, then you can undo this procedure by renaming folders and get an older version from the link here: Install an older version of Firefox.

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

Not much. I've followed that but I'm still getting the exclamation mark on that page both opening normally and in safe mode...

more options

Does it make any difference if you either

  • test in a private window (Ctrl+Shift+p), or
  • clear the cache completely?

To clear cache:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

more options

Unfortunately no, I've tried both but in both cases I still see the exclamation mark...

more options

My only other theories would be a proxy or malware.

more options

Do you see any warnings in the Web Console (Firefox/Tools > Web Developer)? You can also check the Net log.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Modified by cor-el