X
Tap here to go to the mobile version of the site.

Support Forum

Firefox error when I manually close the probram

Posted

Constantly get an error box when I press the red x to quit Firefox. Very aggravating.

Box says that that Firefox crashed. I did not. I shut it down. Box wants me to send error report. I did that a zillion times! I have no special settings for history or stuff like that. This all started with the update to 37.0. Updates 37.1 and 37.2 did not fix this issue either. My system is 64bit windows 8.1. This issue also happening on my laptop. That is windows 7, 32 bit machine. I did a refresh to my Firefox but that did not solve the problem either.

Help!

Constantly get an error box when I press the red x to quit Firefox. Very aggravating. Box says that that Firefox crashed. I did not. I shut it down. Box wants me to send error report. I did that a zillion times! I have no special settings for history or stuff like that. This all started with the update to 37.0. Updates 37.1 and 37.2 did not fix this issue either. My system is 64bit windows 8.1. This issue also happening on my laptop. That is windows 7, 32 bit machine. I did a refresh to my Firefox but that did not solve the problem either. Help!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • GEPlugin
  • Google Update
  • Logitech Harmony Remote Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Shockwave Flash 17.0 r0
  • 5.1.31211.0
  • WildTangent Games App V2 Presence Detector

Application

  • Firefox 37.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.2/WINNT/en-US/

Extensions

  • Norton Toolbar 2014.7.12.7 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Skype Click to Call 7.3.16540.9015 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7570
  • adapterDescription2:
  • adapterDeviceID: 0x675d
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17415
  • driverDate: 8-30-2013
  • driverDate2:
  • driverVersion: 13.152.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7570 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Abhishek Singh Kushwah 3 solutions 36 answers

Post the crash report by typing about:crashes in Location bar and let us examine the problem.

Post the crash report by typing about:crashes in Location bar and let us examine the problem.

Question owner

These are some of my crash reports: bp-50c53dc5-112b-4b04-8c38-dd7482150510 5/10/2015 8:13 AM bp-73e7ba1c-7e49-4e89-8fe6-a14f22150423 4/23/2015 7:24 PM bp-cc4ac03b-37d8-418a-9fe8-5630e2150422 4/22/2015 6:41 AM bp-4357b2b3-cbe4-4a0c-b055-727222150420 4/20/2015 5:08 PM bp-99415684-5763-4591-9565-9fdff2150418 4/18/2015 4:38 PM bp-fcd9d459-3bb8-45df-be4c-1c1c82150417 4/17/2015 4:41 PM bp-f8c00a94-dbbb-46e5-a465-1ad3c2150416 4/16/2015 4:45 PM bp-8b103a9f-4b99-4b60-ba68-77e2e2150416 4/16/2015 4:21 PM bp-e6b6e4e6-766e-43ec-a0ba-f2a112150415 4/15/2015 6:43 AM bp-e5019400-9248-4338-9bcd-6f7002150413 4/13/2015 7:09 PM bp-28475845-fd72-4aec-ae22-5c25f2150411 4/11/2015 2:47 PM bp-88441201-9ae7-4d3d-970e-4bd172150410 4/10/2015 6:44 PM bp-7fd12722-2938-49d5-b38f-e4d182150410 4/10/2015 6:22 PM

I hope this helps you find out what is wrong. Thank you for your help.

These are some of my crash reports: bp-50c53dc5-112b-4b04-8c38-dd7482150510 5/10/2015 8:13 AM bp-73e7ba1c-7e49-4e89-8fe6-a14f22150423 4/23/2015 7:24 PM bp-cc4ac03b-37d8-418a-9fe8-5630e2150422 4/22/2015 6:41 AM bp-4357b2b3-cbe4-4a0c-b055-727222150420 4/20/2015 5:08 PM bp-99415684-5763-4591-9565-9fdff2150418 4/18/2015 4:38 PM bp-fcd9d459-3bb8-45df-be4c-1c1c82150417 4/17/2015 4:41 PM bp-f8c00a94-dbbb-46e5-a465-1ad3c2150416 4/16/2015 4:45 PM bp-8b103a9f-4b99-4b60-ba68-77e2e2150416 4/16/2015 4:21 PM bp-e6b6e4e6-766e-43ec-a0ba-f2a112150415 4/15/2015 6:43 AM bp-e5019400-9248-4338-9bcd-6f7002150413 4/13/2015 7:09 PM bp-28475845-fd72-4aec-ae22-5c25f2150411 4/11/2015 2:47 PM bp-88441201-9ae7-4d3d-970e-4bd172150410 4/10/2015 6:44 PM bp-7fd12722-2938-49d5-b38f-e4d182150410 4/10/2015 6:22 PM I hope this helps you find out what is wrong. Thank you for your help.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

This could be a problem with Norton software.

You can try to disable all Norton extensions in Firefox.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

This could be a problem with Norton software. You can try to disable all Norton extensions in Firefox. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/
FredMcD
  • Top 10 Contributor
4260 solutions 59646 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable the Norton Toolbar.


https://support.mozilla.org/en-US/questions/1048938 Firefox takes two minutes plus to load, apparent clash with Norton Internet Security

Norton showed where to exclude things from Autoprotect Open Norton Administrative Settings. Under Performance Monitoring, find Program Exclusions. To its far right, press the Configure + link.

You will have to add each program one at a time from the Mozilla Firefox and Mozilla Maintenance Service<Windows> folders..

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable the Norton Toolbar. -------------------------------- https://support.mozilla.org/en-US/questions/1048938 Firefox takes two minutes plus to load, apparent clash with Norton Internet Security Norton showed where to exclude things from Autoprotect Open '''Norton Administrative Settings.''' Under '''Performance Monitoring, ''' find '''Program Exclusions. ''' To its far right, press the '''Configure +''' link. You will have to add each program one at a time from the '''Mozilla Firefox''' and '''Mozilla Maintenance Service'''<Windows> folders..

Question owner

Tried both suggestions. Neither one fixed the issue.

Still crashes... bp-c7ebd2e0-4252-40ec-9950-870082150511 5/10/2015 10:10 PM bp-7b698e4f-69d0-48d4-85a0-a743c2150511 5/10/2015 9:50 PM bp-2333913a-8e5e-4fd8-9293-7262e2150510 5/10/2015 4:44 PM bp-876e95eb-dc14-497e-90bc-e47062150510 5/10/2015 3:58 PM bp-50c53dc5-112b-4b04-8c38-dd7482150510 5/10/2015 8:13 AM

Tried both suggestions. Neither one fixed the issue. Still crashes... bp-c7ebd2e0-4252-40ec-9950-870082150511 5/10/2015 10:10 PM bp-7b698e4f-69d0-48d4-85a0-a743c2150511 5/10/2015 9:50 PM bp-2333913a-8e5e-4fd8-9293-7262e2150510 5/10/2015 4:44 PM bp-876e95eb-dc14-497e-90bc-e47062150510 5/10/2015 3:58 PM bp-50c53dc5-112b-4b04-8c38-dd7482150510 5/10/2015 8:13 AM
FredMcD
  • Top 10 Contributor
4260 solutions 59646 answers

winmm.dll = Windows Multimedia

mswsock.dll = Microsoft

gdi32.dll file = Windows GDI (Graphics Device Interface)

combase.dll = Microsoft

atiuxpag.dll = Advanced Micro Devices

atidxx32.dll = Advanced Micro Devices = Radeon DirectX

IPSEng32.dll = Symantec Intrusion Detection

IPSLdr32.dll = Symantec Intrusion Detection

===============

One report also said; Signature shutdownhang


Perform a System File Check to fix corrupted system files http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

winmm.dll = Windows Multimedia mswsock.dll = Microsoft gdi32.dll file = Windows GDI (Graphics Device Interface) combase.dll = Microsoft atiuxpag.dll = Advanced Micro Devices atidxx32.dll = Advanced Micro Devices = Radeon DirectX IPSEng32.dll = Symantec Intrusion Detection IPSLdr32.dll = Symantec Intrusion Detection =========================== One report also said; Signature shutdownhang ---------------------------------- Perform a System File Check to fix corrupted system files http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

Can you confirm what you tried so far?


Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Can you confirm what you tried so far? ---- Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware
jscher2000
  • Top 10 Contributor
8775 solutions 71729 answers

I think Firefox 37 is the first version to detect that Firefox is unable to shut down correctly -- that there was a hang during shutdown -- and record that as a crash. So the underlying problem of unexpectedly slow shutdown might have been present before and just not brought to your attention. Or it could be a new problem.

Some changes were made in Firefox 38 (due out this week) that should reduce the problem of shutdown hangs. Hopefully that will help.

As a workaround for now, what about keeping a Firefox window opened and minimized at all times instead of shutting down the browser so frequently?

Also, I don't know whether it's a coincidence, but another user whose similar crash reports I just read also runs Norton security software.

I think Firefox 37 is the first version to detect that Firefox is unable to shut down correctly -- that there was a hang during shutdown -- and record that as a crash. So the underlying problem of unexpectedly slow shutdown might have been present before and just not brought to your attention. Or it could be a new problem. Some changes were made in Firefox 38 (due out this week) that should reduce the problem of shutdown hangs. Hopefully that will help. As a workaround for now, what about keeping a Firefox window opened and minimized at all times instead of shutting down the browser so frequently? Also, I don't know whether it's a coincidence, but another user whose similar crash reports I just read also runs Norton security software.

Question owner

I am currently testing a variation of a suggestion by FredMcD that Norton 360 is the root cause of my problem. I disabled the toolbar before, but now I also turned off the NORTON PASSWORD VAULT. That SEEMS to have cured the issue. I am now shutting down without those annoying crash reports... so far. I have only tested this fix for a day so I am not ready to declare victory yet. I am thinking that the Norton Password Vault was remaining open and hanging up the orderly shutdown of Firefox... at least from Firefox's viewpoint.

Thank you all for your kind help with my problem. I hope this really has fixed it. I was having some funky experiences with the NORTON PASSWORD VAULT not working properly with a very few websites. I was going to dump it anyway and go back to the Firefox built-in password manager.

I am currently testing a variation of a suggestion by FredMcD that Norton 360 is the root cause of my problem. I disabled the toolbar before, but now I also turned off the NORTON PASSWORD VAULT. That SEEMS to have cured the issue. I am now shutting down without those annoying crash reports... so far. I have only tested this fix for a day so I am not ready to declare victory yet. I am thinking that the Norton Password Vault was remaining open and hanging up the orderly shutdown of Firefox... at least from Firefox's viewpoint. Thank you all for your kind help with my problem. I hope this really has fixed it. I was having some funky experiences with the NORTON PASSWORD VAULT not working properly with a very few websites. I was going to dump it anyway and go back to the Firefox built-in password manager.
FredMcD
  • Top 10 Contributor
4260 solutions 59646 answers

FredMcD said

Norton showed where to exclude things from Autoprotect

Have you checked this out?

''FredMcD [[#answer-726765|said]]'' <blockquote> Norton showed where to exclude things from Autoprotect </blockquote> Have you checked this out?