Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not allow cookies?

  • 2 replies
  • 2 have this problem
  • 25 views
  • Last reply by cor-el

more options

I'm really not sure what's going on with my Firefox. I'm trying to use Google Scholar and it keeps telling me that I need to enable cookies to use it properly (add libraries, change settings etc).

By default, my cookie settings are: Use custom settings for history > Accept cookies from sites > Accept third-party cookies (From visited), Keep until (I close Firefox). And I've never had a problem with that before. But no matter what I do now, I can't get it to work...

THINGS I'VE TRIED (in no particular order): - Changing cookie preferences to: Use custom settings for history > Accept cookies from sites > Accept third-party cookies (Always), Keep until (They expire). - Clearing all cookies and cache (via clearing history) - Clearing cookies individually: Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" - Clearing the Cache: Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" - Resetting Firefox - Deleting cookies.sqlite from my profile - Clearing history for that site: https://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them#w_clear-history-for-that-site

I'm at a complete loss. Despite all of this it STILL tells me I need to enable my cookies...Is there anything that anyone can suggest to me to fix this??

All Replies (2)

more options

Sorry the formatting came out funny...I've never posted here before

more options

You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

You can try to clear the Site Preferences or possibly rename or delete the permissions.sqlite file.

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

You can also try to access the website in New Private Window.

You can check if DOM Storage is enabled.

Are there any specific errors about this website in the Browser Console (Firefox/Tools > Web Developer)?