X
Tap here to go to the mobile version of the site.

Support Forum

Hi, I I receive a "Secure Connection Failed" warning when trying to access a site that I know is trust worthy. The website is https://www.planet.snb.ca. Thanks

Posted

I I receive a "Secure Connection Failed" warning when trying to access a site that I know is trust worthy. The website is https://www.planet.snb.ca.

the error is as follows: "The connection to www.planet.snb.ca was interrupted while the page was loading.

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem."
I I receive a "Secure Connection Failed" warning when trying to access a site that I know is trust worthy. The website is https://www.planet.snb.ca. the error is as follows: "The connection to www.planet.snb.ca was interrupted while the page was loading. The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem."

Chosen solution

It works for me if I add this domain to the security.tls.insecure_fallback_hosts pref and the www.planet.snb.ca domain. You may have to add more domains if you keep getting an error message when opening pages to different domains.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Citrix Online App Detector Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • BlackBerry WebSL Browser Plug-In
  • Shockwave Flash 17.0 r0
  • 5.1.31211.0

Application

  • Firefox 37.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Skype Click to Call 6.11.0.13307 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI FirePro V4800 (FireGL V)
  • adapterDescription2:
  • adapterDeviceID: 0x68c8
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 240a1002
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 100 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300 ]
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 11-20-2012
  • driverDate2:
  • driverVersion: 9.3.3.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI FirePro V4800 (FireGL V) Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Tyler Downer
  • Top 10 Contributor
  • Moderator
1469 solutions 10110 answers

This is because this website uses old and insecure protocols to secure itself. You can see a full report at https://www.ssllabs.com/ssltest/analyze.html?d=planet.snb.ca

Please contact the website owners and send them a copy of the above report. They then need to do some serious work on updating their site's security.

This is because this website uses old and insecure protocols to secure itself. You can see a full report at https://www.ssllabs.com/ssltest/analyze.html?d=planet.snb.ca Please contact the website owners and send them a copy of the above report. They then need to do some serious work on updating their site's security.

Question owner

The site is owned by the Province of New Brunswick, I can access this from IE with no trouble. Tried adding the site to exceptions but no luck. Something has changed in Firefox, as it worked a while ago. Is there anything I can do on my end? I understand the risk, as there will be none with this site.

The site is owned by the Province of New Brunswick, I can access this from IE with no trouble. Tried adding the site to exceptions but no luck. Something has changed in Firefox, as it worked a while ago. Is there anything I can do on my end? I understand the risk, as there will be none with this site.
cor-el
  • Top 10 Contributor
  • Moderator
16610 solutions 150021 answers

The website may try to fallback to TLS 1.0 in a way that is no longer allowed in current releases or may be using a deprecated cipher suite.

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the full domain (www.planet.snb.ca) to the value of this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). You should only see domains separated by a comma in the value column.

If this helps then you can contact this website and ask them to look into this.


The website may try to fallback to TLS 1.0 in a way that is no longer allowed in current releases or may be using a deprecated cipher suite. You can open the <b>about:config</b> page via the location/address bar and use its search bar to locate this pref: *security.tls.insecure_fallback_hosts You can double-click the line to modify the pref and add the full domain (www.planet.snb.ca) to the value of this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). You should only see domains separated by a comma in the value column. If this helps then you can contact this website and ask them to look into this. ---- *https://developer.mozilla.org/en-US/Firefox/Releases/36/Site_Compatibility#Security *https://developer.mozilla.org/en-US/Firefox/Releases/37/Site_Compatibility#Security

Question owner

Thank you but I have already tried that, with no luck.

Thank you but I have already tried that, with no luck.
Tyler Downer
  • Top 10 Contributor
  • Moderator
1469 solutions 10110 answers

This website only supports TLS 1.0, which is a VERY old technology. It needs to support TLS 1.2. All browsers will eventually be disabling support for TLS 1.0, and even though you trust the site your information can be intercepted by malicious third-parties. You need to complain to the website and tell them to update their security.

This website only supports TLS 1.0, which is a VERY old technology. It needs to support TLS 1.2. All browsers will eventually be disabling support for TLS 1.0, and even though you trust the site your information can be intercepted by malicious third-parties. You need to complain to the website and tell them to update their security.

Helpful Reply

Thanks Tyler but you are talking to a guy that still has a computer in the office running Windows 2000! The province is always behind and it will take forever to get them to change this. Is there any setting I can perform in my Firefox browser(37.0.2) to allow me to access this site. I need this for my work. If not I will have to resort to using IE just for this site, which I dislike. thanks again, Brent

Thanks Tyler but you are talking to a guy that still has a computer in the office running Windows 2000! The province is always behind and it will take forever to get them to change this. Is there any setting I can perform in my Firefox browser(37.0.2) to allow me to access this site. I need this for my work. If not I will have to resort to using IE just for this site, which I dislike. thanks again, Brent
Tyler Downer
  • Top 10 Contributor
  • Moderator
1469 solutions 10110 answers

There is no safe way to enable Access to this site. Use IE (until this is disabled in IE, which it will be soon) and complain to the site to ask them to update. All browsers will eventually stop working on this site. The site needs to update, not you.

There is no safe way to enable Access to this site. Use IE (until this is disabled in IE, which it will be soon) and complain to the site to ask them to update. All browsers will eventually stop working on this site. The site needs to update, not you.
cor-el
  • Top 10 Contributor
  • Moderator
16610 solutions 150021 answers

Chosen Solution

It works for me if I add this domain to the security.tls.insecure_fallback_hosts pref and the www.planet.snb.ca domain. You may have to add more domains if you keep getting an error message when opening pages to different domains.

It works for me if I add this domain to the security.tls.insecure_fallback_hosts pref and the www.planet.snb.ca domain. You may have to add more domains if you keep getting an error message when opening pages to different domains.

Question owner

Thanks Cor-el that worked! I was using the full name with "https://" as the prefix and that is why it was not working. Take Care

Thanks Cor-el that worked! I was using the full name with "https://" as the prefix and that is why it was not working. Take Care

Modified by jedeng

cschiffer 0 solutions 1 answers

Helpful Reply

I cannot understand any of this, I even tried to sign up for an account with Mozilla and I suddenly got this message that the site was no secure. I'm sick of this as I'll be in the middle of something and suddenly I'm out and can't get back in. Perhaps I need a different browser or someone who can speak to me in a lingo I understand.

I cannot understand any of this, I even tried to sign up for an account with Mozilla and I suddenly got this message that the site was no secure. I'm sick of this as I'll be in the middle of something and suddenly I'm out and can't get back in. Perhaps I need a different browser or someone who can speak to me in a lingo I understand.
cor-el
  • Top 10 Contributor
  • Moderator
16610 solutions 150021 answers

Hi cschiffer

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"
  • Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate"
  • Click the "View" button and inspect the certificate and check who is the issuer.

You can see more details like the intermediate certificates that are used in the Details tab.

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field type/paste the URL of the website

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

Check who is the issuer of the certificate.

You can inspect more details like the certificate chain in Details tab of the Certificate Viewer.

Can you attach a screenshot of the Certificate Viewer window?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
Hi cschiffer You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar. *https://support.mozilla.org/kb/Secure+Connection+Failed You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates. *Click the link at the bottom of the error page: "I Understand the Risks" *Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate" *Click the "View" button and inspect the certificate and check who is the issuer. You can see more details like the intermediate certificates that are used in the Details tab. If you can't inspect the certificate via "I Understand the Risks" then try this: Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field type/paste the URL of the website *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer Check who is the issuer of the certificate. You can inspect more details like the certificate chain in Details tab of the Certificate Viewer. Can you attach a screenshot of the Certificate Viewer window? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB