X
Tap here to go to the mobile version of the site.

Support Forum

Firefox slow to open links from Thunderbird and elsewhere

Posted

With versions of Firefox later than 34 (or possibly 35 - not sure) attempting to open a page link from an email in Thunderbird and occasionally other sources, results in Firefox 36 and 37 hanging for up to a minute before opening the new tab and page, so I am forced to use 34 to retain smooth operation.

I have not included the Troubleshooting Information as the problem does not relate to the Firefox version currently in use.

Edit: I asked the question originally in this thread which will show some of the things which were suggested and tried:

http://forums.digitalspy.co.uk/showthread.php?t=2056047

With versions of Firefox later than 34 (or possibly 35 - not sure) attempting to open a page link from an email in Thunderbird and occasionally other sources, results in Firefox 36 and 37 hanging for up to a minute before opening the new tab and page, so I am forced to use 34 to retain smooth operation. I have not included the Troubleshooting Information as the problem does not relate to the Firefox version currently in use. Edit: I asked the question originally in this thread which will show some of the things which were suggested and tried: http://forums.digitalspy.co.uk/showthread.php?t=2056047

Modified by albertd

Chosen solution

It's a start. Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

If it is;

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • np-mswmp
  • Motive Plugin for Mozilla Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • Virtual Earth 3D 4.00090316005 plugin for Mozilla
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

More Information

FredMcD
  • Top 10 Contributor
4308 solutions 60491 answers

Helpful Reply

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.


Open the options on all of your protection programs, and tell them to leave the browses alone. For anti-virus, look under; Autoprotect or Programs Monitor

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' ----------------------- Open the options on all of your protection programs, and tell them to leave the browses alone. For anti-virus, look under; Autoprotect or Programs Monitor

Question owner

Thank you Fred. I am afraid you will have to explain that in more detail. The only toolbar I have in Firefox is the standard Bookmarks toolbar. As for the antivirus aspect, I have no idea what you mean - where should I look for what you are talking about. I am using Norton 360.

Thank you Fred. I am afraid you will have to explain that in more detail. The only toolbar I have in Firefox is the standard Bookmarks toolbar. As for the antivirus aspect, I have no idea what you mean - where should I look for what you are talking about. I am using Norton 360.
FredMcD
  • Top 10 Contributor
4308 solutions 60491 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Look for the Norton add-on and disable it.

Then restart Firefox. Is it any better?

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Look for the Norton add-on and disable it. Then restart Firefox. Is it any better?

Question owner

Thank you again Fred.

I have updated back to 37.0.2 and the problem is still happening.

I have checked the Extensions as you suggested and the Norton toolbar addon was already disabled.

Thank you again Fred. I have updated back to 37.0.2 and the problem is still happening. I have checked the Extensions as you suggested and the Norton toolbar addon was already disabled.
FredMcD
  • Top 10 Contributor
4308 solutions 60491 answers

Chosen Solution

It's a start. Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

If it is;

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

It's a start. Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? If it is; Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

Thanks again Fred. Ouch, that looks horribly techy for an old man (I'm 71) to tackle, especially the Windows Safe Mode bit. Anyway, give me quite a bit of time and I will see if I can fathom out what you mean.

Thanks again Fred. Ouch, that looks horribly techy for an old man (I'm 71) to tackle, especially the Windows Safe Mode bit. Anyway, give me quite a bit of time and I will see if I can fathom out what you mean.

Question owner

Hi Fred.

I have tried Firefox in Safe Mode and the problem went away. More interesting, however, was that when I closed Firefox and reopened it normally, the problem was still gone.

Does this tell you anything of value?

It will be interesting what happens in the next few days.

Hi Fred. I have tried Firefox in Safe Mode and the problem went away. More interesting, however, was that when I closed Firefox and reopened it normally, the problem was still gone. Does this tell you anything of value? It will be interesting what happens in the next few days.

Modified by albertd

FredMcD
  • Top 10 Contributor
4308 solutions 60491 answers

It could be a file somewhere was corrupted, and somehow was replaced. If it returns in the next few days, come back here.

If it should return after that, create a new question, and include the link for this post.

Good luck. Safe Surfing.

It could be a file somewhere was corrupted, and somehow was replaced. If it returns in the next few days, come back here. If it should return after that, create a new question, and include the link for this post. Good luck. Safe Surfing.

Question owner

Thanks Fred. All noted.

Thanks Fred. All noted.