X
Tap here to go to the mobile version of the site.

Support Forum

Cache always in use, very hard for CSS development

Posted

Hello,

Very recently the way CSS changes are displayed changed : now I need to use "Command + Shift + R" EVERY TIME... in the past just reloading the page would show the modifications.

I've also detected that ClearCache extension doesn't work anymore, neither does CacheToggle. I suspect something has been changed in the way the cache is handled.

Any idea ? Using Command + Shift + R all the time just to see a CSS modification is a real pain in the butt and if every extension allowing me to disable caching don't work anymore I don't see any other solution.

Thanks,

Cheers,

PS : using FF 37.0.1 on OSX Yosemite

Hello, Very recently the way CSS changes are displayed changed : now I need to use "Command + Shift + R" EVERY TIME... in the past just reloading the page would show the modifications. I've also detected that ClearCache extension doesn't work anymore, neither does CacheToggle. I suspect something has been changed in the way the cache is handled. Any idea ? Using Command + Shift + R all the time just to see a CSS modification is a real pain in the butt and if every extension allowing me to disable caching don't work anymore I don't see any other solution. Thanks, Cheers, PS : using FF 37.0.1 on OSX Yosemite

Chosen solution

OK SOLVED.

The culprit was Better Wordpress Minify plugin... which was still activated.

Somehow the changes I made weren't "compiled" by the plugin but forcing the refresh with Command + Shift + R solved the issue...

So it's solved I just need to disable this plugin during development.

Cheers,

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Fournit des informations sur le navigateur web par défaut
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Ce module vous permet de visualiser le contenu multimédia de nombreux sites web. Pour en savoir plus, consultez le site QuickTime.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 17.0 r0

Application

  • Firefox 37.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.1/Darwin/fr/

Extensions

  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • BuiltWith 1.9.6 (gary@builtwith.com)
  • CacheToggle 0.6 (cachetoggle@pau.santesmasses.net)
  • ColorZilla 2.8 ({6AC85730-7D0F-4de0-B3FA-21142DD85326})
  • CoLT 2.6.5 ({e6c4c3ef-3d4d-42d6-8283-8da73c53a283})
  • DownThemAll! 2.0.18 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Firebug 2.0.9 (firebug@software.joehewitt.com)
  • Firepicker 1.4.3 (firepicker@thedarkone)
  • Ghostery 5.4.3 (firefox@ghostery.com)
  • LastPass 3.1.1 (support@lastpass.com)
  • MeasureIt 0.4.14 ({75CEEE46-9B64-46f8-94BF-54012DE155F0})
  • NoDoFollow 1.1 ({c2b1f3ae-5cd5-49b7-8a0c-2c3bcbbbb294})
  • RefControl 0.8.17 ({455D905A-D37C-4643-A9E2-F6FEFAA0424A})
  • Self-Destructing Cookies 0.4.7 (jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack)
  • SEO For Firefox 3.6.14 (seo4firefox@seobook.com)
  • Seo Toolbar 1.2.10 (seotoolbar@seobook.com)
  • ShowIP 2.7.7 ({3e9bb2a7-62ca-4efa-a4e6-f6f6168a652d})
  • Speed Dial 0.9.6.17 ({64161300-e22b-11db-8314-0800200c9a66})
  • Status-4-Evar 2015.02.06.23 (status4evar@caligonstudios.com)
  • User Agent Switcher 0.7.3 ({e968fc70-8f95-4ab9-9e79-304de2a71ee1})
  • Video Downloader professional 1.97.36 (ffext_basicvideoext@startpage24)
  • Web Developer 1.2.5 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Clear Cache 2.0.1 (clearcache@michel.de.almeida) (Inactive)
  • Flashblock 1.5.18 ({3d7eb24f-2740-49df-8937-200b1cc08f8a}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Chosen Solution

OK SOLVED.

The culprit was Better Wordpress Minify plugin... which was still activated.

Somehow the changes I made weren't "compiled" by the plugin but forcing the refresh with Command + Shift + R solved the issue...

So it's solved I just need to disable this plugin during development.

Cheers,

OK SOLVED. The culprit was Better Wordpress Minify plugin... which was still activated. Somehow the changes I made weren't "compiled" by the plugin but forcing the refresh with Command + Shift + R solved the issue... So it's solved I just need to disable this plugin during development. Cheers,