Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Internal websites are not opening

  • 3 replies
  • 2 have this problem
  • 20 views
  • Last reply by cor-el

more options

Hi, I have been using Firefox as my web browser. But now when I want to open certain sites in my companies intranet, I keep getting this error: "The page you are trying to view cannot be shown because the authenticity of the received data could not be verified."

I understand this is a feature to block unverified certificates, but I need an option to disable this for my companies internal websites.

Please tell me if there is a workaround

Hi, I have been using Firefox as my web browser. But now when I want to open certain sites in my companies intranet, I keep getting this error: "The page you are trying to view cannot be shown because the authenticity of the received data could not be verified." I understand this is a feature to block unverified certificates, but I need an option to disable this for my companies internal websites. Please tell me if there is a workaround

All Replies (3)

more options

The website may try to fallback to TLS 1.0 in a way that is no longer allowed in current releases or may be using a deprecated cipher suite.

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the domain to this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). You should only see domains separated by a comma in the value column.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


Modified by cor-el

more options

Well this helped for sites with a fixed url (like wwwin.xyz.com) but for urls which have a query string, I was not able figure out what needs to be added to the safe url list. Isn't there a way to disable this altogether?

more options

You need to add the part after https:// until the next slash (/) (i.e the full domain part). There should be no spaces and slashes in the value of the pref, only a comma to separate multiple entries.