Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I want to download an mp3 file, not play it. How do I do it?

  • 3 replies
  • 14 have this problem
  • 235 views
  • Last reply by jscher2000

more options

I'm trying to download a Sunday sermon on mp3 for my Mother. In IE, I always get the option to open or save the file. With Firefox, it always plays when I click on it. I tried to change the options in firefox, but mp3 is not on the list, and I don't know how to add it.

All Replies (3)

more options

Hello,

If you right click you should be able to choose save link as and the option to save as an mp3 should pop up.

Sir.Mayo

more options

I can right-click it, but then I have to go through the whole file structure to find the file to post it to. Plus, it's easy to forget. For years, I've been clicking the button that says "download", and a popup window with my default file location askes me where to save the file. The folder I want is usually directly under that folder, easy-peasy.

Isn't there some way to bring that behaviour back? Why have an option in the General tab that asks if I want to be asked where to save files, if it's not going to be looked at by whatever is doing the download function?

more options

My guess is that the site is not specially coding the file for download so Firefox goes ahead and loads it in a tab.

Some users facing this situation have completely turned off Firefox's ability to play MPEG media (MP3s, MP4s) without a plugin, which is a little drastic.

The following used to work, but when I try it today, it doesn't seem to work for me. Does it work for you?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media.p and pause while the list is filtered

(3) Double-click the media.play-stand-alone preference to switch it from true to false

I think you might need to exit Firefox and start it up again before that takes effect.