Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do you set a default home page for tabs

  • 7 replies
  • 1 has this problem
  • 32 views
  • Last reply by jscher2000

more options

Default home page setting is easy enough but when clicking the "+" to open a tab I want to set the page that it defauts to. You would think that it would do the default home page but it doesn't and I cant find where to set it.

Chosen solution

Hi, the default New Tab page is about:newtab (tiles/thumbnail images) which can be set or changed like this: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.newtab.url and make sure 'Value' is set to about:newtab (right click to change it if necessary, taking care not to alter anything else).

If you want to have a different New Tab page you can enter the appropriate URL in place of about:newtab (The Firefox Start Page for example is about:home).

Hope that helps.

Read this answer in context 👍 5

All Replies (7)

more options

Chosen Solution

Hi, the default New Tab page is about:newtab (tiles/thumbnail images) which can be set or changed like this: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.newtab.url and make sure 'Value' is set to about:newtab (right click to change it if necessary, taking care not to alter anything else).

If you want to have a different New Tab page you can enter the appropriate URL in place of about:newtab (The Firefox Start Page for example is about:home).

Hope that helps.

more options

See also this article about the New Tab page (about:newtab):

more options

cybrmstr said

Default home page setting is easy enough but when clicking the "+" to open a tab I want to set the page that it defauts to. You would think that it would do the default home page but it doesn't and I cant find where to set it.

I thought this would fix the problem but alas this can't be changed it always resets to what its set to

more options

Do you mean that the value of the browser.newtab.url pref changes?

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Modified by cor-el

more options

No what I'm telling you is it is set to some website www.trovi.com/ a bunch of other stuff......anything I do to change it doesn't save....it goes back to the trovi website.....I can't set it to ANYTHING not even about:home....nothing at all....no edits can be made to it that save.....I can't be any more clearer then that.

more options
more options

Troubleshooting tips on the browser.newtab.url preference:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save. Also beware of features in utility programs like Advanced SystemCare that roll back settings changes between sessions.


If bad add-ons do not have a Remove button or keep coming back, here's my suggested procedure for tracking down and cleaning them up. I know this seems long, but it's not that bad.

(1) Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

(2) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

(3) You can search for remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

Success?