Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

InstantFox throwing away a letter

  • 3 replies
  • 2 have this problem
  • 24 views
  • Last reply by cor-el

more options

Hi there!

So InstantFox is not working as expected. For example, when I type "w california" in the url bar, hit enter, http://en.wikipedia.org/wiki/Californi was reached - the last letter "a" was automatically dropped. One more example, type in the url bar "y apple" and https://www.youtube.com/results?search_query=appl is reached - the last letter "e" got sabotaged. Damn it.

Ideas?

Thanks! Cavessson

All Replies (3)

more options

I see that in a couple reviews (March 28, March 5): https://addons.mozilla.org/firefox/addon/instantfox/reviews/

There is a bug report on file but I don't see any official progress on it: https://github.com/estivo/Instantfox/issues/103

Obviously it's irritating but you could double the last letter of your query...


Firefox doesn't show instant results based on the address bar, but it does have a search keyword feature. This allows you to assign a letter to a search engine in the same way that InstantFox seems to work.

I can't figure out the new place to add/edit search engine keywords, so you may have to use the old dialog. Copy the following and in a new tab paste it into the address bar and press Enter/Return:

chrome://browser/content/search/engineManager.xul

You'll see that when you select a search site, you can assign a "keyword" such as g for Google or w for Wikipedia.

To test the built-in feature, you'll need to disable InstantFox on the Add-ons page. Either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then you should be able to find InstantFox on the right.

Modified by jscher2000

more options

Thanks jscher2000 for the pointers. Think the issue is due to incompatibility with the updated Firefox. It used to work well.

Double the last letter is a wonderful workaround! Didn't think of dat : )

For a less geeky way to assign a keyword to a search engine: 1. Bookmark www.google.com 2. Press "Shift+Cmd+B" for Mac, or "Ctrl+Shift+Cmd" for PC to enter the bookmark page 3. Find at the bottom of the screen an arrow key, click 4. You'll find the keyword option

Modified by Cavesson

more options

You can add a keyword in "Options/Preferences > Search" (click in the keyword column area).