Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can you make Firefox stop asking me to make Yahoo my default search?

  • 4 replies
  • 1 has this problem
  • 4 views
  • Last reply by cor-el

more options

This is nothing new to you. I am repeatedly asked to make Yahoo my default search, and have repeatedly declined. I'm sure there's a programming problem, since I am also sure that you don't want to annoy me or any other users. So it'd be great if you fixed this. Thanks.

This is nothing new to you. I am repeatedly asked to make Yahoo my default search, and have repeatedly declined. I'm sure there's a programming problem, since I am also sure that you don't want to annoy me or any other users. So it'd be great if you fixed this. Thanks.

All Replies (4)

more options

I'm sorry you are having this trouble. I'd suggest you do the following:

Download the newest version of Firefox, 37 from www.getfirefox.com. Install it.

Then, set your default search engine to whatever you want. Use the Search bar in Firefox and manage search engines

If you still get prompted to set your search engine as yahoo, please let us know the exact message you see. Thanks!

more options

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

Hi. As you suggested, I updated Firefox and restarted, and set my search preferences, and had a few days of not being asked to make Yahoo my search engine, until today, when once again Firefox is informing me that Yahoo is the program's preferred search engine and asking if I'd like to make it my default. Thanks for any other suggestions for how to get Firefox to stop doing this.

more options

You can try to set this pref to false on the about:config page.

  • browser.search.geoSpecificDefaults

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.