Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

History Sidebar started showing up today. I cannot eliminate it

  • 2 replies
  • 2 have this problem
  • 1728 views
  • Last reply by decrepit

more options

Today, whenever I bring up Firefox as my home page, the history sidebar shows up. I can uncheck it, but the next time I load the home page it shows up. My privacy setting is to never retain the history. How can I keep from having to use the "x" or uncheck it to close it? As I said, this just started this afternoon.

Chosen solution

If you are running Firefox in automatic private browsing mode, it's possible that Firefox is not remembering the change of closing the sidebar.

Since opening the sidebar is not the default behavior, perhaps you could eliminate the problem by removing a settings file which stores window positions and other user interface data. If you want to try that, here's how you do it:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Does the sidebar stay closed?

Read this answer in context 👍 3

All Replies (2)

more options

Chosen Solution

If you are running Firefox in automatic private browsing mode, it's possible that Firefox is not remembering the change of closing the sidebar.

Since opening the sidebar is not the default behavior, perhaps you could eliminate the problem by removing a settings file which stores window positions and other user interface data. If you want to try that, here's how you do it:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Does the sidebar stay closed?

more options

Fantastic! Thanks for the help.