Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do ports remain open after closing Firefox?

  • 3 replies
  • 2 have this problem
  • Last reply by JohnCorliss

more options

I have noticed recently that several ports associated with Firefox remain open when the Firefox browser is closed. The number of open ports increases each time Firefox is opened and I have seen that the number of open ports has reached to more than 1,000 open ports at a time. The majority of the open ports are outbound TCP using port 443 and I also note a sustained increase in the network traffic after Firefox is closed.

I have observed ports opened by the Explorer browser and noted that all of the ports opened with Explorer close when the Explorer browser is closed. The Firefox ports remain open when the browser is closed.

Questions: - Should all open ports associated with an open Firefox browser close when the Firefox browser is closed? - Does Firefox have a setting that closes all open ports when the Firefox browser is closed? - Does XP have a setting that will close all open ports associated with Firefox when Firefox is closed? - Should I have security concerns about the accumulating open ports and increased network activity when using Firefox?


All Replies (3)

more options

Yes, I have this same problem. However, I'd like to point out that in order to avoid confusion, you should refer to Microsoft's browser as "Internet Explorer" rather than just "Explorer". Windows Explorer is a file manager and can easily be confused with Internet Explorer.

more options

Did you make sure that all Firefox instances are closed?

You can verify that in the Windows Task Manager. If there are any leftover Firefox or plugin-container processes left then kill them.

Use "3-bar" menu button > Exit (Power button) (Windows: File > Exit; Mac: Firefox > Quit Firefox; Linux: File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

In case you use "Clear history when Firefox closes" then try to disable this feature.

more options

Please see my post here:

Thanks for replying.