X
Tap here to go to the mobile version of the site.

Support Forum

Plug in Container and Flash Crashing Issue

Posted

Finally Flash started working .............partly.

Using Windows 8.1 Firefox 36.0.4

I say "Partly" because the Pages I use I have to refresh the page 3-7 before it catches and Flash decides to work.

So I did some working to see what and had my Windows Task Manager up and wondering why processes shuffled around when I reloaded page where flash crashed and failed to load as soon as page came up.

So i Noticed in the Task manager too a Windows Problem Reporting popped up when Flash Crashed (didn't load) So I said there must be a file of why it crashed. So I went to Start>Computer (Right Clicked) Manage > Opened Computer Management on left side clicked Event Viewer

I hope these screen captures can help to see why Flash is crashing.

I also made a Dump file plug-in container of and it is pretty Big 203,170 MB after i got flash to work by refreshing the page several times.

Finally Flash started working .............partly. Using Windows 8.1 Firefox 36.0.4 I say "Partly" because the Pages I use I have to refresh the page 3-7 before it catches and Flash decides to work. So I did some working to see what and had my Windows Task Manager up and wondering why processes shuffled around when I reloaded page where flash crashed and failed to load as soon as page came up. So i Noticed in the Task manager too a Windows Problem Reporting popped up when Flash Crashed (didn't load) So I said there must be a file of why it crashed. So I went to Start>Computer (Right Clicked) Manage > Opened Computer Management on left side clicked Event Viewer I hope these screen captures can help to see why Flash is crashing. I also made a Dump file plug-in container of and it is pretty Big 203,170 MB after i got flash to work by refreshing the page several times.
Attached screenshots

Modified by mrbunnylamakins

Chosen solution

BEX errors typcally indicate an attempted software process injection and can be a sign of malware.

Also, if the EXE is launching when you play Flash media in Firefox, then you did not successfully disable the Protected Mode feature as I suggested in response to your post earlier this week: Why is Adobe deliberately Hating Firefox? When Protected Mode is disabled, the DLL will launch inside plugin-container.exe and you will not see Flash EXE processes spawned outside.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • DivX Web Player version 3.2.4.1250
  • DivX VOD Helper Plug-in
  • GEPlugin
  • Google Update
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 17.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.6.156
  • Unity Player 4.6.2f1
  • VLC media player Web Plugin 2.1.5

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

More Information

FredMcD
  • Top 10 Contributor
3669 solutions 50336 answers

Helpful Reply

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Chosen Solution

BEX errors typcally indicate an attempted software process injection and can be a sign of malware.

Also, if the EXE is launching when you play Flash media in Firefox, then you did not successfully disable the Protected Mode feature as I suggested in response to your post earlier this week: Why is Adobe deliberately Hating Firefox? When Protected Mode is disabled, the DLL will launch inside plugin-container.exe and you will not see Flash EXE processes spawned outside.

BEX errors typcally indicate an attempted software process injection and can be a sign of malware. Also, if the EXE is launching when you play Flash media in Firefox, then you did not successfully disable the Protected Mode feature as I suggested in response to your post earlier this week: [https://support.mozilla.org/questions/1053512 Why is Adobe deliberately Hating Firefox?] When Protected Mode is disabled, the DLL will launch inside plugin-container.exe and you will not see Flash EXE processes spawned outside.

Helpful Reply

This worked 100 % Thanks!

jscher

"

Hi nonsaya, thank you for that.

A common problem on Windows Vista and higher is incompatibility with the protected mode feature of the Flash Player plugin. I recommend disabling it.

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Or if Windows gives you problems with permissions, try this way:

(1) In a My Computer or Windows Explorer window, open this folder:

C:\Windows\SysWOW64\Macromed\Flash

If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead:

C:\Windows\System32\Macromed\Flash

(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)

(2) Check for a file named mms.cfg:

Note: If you do not see file extensions such as .ocx, .dll, .exe, and .cfg on the files in this folder, then Windows may be hiding these from you. In order to work with file names accurately, it is best to unhide the extensions. This Microsoft support article has the steps: http://support.microsoft.com/kb/865219.

(A) If mms.cfg exists, drag it to your Documents folder where you can edit it without being bothered about administrator privileges

(B) If mms.cfg does not exist, open your Documents folder, right-click > New > Text File and name the new file mms.cfg

(3) Open mms.cfg from Documents into a text editor such as Notepad.

Add this on its own line (I put it last):

ProtectedMode=0

Save the file and close Notepad.

(4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents

This change will take effect once the Flash plugin is completely unloaded, which may require exiting and restarting Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox). "

This worked 100 % Thanks! jscher " Hi nonsaya, thank you for that. A common problem on Windows Vista and higher is incompatibility with the protected mode feature of the Flash Player plugin. I recommend disabling it. See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox? Or if Windows gives you problems with permissions, try this way: (1) In a My Computer or Windows Explorer window, open this folder: C:\Windows\SysWOW64\Macromed\Flash If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead: C:\Windows\System32\Macromed\Flash (Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.) (2) Check for a file named mms.cfg: Note: If you do not see file extensions such as .ocx, .dll, .exe, and .cfg on the files in this folder, then Windows may be hiding these from you. In order to work with file names accurately, it is best to unhide the extensions. This Microsoft support article has the steps: http://support.microsoft.com/kb/865219. (A) If mms.cfg exists, drag it to your Documents folder where you can edit it without being bothered about administrator privileges (B) If mms.cfg does not exist, open your Documents folder, right-click > New > Text File and name the new file mms.cfg (3) Open mms.cfg from Documents into a text editor such as Notepad. Add this on its own line (I put it last): ProtectedMode=0 Save the file and close Notepad. (4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents This change will take effect once the Flash plugin is completely unloaded, which may require exiting and restarting Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox). "