X
Tap here to go to the mobile version of the site.

Support Forum

Youtube Resetting My Cookie Permissions Each Time I Visit

Posted

YouTube is resetting my Page Info > Permissions > Set Cookies > Block each time I visit.

YouTube is resetting my Page Info > Permissions > Set Cookies > Block each time I visit.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

More Information

jscher2000
  • Top 10 Contributor
8688 solutions 71014 answers

YouTube shouldn't be able to change your settings. What change do you see occurring?

YouTube shouldn't be able to change your settings. What change do you see occurring?
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

Make sure that you do not clear the Site Preferences.

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Make sure that you do not clear the Site Preferences. Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Question owner

jscher2000 said

YouTube shouldn't be able to change your settings. What change do you see occurring?

After I watch YouTube videos in Private Browser mode, my Set Cookies go from Block to Allow. I have to change back every time.

''jscher2000 [[#answer-709282|said]]'' <blockquote> YouTube shouldn't be able to change your settings. What change do you see occurring? </blockquote> After I watch YouTube videos in Private Browser mode, my Set Cookies go from Block to Allow. I have to change back every time.
jscher2000
  • Top 10 Contributor
8688 solutions 71014 answers

Are you using the option to start up automatically in private browsing mode? This usually is set in the Options dialog by choosing "Firefox will: Never remember history".

In that mode, Firefox generally allows all cookies for the current session, and permission changes you make might be similarly temporary. I don't have much experience with that mode.

Are you using the option to start up automatically in private browsing mode? This usually is set in the Options dialog by choosing "Firefox will: Never remember history". In that mode, Firefox generally allows all cookies for the current session, and permission changes you make might be similarly temporary. I don't have much experience with that mode.

Question owner

jscher2000 said

Are you using the option to start up automatically in private browsing mode?

No, I don't use the automatic mode. I've been using manual private browsing mode for years and just recently started having this problem over a week ago.

''jscher2000 [[#answer-711161|said]]'' <blockquote> Are you using the option to start up automatically in private browsing mode? </blockquote> No, I don't use the automatic mode. I've been using manual private browsing mode for years and just recently started having this problem over a week ago.
jscher2000
  • Top 10 Contributor
8688 solutions 71014 answers

Could you spell it out for me a little more:

(1) In a Regular (non-private) window, check that the YouTube cookie permission is Block before you visit the site.

You can check using the Permissions Manager page:

  • type or paste about:permissions in the address bar and press Enter
  • as the left column populates, type youtube into the search box above the list and it should filter down to relevant entries (sometimes new items appear as Firefox continues searching)
  • click www.youtube.com in the left column and examine the Set Cookies permission on the right side; check any other domains that appear

(2) Visit YouTube in the private window as usual

(3) Back in the regular window, reload about:permissions and check again. Any change there?

Could you spell it out for me a little more: (1) In a Regular (non-private) window, check that the YouTube cookie permission is Block before you visit the site. You can check using the Permissions Manager page: * type or paste about:permissions in the address bar and press Enter * as the left column populates, type youtube into the search box above the list and it should filter down to relevant entries (sometimes new items appear as Firefox continues searching) * click www.youtube.com in the left column and examine the Set Cookies permission on the right side; check any other domains that appear (2) Visit YouTube in the private window as usual (3) Back in the regular window, reload about:permissions and check again. Any change there?

Question owner

jscher2000 said

Could you spell it out for me a little more: (1) In a Regular (non-private) window, check that the YouTube cookie permission is Block before you visit the site. You can check using the Permissions Manager page:
  • type or paste about:permissions in the address bar and press Enter
  • as the left column populates, type youtube into the search box above the list and it should filter down to relevant entries (sometimes new items appear as Firefox continues searching)
  • click www.youtube.com in the left column and examine the Set Cookies permission on the right side; check any other domains that appear
(2) Visit YouTube in the private window as usual (3) Back in the regular window, reload about:permissions and check again. Any change there?

So I also just used this method and Set Cookies to "Block" for all the Youtube sites that came up in the search. I then opened a private window and browsed Youtube for a bit. After coming back after awhile my Set Cookies permission for www.youtube.com had been reset to "Allow First Party Only."

''jscher2000 [[#answer-712021|said]]'' <blockquote> Could you spell it out for me a little more: (1) In a Regular (non-private) window, check that the YouTube cookie permission is Block before you visit the site. You can check using the Permissions Manager page: * type or paste about:permissions in the address bar and press Enter * as the left column populates, type youtube into the search box above the list and it should filter down to relevant entries (sometimes new items appear as Firefox continues searching) * click www.youtube.com in the left column and examine the Set Cookies permission on the right side; check any other domains that appear (2) Visit YouTube in the private window as usual (3) Back in the regular window, reload about:permissions and check again. Any change there? </blockquote> So I also just used this method and Set Cookies to "Block" for all the Youtube sites that came up in the search. I then opened a private window and browsed Youtube for a bit. After coming back after awhile my Set Cookies permission for www.youtube.com had been reset to "Allow First Party Only."
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

Maybe also check the value of this pref on the about:config page:

Maybe also check the value of this pref on the <b>about:config</b> page: *http://kb.mozillazine.org/network.cookie.blockFutureCookies

Question owner

cor-el said

Maybe also check the value of this pref on the about:config page:

I can't find that setting in my about:config. I've attached an image that shows what I can see.

''cor-el [[#answer-718565|said]]'' <blockquote> Maybe also check the value of this pref on the <b>about:config</b> page: *http://kb.mozillazine.org/network.cookie.blockFutureCookies </blockquote> I can't find that setting in my about:config. I've attached an image that shows what I can see.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

That pref isn't there by default, so if you do not have it then it is OK.

Note that you need to clear all the cookies of a website (domain) when you change the permissions because permissions only apply to newly created cookies.

That pref isn't there by default, so if you do not have it then it is OK. Note that you need to clear all the cookies of a website (domain) when you change the permissions because permissions only apply to newly created cookies.

Question owner

Since I haven't seen any working solution for this, I'll just assume for now that it's a security problem/bug in Firefox...certain websites able to override permission settings somehow.

Since I haven't seen any working solution for this, I'll just assume for now that it's a security problem/bug in Firefox...certain websites able to override permission settings somehow.
jscher2000
  • Top 10 Contributor
8688 solutions 71014 answers

I wasn't able to replicate the issue; I tested in a new profile. YouTube cookies stayed blocked.

Maybe your site permissions database has become corrupted. You could try renaming it and gradually build a new one. If you have saved a lot of permissions, that might not be an appealing prospect, but...

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename permissions.sqlite to something like permissions.old (in case you want to undo this change later).

Start Firefox back up and block YouTube cookies again. Does the setting stick?

I wasn't able to replicate the issue; I tested in a new profile. YouTube cookies stayed blocked. Maybe your site permissions database has become corrupted. You could try renaming it and gradually build a new one. If you have saved a lot of permissions, that might not be an appealing prospect, but... Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''permissions.sqlite''' to something like permissions.old (in case you want to undo this change later). Start Firefox back up and block YouTube cookies again. Does the setting stick?
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware

Question owner

FYI, I was never able to get this issue fixed. Seems like a bug with the browser.

FYI, I was never able to get this issue fixed. Seems like a bug with the browser.
jscher2000
  • Top 10 Contributor
8688 solutions 71014 answers

This may not apply to you, but since we never discussed what extensions you were using...

Some users mentioned this week that the EFF's Privacy Badger extension will override/change your site-specific cookie allow/block settings based on its own judgment. This issue is mentioned in some reviews of the extension as well: https://addons.mozilla.org/firefox/addon/privacy-badger-firefox/reviews/

Do you have that or any other cookie-related extensions?

This may not apply to you, but since we never discussed what extensions you were using... Some users mentioned this week that the EFF's Privacy Badger extension will override/change your site-specific cookie allow/block settings based on its own judgment. This issue is mentioned in some reviews of the extension as well: https://addons.mozilla.org/firefox/addon/privacy-badger-firefox/reviews/ Do you have that or any other cookie-related extensions?

Question owner

jscher2000 said

This may not apply to you, but since we never discussed what extensions you were using... Some users mentioned this week that the EFF's Privacy Badger extension will override/change your site-specific cookie allow/block settings based on its own judgment. This issue is mentioned in some reviews of the extension as well: https://addons.mozilla.org/firefox/addon/privacy-badger-firefox/reviews/ Do you have that or any other cookie-related extensions?

I do have that extension.

''jscher2000 [[#answer-741809|said]]'' <blockquote> This may not apply to you, but since we never discussed what extensions you were using... Some users mentioned this week that the EFF's Privacy Badger extension will override/change your site-specific cookie allow/block settings based on its own judgment. This issue is mentioned in some reviews of the extension as well: https://addons.mozilla.org/firefox/addon/privacy-badger-firefox/reviews/ Do you have that or any other cookie-related extensions? </blockquote> I do have that extension.
jscher2000
  • Top 10 Contributor
8688 solutions 71014 answers

It's the one you least suspect... try disabling it for a while and see if the bizarre behavior stops.

It's the one you least suspect... try disabling it for a while and see if the bizarre behavior stops.