Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I permanently delete all one click search engines from Firefox 36.0.1 except Startpage?

  • 5 replies
  • 1 has this problem
  • 392 views
  • Last reply by cor-el

more options

Every time I start a session in Firefox, I must delete google search engine, because it re appears time and time again, no matter what I do. Is there a permanent fix to just make it go away for ever from my browser? Thank you in advance

Every time I start a session in Firefox, I must delete google search engine, because it re appears time and time again, no matter what I do. Is there a permanent fix to just make it go away for ever from my browser? Thank you in advance

Chosen solution

Do you mean that Google appears in the search bar, or in the search box on the built-in Firefox home page? Or do you mean Google takes over your entire home page?

If Google is replacing your home page at startup even though you changed it during your previous session, there are a variety of possible reasons. This article describes some of them: How to fix preferences that won't save.

Another reason is software like Advanced SystemCare or other utility software with a home page protection feature: it will undo browser settings changes to protect you from unwanted changes. But it doesn't know which ones are wanted and which ones aren't, so it undoes all the changes. If you have software like this, turn off this feature, at least until you get Firefox working the way you want.

Read this answer in context 👍 1

All Replies (5)

more options

Hello there,

To remove Chrome from your search engine then follow these steps:

1. Click on the magnifying glass in the Search bar on your toolbar, then click "Change Search Settings"

2. Click on the search engine you wish to remove

3. Click the remove button to take it off the list

https://support.mozilla.org/en-US/kb/search-bar-add-change-manage-search-engines-firefox#w_turn-search-suggestions-on-or-off

Hope this helps!

more options

Here is what I did in order to remove Google and a number of other search engines from my browser:

  1. Disabled the selected search engines
  2. Selected a default search engine
  3. Applied the change
  4. Go back into the settings
  5. Remove selected search engines
  6. Shut down FireFox
  7. Start FireFox back up

From the looks of it, it is no longer there. When I use the StartPage search engine, it uses my chosen default, that being Bing.

Going into the settings to verify, I see only what I have chosen to leave.

Let me know if this helps!

more options

Remove anything Google from your Add-ons Manager, and the computers Programs Folder. Then use these;

Bookmark and use this; Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


Settings Guard for Firefox {web link} Detects and resets changes to settings that are frequently done by add-ons and application installers.

more options

Chosen Solution

Do you mean that Google appears in the search bar, or in the search box on the built-in Firefox home page? Or do you mean Google takes over your entire home page?

If Google is replacing your home page at startup even though you changed it during your previous session, there are a variety of possible reasons. This article describes some of them: How to fix preferences that won't save.

Another reason is software like Advanced SystemCare or other utility software with a home page protection feature: it will undo browser settings changes to protect you from unwanted changes. But it doesn't know which ones are wanted and which ones aren't, so it undoes all the changes. If you have software like this, turn off this feature, at least until you get Firefox working the way you want.

more options

You can manage the search engine in Options/Preferences > Search.

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.