X
Tap here to go to the mobile version of the site.

Support Forum

How do I remove the "Get to Google faster. Switch you default search enging to Google" bar at the top of Firefox?

Posted

Google is already my default search engine. Each time I start Firefox there is a blue banner just under the Bookmarks tool bar that says "Get to Google faster. Switch your default search engine to Google." How do I prevent it's re occurrence? Selecting Sure or No thanks does not help.

Thank you

Google is already my default search engine. Each time I start Firefox there is a blue banner just under the Bookmarks tool bar that says "Get to Google faster. Switch your default search engine to Google." How do I prevent it's re occurrence? Selecting Sure or No thanks does not help. Thank you

Additional System Details

Installed Plug-ins

  • Blue Jeans Installation Plugin
  • Blue Jeans Video Plugin
  • Google Update
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • BlackBerry WebSL Browser Plug-In
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • wpidetector
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 36.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0/WINNT/en-US/

Extensions

  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 8500 GT
  • adapterDescription2:
  • adapterDeviceID: 0x0421
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterSubsysID: 050e1043
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-18-2013
  • driverDate2:
  • driverVersion: 9.18.13.1106
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 8500 GT Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
Jon Gregory 30 solutions 242 answers

I use Adblock Plus to get rid of this problem.

Have a great day!

Jon

I use [https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/ Adblock Plus] to get rid of this problem. Have a great day! Jon
jscher2000
  • Top 10 Contributor
8569 solutions 70080 answers

I think choosing "No Thanks" should set a cookie that Google will check in the future so it doesn't bother you again, but maybe not...

In addition to add-ons like Adblock Plus and Remove It Permanently, you can modify web pages by using custom style rules. If you don't want any new add-ons, post back for steps to use a custom style rule.

I think choosing "No Thanks" should set a cookie that Google will check in the future so it doesn't bother you again, but maybe not... In addition to add-ons like Adblock Plus and [https://addons.mozilla.org/firefox/addon/remove-it-permanently/ Remove It Permanently], you can modify web pages by using custom style rules. If you don't want any new add-ons, post back for steps to use a custom style rule.
Jon Gregory 30 solutions 242 answers

Hey jscher2000 I would really appreciate that if you would post it so I don't have to have an extra add on. It sounds like a better fix, and can help other users that are having this problem, versus having to get an add on.

Thanks!!

Jon

Hey jscher2000 I would really appreciate that if you would post it so I don't have to have an extra add on. It sounds like a better fix, and can help other users that are having this problem, versus having to get an add on. Thanks!! Jon
jscher2000
  • Top 10 Contributor
8569 solutions 70080 answers

Hi Jon, here is the style rule to suppress the blue message bar:

@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document domain("www.google.com") {
  #pushdown {display:none !important;}
}

To apply this to Firefox, you can create (or if it already exists edit) a userContent.css file in your currently active Firefox settings folder and paste it in there. These articles have some background on that:

A long time ago I posted step-by-step instructions, but those may be obsolete now. Some key points are:

(1) To most easily open your current Firefox settings (AKA Firefox profile) folder, you can use any of these:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a Windows Explorer window listing the contents of your settings folder.

(2) By default, there is no chrome folder there unless you have been upgrading from an earlier version of Firefox for a long time. When you create the chrome folder, the name should be all lowercase.

(3) When creating the userContent.css in the chrome folder, the name must be exact. Beware of text editors that tack on .txt at the end (by default, Windows hides this information, but will show the file type as a text file).

(4) I think Firefox only reads the userContent.css file at startup, so you need to exit Firefox and start it up again to test whether it works.

(5) Probably some other things I'm forgetting since I use the Stylish extension to create and apply my custom style rules...

Hi Jon, here is the style rule to suppress the blue message bar: @namespace url(http://www.w3.org/1999/xhtml); @-moz-document domain("www.google.com") { #pushdown {display:none !important;} } To apply this to Firefox, you can create (or if it already exists edit) a userContent.css file in your currently active Firefox settings folder and paste it in there. These articles have some background on that: * http://kb.mozillazine.org/UserContent.css * http://kb.mozillazine.org/Editing_configuration#How_to_edit_configuration_files A long time ago I posted step-by-step instructions, but those may be obsolete now. Some key points are: (1) To most easily open your current Firefox settings (AKA Firefox profile) folder, you can use any of these: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button to launch a Windows Explorer window listing the contents of your settings folder. (2) By default, there is no '''chrome''' folder there unless you have been upgrading from an earlier version of Firefox for a long time. When you create the chrome folder, the name should be all lowercase. (3) When creating the '''userContent.css''' in the chrome folder, the name must be exact. Beware of text editors that tack on .txt at the end (by default, Windows hides this information, but will show the file type as a text file). (4) I think Firefox only reads the userContent.css file at startup, so you need to exit Firefox and start it up again to test whether it works. (5) Probably some other things I'm forgetting since I use the Stylish extension to create and apply my custom style rules...
Jon Gregory 30 solutions 242 answers

Thanks!

Thanks!
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156726 answers

Note that your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

Note that your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself. *http://kb.mozillazine.org/Preferences_not_saved
dafoneguy 0 solutions 3 answers

The simple solution to this problem is to use the following URL for your default home page:

https://www.google.com/webhp?nord=1

Works for me.

The simple solution to this problem is to use the following URL for your default home page: https://www.google.com/webhp?nord=1 Works for me.
jscher2000
  • Top 10 Contributor
8569 solutions 70080 answers

Hi dafoneguy, if I right-click that link and Open Link in New Private Window (to bypass any saved cookies), I still get the blue bar after a moment. Could there be a typo?

Hi dafoneguy, if I right-click that link and Open Link in New Private Window (to bypass any saved cookies), I still get the blue bar after a moment. Could there be a typo?
dafoneguy 0 solutions 3 answers

No typo. That link works for me using a different version of the Firefox browser. I haven't used Mozilla Firefox in a long time (since version 24), I switched to a different version of the browser coded by 8pecxstudios. It works much better for me personally. Mozilla made to many changes to their code that didn't work for me. In my browser I can open the link I posted "not logged in" or "logged in" to Google and I don't get the blue bar.

No typo. That link works for me using a different version of the Firefox browser. I haven't used Mozilla Firefox in a long time (since version 24), I switched to a different version of the browser coded by 8pecxstudios. It works much better for me personally. Mozilla made to many changes to their code that didn't work for me. In my browser I can open the link I posted "not logged in" or "logged in" to Google and I don't get the blue bar.
jscher2000
  • Top 10 Contributor
8569 solutions 70080 answers

dafoneguy said

In my browser I can open the link I posted "not logged in" or "logged in" to Google and I don't get the blue bar.

What if you try what I tried and open the new link a private window so that Google can't see previously set cookies?

''dafoneguy [[#answer-742764|said]]'' <blockquote> In my browser I can open the link I posted "not logged in" or "logged in" to Google and I don't get the blue bar. </blockquote> What if you try what I tried and open the new link a private window so that Google can't see previously set cookies?
dafoneguy 0 solutions 3 answers

Yes, I get the blue bar in a new private window. However, I just use "Open Link in New Tab".

Yes, I get the blue bar in a new private window. However, I just use "Open Link in New Tab".
jscher2000
  • Top 10 Contributor
8569 solutions 70080 answers

Hi dafoneguy, I think the difference is whether you have preserved the "do not show that annoying bar again" cookie Google sets when you click No Thanks. The people getting sufficiently annoyed to post this question are either clearing cookies after every session or using automatic private browsing, so they get the bar on their first visit to Google every time they start Firefox up again.

Hi dafoneguy, I think the difference is whether you have preserved the "do not show that annoying bar again" cookie Google sets when you click No Thanks. The people getting sufficiently annoyed to post this question are either clearing cookies after every session or using automatic private browsing, so they get the bar on their first visit to Google every time they start Firefox up again.
techman41973 0 solutions 6 answers

So is there any real solution? accessing Google from the recommended link for me is not working either https://www.google.com/webhp?nord=1 I'm using private browsing mode, so how do I tell Firefox to save the Google cookie so this ribbon message stops popping up? Thanks

So is there any real solution? accessing Google from the recommended link for me is not working either https://www.google.com/webhp?nord=1 I'm using private browsing mode, so how do I tell Firefox to save the Google cookie so this ribbon message stops popping up? Thanks
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156726 answers

That is not possible as in PB mode all cookies will be session cookies, so any data stored in a cookie or otherwise in local storage is lost when you end the PB mode session. That is the way PB mode works and you can't override this in Firefox (maybe some proxy software could though).

That is not possible as in PB mode all cookies will be session cookies, so any data stored in a cookie or otherwise in local storage is lost when you end the PB mode session. That is the way PB mode works and you can't override this in Firefox (maybe some proxy software could though).
jscher2000
  • Top 10 Contributor
8569 solutions 70080 answers

techman41973 said

So is there any real solution?

Modifying the appearance or behavior of websites is always a bit of hack. You just need to choose the hack that is the easiest or most logical for you, or find a new one that you prefer.

''techman41973 [[#answer-748597|said]]'' <blockquote>So is there any real solution?</blockquote> Modifying the appearance or behavior of websites is always a bit of hack. You just need to choose the hack that is the easiest or most logical for you, or find a new one that you prefer.
BlackberryPi 1 solutions 13 answers

OK just figured out you have to install an extension to enable Adblock Plus to block certain visual elements. It works well.

OK just figured out you have to install an extension to enable Adblock Plus to block certain visual elements. It works well.

Modified by BlackberryPi