Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Updated to Firefox 36.0 Now getting Windows Security Alert

  • 16 replies
  • 110 have this problem
  • 74 views
  • Last reply by jscher2000

more options

Hello,

Updated to firefox 36.0 on 2-24-15 Now getting a Windows Security Alert Windows firewall has blocked some features of this program. Name: Firefox Publisher: Mozilla Corporation Path: C:\program files (x86)\mozilla firefox\firefox.exe Private networks box is checked and grayed out. Public networks box is unchecked and is asking to allow access.


When I look at allowed programs through firewall it shows 2 Firefox programs. Firefox --------(box is unchecked ) Firefox C:\program files (x86)\Mozilla Firefox) ----------(box checked off)

Also on 2-24-15 There were Windows 7 updates and a MSE Definition update.

When I booted up computer 2-25-15 the Windows Security Alert appeared.

I have not allowed access from Windows Security Alert window.

Why did this Windows Security Alert appear?

Modified by jorb

Chosen solution

The Windows Security Alert is the only issue. Firefox works normal. It never did not. I have access to the internet on my private network.

I'm using Classic Theme Restorer. What is interesting after clicking menu + customize, I had moved the Hello icon to the Additional Tools and Features area.

When updating to FF 36.0 The Hello icon moved itself back automatically.

I just clicked Cancel in the dialog box and the Windows Security Alert went away. Everything Firefox seems to still be functioning correctly.

If it comes back I will inform this thread.

Thanks,
Read this answer in context 👍 4

All Replies (16)

more options

This happens alot. Firewalls won't recognize the updated version of Firefox, and so they will block it. Just deleting the rules and re-adding them normally works. Configure firewalls so that Firefox can access the Internet

more options

Why is there two Firefox programs, in the firewall allowed program list? What Firefox program should be listed and checked?

more options

Could there be two listings due to differences in capitalization within the path name? From Windows' perspective, they probably are redundant.

(I deleted the various Inbound rules for Firefox and will see what happens the next time I restart.)

I assume these new rules are related to the Firefox Hello feature (https://www.mozilla.org/firefox/hello/). I don't know how narrow you can make the Inbound rule(s) without breaking it.

more options

They are listed like this:

Firefox Firefox (C:\Program Files (x86)\Mozilla Firefox)

The top Firefox listing seems to be used for public networks, because that is the only box that is checked to the right. No other box is checked

The bottom Firefox (C:\Program Files (x86)\Mozilla Firefox) listing seems to be used for Home/Work (Private) networks, because that is the box that is checked off and the box to the very left under name is checked.

It's like the Windows Security Alert window is asking me if I want to Allow the Firefox listing through the firewall, when I'm using a public network.

Modified by jorb

more options

Hi jorb, if you click Cancel in that dialog, does Firefox work normally? If so, I think the issue is the Inbound rule I mentioned. You may not need that rule if you aren't planning to use Hello.

more options

Chosen Solution

The Windows Security Alert is the only issue. Firefox works normal. It never did not. I have access to the internet on my private network.

I'm using Classic Theme Restorer. What is interesting after clicking menu + customize, I had moved the Hello icon to the Additional Tools and Features area.

When updating to FF 36.0 The Hello icon moved itself back automatically.

I just clicked Cancel in the dialog box and the Windows Security Alert went away. Everything Firefox seems to still be functioning correctly.

If it comes back I will inform this thread.

Thanks,

Modified by jorb

more options

those network requests are unrelated to firefox hello - they are for device discovery in the local network to send videos to a chromecast/roku or similar device: https://bugzilla.mozilla.org/show_bug.cgi?id=1054959

more options

I get the same thing after installing ver 36 (see other post). Firewall lists both:

Firefox Firefox (C:\Program Files (x86)\Mozilla Firefox)

I checked both the Public & Private boxes for both. Is that enough, or do I need to go thru the Remove & Add operation?

P.S. Why would you release a version that Windows can't recognize?

more options

P.S. When updating Firefox, it restored icons to the toolbar that I had previously removed.

more options

NVSteve said

I checked both the Public & Private boxes for both. Is that enough, or do I need to go thru the Remove & Add operation?

I really never received an answer to that question. Why is there two Firefox listings in the allowed programs through the Windows Firewall window? I just assumed that the Firefox listing is for when using a Public network. Below image is how I found the boxes checked after updating to FF 36.0 and that is the way I kept them. I figure when I use a public network, I'll get a dialog window asking me if I want to allow the Firefox listing through the firewall.

So far Firefox has been working normal the way the boxes are checked.

NVSteve said

P.S. Why would you release a version that Windows can't recognize?
That is what happens when one company (MS) does something, that the other company (FF) doesn't know about.

Modified by jorb

more options

I'm having the same problem, too. I'm running Windows 7 Home Premium 64 bit. After installing Firefox 36.0 I immediately received a security warning that Firefox was trying access my public and private firewall. This has never happened on any previous version of Firefox. I'm a long time user user of Firefox, but I find this kind of intrusion unacceptable. I reverted back to latest ESR version until a work around is found and this alarming bug is fixed.

Thanks....

more options

This isn't really alarming.... that's a bit hyperbolic ;) Firefox needs access through your firewall, obviously. This change was due to Firefox's needs changing a bit. Deleting your Firewall rules and re-allowing Firefox should suffice.

more options

Tyler Downer said

Deleting your Firewall rules and re-allowing Firefox should suffice.

In the allowed programs window. How many Firefox programs do you show listed?

more options

Accessing my firewall is 'hyperbolic' . No , sorry it isn't . Your answer is condescending. I've tried deleting my firewall rules numerous times and I still receive Window's security warning. What program is trying to put a whole in my firewall  ? What new changes in this version of Firefox need that kind of intrusion ?

more options

Hi! I've used Firefox 99% of the time for well over 10 years & after I installed Windows Update & rebooted, (less than 30 minutes ago), I got the "Windows Security Alert" as described above. I've never had an issue with Firefox & Windows Firewall before, & it seems to me that the only difference is the addition of "Hello", (which is an unnecessary feature, IMHO...why not just type an email or pick up a phone to converse with someone???) I'm just saying...... Anyway, since I have absolutely no intention of ever using "Hello", what is the recommended action for this " Security Warning"? As I said, I've never had any warning regarding Windows Firewall & Firefox, so it seems to me that "Hello" is causing the Firewall to send up a red flag. Since I'm never going to use this new feature is it safe to assume that I should allow Windows Firewall to continue blocking this? Please advise.Thanks! Oh, I checked a couple sites I normally visit & I can still access them & I didn't dismiss the Security Alert yet...so Firefox works fine, but Windows Firewall doesn't like something else about it. I'm not going to test "Hello" to see what happens, so will you please tell me what to do? Thanks again! Nuts4Mutts

more options

Hi Nuts4Mutts, the alert indicates that Firefox is proposing new connection rules be added to the Windows Firewall. You can cancel that if you only need traditional browsing.

Earlier in this thread, there was an explanation for the prompt: https://support.mozilla.org/questions/1048772#answer-696702