Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I make the cursor default to the address bar instead of Google search when I first open FF?

  • 7 replies
  • 4 have this problem
  • 17 views
  • Last reply by Quote720

more options

A recent update changed the behavior when Firefox is first opened. Now, the cursor defaults to a Google search at the middle of the window. Before, it defaulted to the address bar in the same way as when a new tab is opened. When I open a web browser, I typically want to type a web address, not a search. How can I restore this previous behavior?

A recent update changed the behavior when Firefox is first opened. Now, the cursor defaults to a Google search at the middle of the window. Before, it defaulted to the address bar in the same way as when a new tab is opened. When I open a web browser, I typically want to type a web address, not a search. How can I restore this previous behavior?

All Replies (7)

more options

Hello Quote720, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follow on Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
(you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

thank you

more options

The issue persists in safe mode.

more options

Any luck if you update Firefox to the latest version ?

You can also try to see if the issue exist in a new profile.


thank you

more options

This issue was caused when I updated to the latest version.

I'll try the profile thing, but I won't have time for it for a long while. Although, it seems like this wouldn't help on account of this issue was caused by an update, and I don't see the relevance.

more options

I found something, but it's not very helpful because it removes useful functionality. In preferences, I changed "when Firefox starts" to "show blank page", but this removes access to the new very useful "restore previous session" button. Is there any way to show this page when Firefox starts but still have the cursor default to the address bar?

more options

You can click the Home button on the Navigation Toolbar to open the home page with the restore previous session button or move the History button from the "3-bar" Firefox menu button drop-down list to the Navigation Toolbar for easier access to this item.

more options

Well that sort of fixes it. I think the best thing would be if there was an option to have the new window page be the same as the new tab page, and it would be nice to add a restore previous session button with the home, bookmarks, downloads, etc buttons. Pretty sure this will never happen.