Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube videos won't play in Firefox

  • 5 replies
  • 17 have this problem
  • 203 views
  • Last reply by FredMcD

more options

Youtube videos were playing fine in Firefox yesterday, but not today. I get a perpetual loading circle on a black screen. if i hover over the bar underneath it'll show me thumbnail captures of the video as i move my mouse across; similarly, if i drag my mouse while holding down, it'll show a horizontal grid of thumbnails superimposed over a bigger picture.

Chrome plays the videos fine still, so I'm sure it's not a plugin issue or it'd be affecting Chrome also. Plugins are all up to date, for what it's worth. Was already using the most recent Firefox update before this, also.

One thing I found coincidental is that this seemed to happen after I followed the instructions on this page https://support.mozilla.org/en-US/kb/vine-and-other-html5-videos-wont-play?esab=a&as=aaq because Vines and some other videos were showing static images instead of videos. After I toggled the setting to "false", some hours later I went to open Youtube and none of the videos were showing. I changed the windows media foundation setting back to "true" then, but it made no difference. After that, here's all I tried:

1. cleared cache and cookies. 2. ran firefox in safe mode; videos still wouldn't play. 3. disabled all extensions; videos still wouldn't play. 4. turned off the hardware acceleration for firefox, to no effect. 5. deactivated plugins to no effect.

Something I noticed: when right-clicking on the video player, at the bottom of the list is an "about HTML5 player" option. I remembered that to say "About Flash Player" instead in the past.

Because of this, I searched "firefox youtube using html5" and one of the first results was this add-on: https://addons.mozilla.org/en-us/firefox/addon/youtube-all-html5

I installed it and now videos are suddenly playing again, and if I right click videos it instead says "about flash player" at the bottom again now instead of HTML5. Disabling the add-on causes videos to not work again.

So, my question now is, what's the cause of this? I shouldn't have to install an add-on just for Youtube videos to play in Firefox, especially since they were playing fine before.

All Replies (5)

more options

Try Firefox 37, we have made HTML5 video player default.

more options

Excuse me, I'm running Firefox 37 (Win7 64x) and I've been having the same problem since yesterday. And again, it worked just fine the day before and it continues to work fine in Chrome.

I tried the same plugin and it works, but it's still really sloppy for something as important as YouTube to suddenly stop working without a plugin.

Modified by AllPurposeNerd

more options

Security Issue: Update your Flash Player Version 17.0.0.169
https://www.adobe.com/products/flashplayer/distribution3.html

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Yeah, not really. Updating flash and my drivers did nothing. Still works with the plugin, still perpetual loading without it.

more options

You could try disabling Flash plugin's protected mode. The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste flash and pause while the list is filtered (C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.


1) Enter the config by typing about:config in the address bar. 2) Enter media.mediasource.webm.enabled and press enter. 3) Right click on it and change to true, for some reason it is set as "false" which makes MSE & WebM VP9 not work properly. 4) Visit: https://www.youtube.com/html5 and check that everything is OK. 5) Try to watch a video. It should work now.