Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I have set up my firefox shortcut to go directly to the profile manager. I have had it that way for years. All the sudden it has stopped working

  • 8 replies
  • 1 has this problem
  • 1072 views
  • Last reply by John99

more options

Hi,

I cannot get my firefox shortcuts to go directly to the profile manager anymore. I don't know why. I know I have set the target up correctly in properties but it still will not go to the profile manger. Please help.

Here is what is in the target location in properties:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -profilemanger

Chosen solution

I haven't had a problem yet. Been doing it that way for about two years. This most recent update erased the -P "profilemanager" -no-remote. I added it back in and waala! Off and running again.

But dully noted. Thank you for the advice.

Read this answer in context 👍 0

All Replies (8)

more options

You may find a simple -P works. In Linux the argument is -ProfileManger not -profilemanager I am not certain if Firefox on Windows is case sensitive for this but worth trying with a capital P and a capital M

more options

I am able to open profile manager as long as all firefox windows and profiles are closed. What I can't do and what I used to be able to do is have multiple profiles open at one single time. Firefox will not let me do that now. If one profile is open and I click to open another profile it will automatically open up in the already open profile. I want multiple profiles open at the same time. I could do that before the upgrade.

more options

Hi again daddhugh, Would I be correct to say you can now open Firefox with the profile manager and choose a profile, that's progress then.

Running multiple instances is nothing to do with the upgrade you need to use -no-remote but only on the additional profiles.

It is NOT recommended to use -no-remote on your default browser's profile it will cause problems.

more options

How do you add -no remote to the additional profiles? I have always had it set up where the profile manager opens and I select which profile I want to open. If there is a firefox window of any kind open I cannot open any other profile except for that one. I won't even be prompted to open the profile manager. The setup I have now is the same setup I had before the upgrade. Since the upgrade I am not able to open the profile manager as long as there is a firefox window open. I have the "don't ask at startup" option unchecked.

more options

I figured it out. It's not that you need -no-remote on each individual profile, you need -no-remote on the one single shortcut so that shortcut will always open profile manager. It is -P "profilemanager" -no-remote

That way it always opens profile manager so you can select a different profile.

Thanks for the -no-remote tip!

more options

daddhugh said

I figured it out. It's not that you need -no-remote on each individual profile, you need -no-remote on the one single shortcut so that shortcut will always open profile manager. It is -P "profilemanager" -no-remote

If you do it that way, you are liable to have a problem with your Default Profile and opening the "default browser" from external links.


as John mentioned "It is NOT recommended to use -no-remote on your default browser's profile it will cause problems."

more options

Chosen Solution

I haven't had a problem yet. Been doing it that way for about two years. This most recent update erased the -P "profilemanager" -no-remote. I added it back in and waala! Off and running again.

But dully noted. Thank you for the advice.

more options

Glad all is working again. If you have not come across this problem in two years maybe you just do not set Firefox as the Sytem's default browser. If so no need to read any further.

Just be aware that in some circumstances you will run into problems with the way you appear to have done this. If you try to take an action that opens Firefox indirectly it may fail.

The action you are trying to avoid, opening another window of the existing Firefox is sometimes essential.

If you try to use a hyperlink or an HTML file your Windows Vista OS will normally try to use your default browser. That may well be Firefox. If that is the case and Firefox tries to open with -no-remote it will fail if the profile is in use. (Or warn you then automatically close down the already running profile )

I will quote from another help article