Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

My computer was updated and firefox is now blocking many pages that i frequent. How can I change this?

  • 1 reply
  • 1 has this problem
  • 7 views
  • Last reply by philipp

more options

Microsoft recently updated on my computer. I have two profiles on the computer and under the admin profile, I can function normally and visit and website. My husband's profile is blocking him on Mozilla by saying almost all sites are insecure, such as: facebook, google maps, google, msn. If you type in the web address, it just says this connection is untrusted. Sometimes it gives me the option to make an exception, but not all the time. How can I fix this?

All Replies (1)

more options

hello ashkees, first please make sure that the date, time & timezone are set correctly on your system. if this doesn't solve the issue (or it is already set properly), a possible solution depends on different factors:

  • what is the error code shown under technical details on the error page?

in case the error code equals sec_error_unknown_issuer, please attempt to add an exception on the bottom of the error page (don't add it for real) & inspect the certificate (see the screenshot attached for instructions):

  • which issuer information does the certificate contain?

please report back with those pieces of information. thank you!