Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

There is a problem with Firefox "remembering" my Verizon residential account password. Using Firefox, I am forced to enter my ID and password every time.

  • 11 replies
  • 11 have this problem
  • 1 view
  • Last reply by FredMcD

more options

There is a problem with Firefox "remembering" my Verizon residential account password. Using Firefox, I am forced to enter my ID and password every time I have closed my browser and then relaunch, or close my e-mail for any appreciable length of time, even when I have checked the "keep me logged in" option given by Verizon. I spent a long time today working with Verizon technical support and they (and I) can verify that this is specific to Firefox and does not happen with IE. So far, this seems to be limited to Verizon login, but there may be other protected online accounts impacted. If it helps, I run Firefox under Windows 7 with Norton Security and the Norton toolbar enabled. This is a real pain and needs to be fixed.

Chosen solution

With the form filler add-ons;

Go to the web site. After you enter data into a form, you tell the form filler to remember what was entered, The form filler saves the information based of the site address, and the name of the field the information was entered into. If the same field shows up on a different page for the same site, or when you go back to that same page, the information stored is automatically entered for you. So far, I have not found a web page that stops these from working.

Read this answer in context 👍 2

All Replies (11)

more options

Details like websites remembering you (log you in automatically) are stored in a cookie.

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

more options

Thanks, but I already have it set to accept cookies and -- though I DO clear history on disconnect -- already have excepted (i.e. specified to NOT clear) both cookies and site preferences.

more options

Warning. There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) you can find several add-ons that can override this, and give you better control of your password information. You can also try a Form Filling add-on.

more options

Thanks for the suggestions, but there doesn't seem to be a password add-on or form filler that would apply here, at least not without more specific recommendations based on my situation. Besides, I've used Firefox for quite a while and this just started happening as of the day of my original post, so something's not working the way it should.

Again, based on the work I did yesterday (date of original post) together with Verizon tech support -- a real person on the phone, not a "chat" person -- the problem is with Firefox, since login and password retention worked with IE and failed repeatedly with Firefox. I realize I could use IE for e-mail since it does not have the problem, but I vastly prefer Firefox for stability and security. It's just that much better.

more options

Chosen Solution

With the form filler add-ons;

Go to the web site. After you enter data into a form, you tell the form filler to remember what was entered, The form filler saves the information based of the site address, and the name of the field the information was entered into. If the same field shows up on a different page for the same site, or when you go back to that same page, the information stored is automatically entered for you. So far, I have not found a web page that stops these from working.

more options

I installed SimpleFill. Not exactly the clearest about how to use, but I have managed to get it working with my Verizon account. This add-on requires a right click/select for ID and again for PW, which is certainly better than having to manually input each field every time, but I was hoping for an autofill that obviated manual input completely. Perhaps that's unrealistic. I guess my point would still be that there is some issue that has disrupted the previously functioning retention of both the ID and PW for my Verizon account and that seems to be specific to some Firefox change/glitch. But this work around is better than no fix at all.

Thanks Fred McD, particularly for your persistence. User assistance from Firefox support forums is one of the big reasons I vastly prefer to use it as my browser.

more options

The add-on I use will fill in the web page as soon as the page loads. It can even be set up so that universal information like name, address, phone . . . . is only entered once, and will be posted to any web page.

Autofill {web link} Autofill is a small but powerful add-on that serves one purpose: fill form fields automatically on page load. It is for people who just want a straightforward form filler without all the bells and whistles.

more options

I have the same not staying logged in happening for past several days. Verizon says it's a FF problem after much investigating. I'm using Mac mini osx10.5.8 and ffv34. I have to agree because it works fine on Safari. Can the Bugzilla folks look into this for us please?

more options

ann1026 said

I have the same not staying logged in

Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new This will let us look at your system details. No Personal Information Is Collected.

more options

ann1026 said

I have the same not staying logged in happening for past several days. Verizon says it's a FF problem after much investigating.

Thanks for posting this. It's reassuring to see that I am not the only one having this Verizon issue. If you read the thread, you will see several suggestions. FredMcD has been quite helpful, although I wasn't able to get Autofill to work for me (most likely my lack of understanding).

For me, SimpleFill works OK. Once you name the actions (i.e., "ID"; "PW"; etc.) and fill in your user-specific information, you r/click on the blank in the My Verizon login screen, select SimpleFill from the menu that pops up, and click on the info you need to enter. Because Verizon sets up its login as 2 separate pages (ID followed by PW), you have to do this at each page. This is NOT a long-term solution. It is a work-around, but better a r/click than having to manually enter your ID and PW every single time.

Assuming Verizon tech support is right that this is a Firefox issue (not necessarily a good assumption IMHO) I hope the folks at BugZilla will devote some effort to fixing the glitch. In the meantime, if anyone else has a long-term fix, I'd be grateful for more input.

more options

A quick lesson on Autofill. When the web page loads, fill out the input boxes. But Only the fields that you want AutoFill to remember. Examples; Login, Password, other such things: Yes. Credit Card, SSN, other such high security stuff: No. Also, in the case of something like a repair ticket or forms like that, only your ID stuff and not the other fields.

Once you are done filling in those fields, right click an empty area. Select Autofill. Then Add Rules. Follow the prompts. and you are done.