X
Tap here to go to the mobile version of the site.

Support Forum

I get "Error: invalid_client" when I try to import my Google Contacts into Hello.

Posted

When I click the "Import" button in Hello, I get a pop-up Google error page, and no contacts are imported.

Entire error is below:


401. That’s an error.

Error: invalid_client

The OAuth client was not found. Request Details

   scope=https://www.google.com/m8/feeds
   response_type=code
   redirect_uri=urn:ietf:wg:oauth:2.0:oob:auto
   client_id=no-google-oauth-api-clientid

That’s all we know.


When I click the "Import" button in Hello, I get a pop-up Google error page, and no contacts are imported. Entire error is below: ---------- 401. That’s an error. Error: invalid_client The OAuth client was not found. Request Details scope=https://www.google.com/m8/feeds response_type=code redirect_uri=urn:ietf:wg:oauth:2.0:oob:auto client_id=no-google-oauth-api-clientid That’s all we know. ----------

Chosen solution

Hi ChrisKouza , You may want to check to make sure that you are not blocking api. This should be done automatically when you authenticate to import however this is how it is done manually: https://wiki.mozilla.org/Loop/OAuth_Setup

Via this bug it may also be linux related: https://bugzilla.mozilla.org/show_bug.cgi?id=1106854

In the meantime please try the manual set up in the wiki and follow that bug for updates, I apologize for the inconvenience!

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • DivX Web Player version 1.4.0.233
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 34.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0/Linux/en-US/

Extensions

  • Adblock Plus 2.6.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • LastPass 3.1.1 (support@lastpass.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.9 (ubufox@ubuntu.com)
  • Ubuntu Online Accounts 0.5 (online-accounts@lists.launchpad.net)
  • Unity Desktop Integration 3.0.2 (webapps-team@lists.launchpad.net)
  • Unity Websites integration 2014.08.06.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66})
  • User Agent Switcher 0.7.3 ({e968fc70-8f95-4ab9-9e79-304de2a71ee1})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Bay Trail
  • adapterDeviceID: Mesa DRI Intel(R) Bay Trail
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 10.1.3
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Bay Trail
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.frecency_experiment: 1
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141127111021
  • browser.startup.homepage: https://www.google.com/webhp?tab=mw&ei=u5IZVKTSBtCVqAbdioKwDQ&ved=0CA4QqS4oCw
  • browser.startup.homepage_override.buildID: 20141127111021
  • browser.startup.homepage_override.mstone: 34.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 34.0
  • media.gmp-gmpopenh264.lastUpdate: 1416192662
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1420365274
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1420438425
  • places.history.expiration.transient_current_max_pages: 100577
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1418795461

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Chosen Solution

Hi ChrisKouza , You may want to check to make sure that you are not blocking api. This should be done automatically when you authenticate to import however this is how it is done manually: https://wiki.mozilla.org/Loop/OAuth_Setup

Via this bug it may also be linux related: https://bugzilla.mozilla.org/show_bug.cgi?id=1106854

In the meantime please try the manual set up in the wiki and follow that bug for updates, I apologize for the inconvenience!

Hi ChrisKouza , You may want to check to make sure that you are not blocking api. This should be done automatically when you authenticate to import however this is how it is done manually: [https://wiki.mozilla.org/Loop/OAuth_Setup] Via this bug it may also be linux related: [https://bugzilla.mozilla.org/show_bug.cgi?id=1106854] In the meantime please try the manual set up in the wiki and follow that bug for updates, I apologize for the inconvenience!