Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox and other browsers close automatically after few minutes without any error message?

  • 8 replies
  • 11 have this problem
  • 8412 views
  • Last reply by FredMcD

more options

Firefox and other browsers close automatically after few minutes without any error message I deleted every add-ons and reset firefox and tried firefox from safe mode and Private browsing, and cleared all data and cookies and the same problem pleeeeeease help me

Chosen solution

I think the problem was because of Anti-porn I uninstalled it and it solved, Thank you very much for your answers :)

Read this answer in context 👍 1

All Replies (8)

more options

Please update Firefox to the latest version: Update Firefox to the latest release

If this continues to happen, please check to make sure that there is not an antivirus that is blocking Firefox from running.

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.

more options

thank you guigs2 for your answer: but the problem still happen :( I can't solve it i reinstalled my windows and did all steps

more options

Something on your computer is causing this issue.

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

the same problem :( :( :(

more options

Start your Computer in safe mode. Then start Firefox. Try Safe web sites.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

then ?????

more options

Chosen Solution

I think the problem was because of Anti-porn I uninstalled it and it solved, Thank you very much for your answers :)

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so other will know.