Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Suddenly I cannot open email attachments. I get a message stating that "security settings" do not allow. Where are these settings located and who set them?

  • 2 replies
  • 3 have this problem
  • 2802 views
  • Last reply by jscher2000

more options

I am using TWC (Time Warner Cable) as my mail server and Firefox as my browser. I went to my emails and tried to open an attachment and got an error message stating "security settings were preventing the file from being downloaded". Okay, I contacted TWC, Norton, and my PC settings. It looks as though Firefox is the problem! If I use a different browser ie: Google and go to my email account I have no problem. I remember recently that Firefox did a download of upgrades and this may be the cause of the problem.

Chosen solution

Thank you for your private message with the error text: "Your current security settings do not allow this file to be downloaded."

Firefox partially integrates with Internet Explorer's security settings for download purposes. You can liberalize your IE settings for the "Internet zone" by following the steps in this Microsoft forums reply:

http://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/error-message-your-current-security-settings-do/59cc236d-7baf-4552-92ff-b34b9a6942aa

Note: Traditionally, the Internet Options dialog was available in the Windows Control Panel as well as in IE. Not sure about Windows 8.1.

Does that fix it?

Read this answer in context 👍 1

All Replies (2)

more options

The next time you see this, could you post the exact wording of the error (for Googling purposes) or a screen shot of the error?

Also, I don't know whether you have Firefox set to ask you to select the folder/file name when downloading but if you do, does the error appear before or after that step?

more options

Chosen Solution

Thank you for your private message with the error text: "Your current security settings do not allow this file to be downloaded."

Firefox partially integrates with Internet Explorer's security settings for download purposes. You can liberalize your IE settings for the "Internet zone" by following the steps in this Microsoft forums reply:

http://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/error-message-your-current-security-settings-do/59cc236d-7baf-4552-92ff-b34b9a6942aa

Note: Traditionally, the Internet Options dialog was available in the Windows Control Panel as well as in IE. Not sure about Windows 8.1.

Does that fix it?