X
Tap here to go to the mobile version of the site.

Support Forum

I can't login to my school website anymore since I have updated my firefox to 34.0.5.

Posted

I can't login to my school website anymore since I have updated my firefox to 34.0.5. I have deleted the cert8.db, and still having the same issue. Please Help! Here is the error: Unable to Connect Securely Firefox cannot guarantee the safety of your data on my.saintleo.edu because it uses SSLv3, a broken security protocol. Advanced info: ssl_error_no_cypher_overlap

I can't login to my school website anymore since I have updated my firefox to 34.0.5. I have deleted the cert8.db, and still having the same issue. Please Help! Here is the error: Unable to Connect Securely Firefox cannot guarantee the safety of your data on my.saintleo.edu because it uses SSLv3, a broken security protocol. Advanced info: ssl_error_no_cypher_overlap

Chosen solution

A possibility is to use this extension to enable SSL3 temporarily only for a website that needs SSL3.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • NOTFOUND
  • Version 5.38.6.0
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 15.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3

Application

  • Firefox 34.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0.5/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Skype Click to Call 7.3.16540.9015 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 620
  • adapterDescription2:
  • adapterDeviceID: 0x1049
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 097710de
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17415
  • driverDate: 7-2-2014
  • driverDate2:
  • driverVersion: 9.18.13.4052
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 620 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.frecency_experiment: 4
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045
  • browser.startup.homepage: https://my.yahoo.com/
  • browser.startup.homepage_override.buildID: 20141126041045
  • browser.startup.homepage_override.mstone: 34.0.5
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 34.0.5
  • gfx.direct3d.last_used_feature_level_idx: 0
  • media.gmp-gmpopenh264.lastUpdate: 1417803364
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1418003976
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1418063047
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1417804401

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4259 solutions 59646 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br>'''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Helpful Reply

I have tried the above solution but it didn't work. I still have the same error, now on two different computers, since I have updated Firefox. I have attached a pic where you can notice the link where I'm suppose to click on, is in a different area. from Firefox to Chrome

I have tried the above solution but it didn't work. I still have the same error, now on two different computers, since I have updated Firefox. I have attached a pic where you can notice the link where I'm suppose to click on, is in a different area. from Firefox to Chrome
philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23470 answers

Helpful Reply

hello regba123, ssl3.0 encrypted connections can be no longer considered secure since an attack vector against them ("POODLE") has become known. please contact the webmaster in charge of your school's site and urge them to update the encryption to something contemporary. https://blog.mozilla.org/security/2014/10/14/the-poodle-attack-and-the-end-of-ssl-3-0/

if you want to re-enable ssl 3.0 in firefox you can do that - however keep the consequences in mind, that you will become vulnerable to the attack mentioned above: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.tls.version.min. double-click it, change its value to 0 and restart the browser.

hello regba123, ssl3.0 encrypted connections can be no longer considered secure since an attack vector against them ("POODLE") has become known. please contact the webmaster in charge of your school's site and urge them to update the encryption to something contemporary. https://blog.mozilla.org/security/2014/10/14/the-poodle-attack-and-the-end-of-ssl-3-0/ if you want to re-enable ssl 3.0 in firefox you can do that - however keep the consequences in mind, that you will become vulnerable to the attack mentioned above: enter '''about:config '''into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''security.tls.version.min'''. double-click it, change its value to '''0''' and restart the browser.
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11290 answers

You should however not keep this preference set at zero as otherwise you may think you are safe on secure site even when any sites still using the old vulnerable SSL 3.0 is in use.

You should however not keep this preference set at zero as otherwise you may think you are safe on secure site even when any sites still using the old vulnerable SSL 3.0 is in use.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

Chosen Solution

A possibility is to use this extension to enable SSL3 temporarily only for a website that needs SSL3.

A possibility is to use this extension to enable SSL3 temporarily only for a website that needs SSL3. *SSL Version Control: https://addons.mozilla.org/firefox/addon/ssl-version-control/