Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When i try to install firefox 33.1 or any version it says "Sorry Firefox cannot be installed. This version requires Windows XP SP2 or newer", I have SP3

  • 2 replies
  • 1 has this problem
  • 56 views
  • Last reply by cor-el

more options

I cannot install the lastest addition of firefox on Windows XP Professional SP3. I currently have version 12.0 and when I click check for Updates it says Firefox is up to date. However almost all websites display a notices that says "Looks like you're using an older version of firefox.

Chosen solution

Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Read this answer in context 👍 1

All Replies (2)

more options

The useragent of the Firefox 12.0 version that you used to post here indicates your Operating System is Windows 2000 (Windows NT 5.0;), which isn't supported by Mozilla for anything newer than Firefox 12.0.

You could try using IE to download Firefox 33.1.1 from here: http://www.mozilla.com/en-US/firefox/all.html

more options

Chosen Solution

Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.