Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop bad Web site from coming up every time I start Firefox?

  • 2 replies
  • 74 have this problem
  • 31698 views
  • Last reply by CaryStevens

more options

After installing some software, the URL "http://hi.ru/?10" keeps opening in a new tab every time I launch Firefox. It also took over my homepage in Chrome and IE, but it was easy to fix those. For some reason though, it keeps ignoring the homepage I changed it to in my Firefox settings. It just keeps bringing up this stupid Russian Web site. I've tried looking for it in about:config but don't see anything there. I've looked for Add-Ons, but nothing there. No toolbars that could be doing it also.

It does seem similar to the problem addressed in this article, but I'm using Windows 8.1, so it's not a simple shortcut that I can edit. https://support.mozilla.org/en-US/kb/wrong-home-page-opens-when-i-start-firefox-how-fix?esab=a&as=aaq

Please help! Arggghh!

Thanks Cary

Chosen solution

So your home page is correct in the Options dialog, but clicking the Home icon or opening a new window (Ctrl+n) loads the wrong page, or loads two tabs (one right, one wrong)?

I know you've checked several of these things before, but if you wouldn't mind taking a second look:

(1) Start with the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

(2) Then, in Firefox, open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.


If the problem only occurs with the desktop shortcut, check for a hijacked "target" using the Desktop side of Windows. Right-click the icon, choose Properties, then the Shortcut tab. If you have pinned the Firefox icon to the Taskbar there is an extra click: right-click the icon and then right-click Mozilla Firefox. Then you can get to Properties.

The "Target" for 32-bit Windows 7 should be no more and no less than the following:

"C:\Program Files\Mozilla Firefox\firefox.exe"

Edit: sorry, forgot to edit after pasting...

The "Target" for 64-bit Windows 8.x should be no more and no less than the following:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If there is extra stuff on the line after that, clear it out.

Any progress?

Read this answer in context 👍 17

All Replies (2)

more options

Chosen Solution

So your home page is correct in the Options dialog, but clicking the Home icon or opening a new window (Ctrl+n) loads the wrong page, or loads two tabs (one right, one wrong)?

I know you've checked several of these things before, but if you wouldn't mind taking a second look:

(1) Start with the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

(2) Then, in Firefox, open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.


If the problem only occurs with the desktop shortcut, check for a hijacked "target" using the Desktop side of Windows. Right-click the icon, choose Properties, then the Shortcut tab. If you have pinned the Firefox icon to the Taskbar there is an extra click: right-click the icon and then right-click Mozilla Firefox. Then you can get to Properties.

The "Target" for 32-bit Windows 7 should be no more and no less than the following:

"C:\Program Files\Mozilla Firefox\firefox.exe"

Edit: sorry, forgot to edit after pasting...

The "Target" for 64-bit Windows 8.x should be no more and no less than the following:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If there is extra stuff on the line after that, clear it out.

Any progress?

Modified by jscher2000

more options

So it appears that when I launch Firefox from the Taskbar's icon, it was opening the bad Web site, but when I launch Firefox from the Start Menu, it was working the way it should.

I simply Unpinned Firefox from the Taskbar and then pinned it again and now it works perfectly.

I sure wish Windows 8.1 would give us access to the properties of these Taskbar and Start Menu shortcuts like Windows 7 and earlier. But Microsoft, in their infinite wisdom, decided we can't be trusted I guess.

Well, thanks for the help. All fixed now.