Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot open Google search results in tab\same window\new window

more options

Google search results are not opening in the new tab\same window\new window.
It is happening only in Firefox, Internet explorer. It is working fine in chrome.
I have tried many solutions like
1. cleared cache, history,everything from browser's, still no result.
2. opened in safe mode, no result.
3. unchecked hardware acceleration, still no result.
4. Other search engines it is working fine, only problem with Google search engine.
5. Tried changing my DNS (Google open DNS, others), no result.
6. Checked with antivirus blocking, nothing is blocking.
7. Reinstalled browsers(Firefox, explorer) no result.
8. Tried with different versions of browsers, including the latest updates ( Firefox,explorer), no result.
9. while disabling Java in about:config it is working in Firefox.
Please help me on this issue.
Thanks in advance.

Modified by cor-el

All Replies (9)

more options

Just to clarify, what is happening when you click a result link: nothing happens at all?

However, if you disable JavaScript (about:config => javascript.enabled => false) then it works normally?

Do you notice any difference if:

(1) You disable "instant prediction" results here: https://www.google.com/preferences (login not required, this is stored in a cookie)

(2) You are logged in versus logged out of your Google account?

more options

By the way, if you want to disable JavaScript just on one or two sites and leave it enabled for all other sites, you can use this extension: https://addons.mozilla.org/firefox/addon/yesscript/

more options

FYI,

when I click a result link : nothing happens at all, as in picture it buffers for 10 mins showing connecting, after some time, it shows "Connection was reset try again".

And BTW if I disable Java script in about:config, it only works until the next restart of browser.

When I tried to change the Google preferences & save as shown in picture, it buffers for 10 mins showing connecting, after some time, it shows "Connection was reset try again" and it is throwing error that "your cookies seem to be disabled", but as shown my cookies setting is fine.

more options

Do you want to try one of the extensions that blocks Google's click tracking? As you can see in the third screen shot, Firefox is stalling on Google's /url script. The following extension (and there are others) bypasses the script so you can go to the result site more directly:

https://addons.mozilla.org/firefox/addon/google-redirect-rewrite-remove/

Note: I haven't tested it myself.

Does that help?


I'm puzzled about Google saying your cookies are not enabled. However, it is possible to create a site-specific exception. To check that, click the padlock or globe in the address back, then More Information, then Permissions. If you scroll or scan down the list of permissions to Set Cookies, you can see whether Google is blocked.

more options

Still No result.

Does DHCP server has got to do anything with this problem ?

more options

Google normally routs the result link to their safe browsing testing service via an onmousedown event that modifies the link (href attribute) if you click it once.

You can check if this bookmarklet makes a difference:

javascript:(function(){var e=document.querySelectorAll('#search a[onmousedown]'),E,i;for(i=0;E=e[i];i++){E.removeAttribute('onmousedown')}})()

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Still no result. 1. I have checked in my laptop with other ISP connection, it is working fine. only problem when I use my network. What might be the problem with my network ? please go through the the above section for workaround I have gone-through.

Suggest me a solution so that I can find out what is the problem in my network, which is blocking in 2 browsers & allowing chrome.

more options

In your original post, you mentioned disabling Java in about:config. Do you mean switching

javascript.enabled

to false allowed you to use Google normally?


What is your connection setting here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings button

The default of "Use system proxy settings" should use your Windows/IE "LAN" settings. You also could try "No proxy".

more options

1. Im using, the auto proxy settings, if i select other options in network, i cannot load even google homepage. 2. yes i have toggled to false javascript.enabled