Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox UI becomes completely unresponsive in debugging mode.

  • 2 replies
  • 3 have this problem
  • 1 view
  • Last reply by dunpealer

more options

I'm using Firefox for web development, and set breakpoints with the `debugger` keyword, or the breakpoint UI in the "Debugger" section of the "Web Developer" tools. I remember that used to work on older versions, but recently it started failing.

Now, when I enter debugging mode (i.e. hit a breakpoint), the debugger UI shows, but it is completely unresponsive: the mouse cursor doesn't change when I hover over any widget, and clicking does nothing.

The only way to get any response is CTRL-r refresh which *sometimes* works, as well as closing the entire Firefox window. Of course, that means I can't actually use it to debug.

I'm on Xubuntu 13.10, running latest stable 64bit Firefox (3.1.1). I also verified the exact same bug on the nightly binary release (firefox-36.0a1.en-US.linux-x86_64.tar.bz2) as well as the recently released Developer Edition (firefox-35.0a2.en-US.linux-x86_64.tar.bz2).

Modified by dunpealer

All Replies (2)

more options

HI dunpealer, Please do file a bug on this and make sure to put version 35 and os linux on bugzilla.mozilla.org.

I am sorry it took so long to get back to you, I also can reproduce this. If you have any questions about bugzilla we are happy to help here as well.

Thank you!

more options