Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does my address bar have a string of icons (rather than the url) when I click on some sites?

  • 10 replies
  • 2 have this problem
  • 974 views
  • Last reply by jhaskins

more options

When I visit some websites, instead of the URL for that site showing up in my address bar, I get this long string of weird looking icons that stretch all the way across the address bar and into the search bar. I've never seen this before until just a few months ago. When I click on the icon on the far left inside the address bar I get this message: "This website does not supply identity information".

Is there any way to get rid of these icons and have the website URL show up instead?

Chosen solution

Hello,

The leftmost button is the Site Identity Button. For more information about it, please see:


Try Firefox Safe Mode to see if the other icons go away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


If those icons are still there covering your address bar in safe mode, please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Read this answer in context 👍 0

All Replies (10)

more options

Chosen Solution

Hello,

The leftmost button is the Site Identity Button. For more information about it, please see:


Try Firefox Safe Mode to see if the other icons go away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


If those icons are still there covering your address bar in safe mode, please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Please provide a screenshot of that.

https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem

It is best to use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed a maximum file size of 1 MB.
Then use the Browse .... button below the Post a Reply text box to upload the screenshot.
more options

Thanks so much for the quick reply.

When I get this string of icons, the leftmost button inside the bar is a globe, and when I click on the globe, it says that "Your connection to this site is not encrypted", as well as "This website does not supply identity information".

When I restarted Firefox in Safe Mode as you suggested, the icons DID NOT appear, so now I guess I need to find out if one of my extensions is causing the problem.

I am attaching a screenshot of my address bar (it's on the StatCounter website) so that you can see what I'm talking about. Hopefully you will be able to see it.

more options

Yep, that's caused by an extension, or the "wrong" combination of extensions.

The Addon Bar or Classic Theme Restorer are to most likely causes, or just having them both installed together. From what I have seen of CTR, I believe it restores the Addon Bar so you may not need the separate The Addon Bar extension, too.

more options

I went ahead and removed the "Addon Bar" extension, but it didn't help. So I disabled the "CTR" extension and that didn't help either. Would you just disable each extension one-by-one and try to find the problem that way? I just noticed the address bar on this site also has the icons, so I'm attaching a screenshot of it too, but they're all pretty much the same.

more options

What theme are you using? Problems with a theme can also cause all the toolbar buttons to appear in strange places.

more options

I'm not sure how to tell which theme I have. I see "Default 33.1" under Appearance. Is that what you mean?

more options

Probably not a theme problem then. Most people do not seem to be having a problem with the default theme. I would start disabling extensions until the problem disappears. The last one that you disabled would be the one causing the problem.

more options

Lol. That's what I was thinking. I'll go ahead and get started on that, and hopefully I'll run into the culprit. Thanks for your help and suggestions.

more options

Well looky here. I only had to disable 3 add-ons, and the third one was a charm. It was the 'RSS Icon 1.0.6'. I re-enabled the other 2 and the icons in the address bar are still gone - finally. Thanks so much for your help. You were exactly right about the extensions being the problem.