Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Many many videos refuse to play; they load but give error on play

  • 11 replies
  • 8 have this problem
  • 4089 views
  • Last reply by joeybingo

more options

I recently made Firefox my default browser, in lieu of Chrome, mainly just for variety and to keep abreast of things; no biggie. There are numerous problems playing videos. I recently solved one big issue, where videos would play but NOT in fullscreen at foxsports.com/foxsportsgo, by disabling hardware acceleration, as suggested under Firefox Help. Thank you. Yes, I've read pretty much ALL of Firefox's canned help suggestions on the topic of video playback problems but I haven't got a solution. I did try doing the master reset as suggested, but it was to no avail. I checked and I have the latest Flash Player plug-in, 15.0.0.189. It's set to Always Activate. I haven't problems with any videos playing when using Chrome. I experienced a number of sites and video play problems but here I'll focus in on just one: a video appears and it seems to have loaded Ok since it shows a frame (a teaser, not the 1st frame); but when I click Play it says, "An error occurred, please try again later" and there's a "Learn More" link. Following that link, the subsequent page says I should wait 30 minutes and then try playback again. That's a crock. As a sample of this problem, go to http://davidblaine.com/video/street-magic and click any of the videos. They all consistently fail for me with that singularly unhelpful generic error message!

[Edit] I just now noticed/realized that I'm on the beta update channel, and just in case that fact is contributing to these video problems, I've uninstalled v34 and installed v33.0.3. But the cited playback problem persists despite the version fallback.

Modified by joeybingo

Chosen solution

Is the issue related? What was interesting was that it looks like your Graphics driver is blocked. However hardware acceleration should disable this, did you try updating it? Upgrade your graphics drivers to use hardware acceleration and WebGL

direct2DEnabledMessage: [u'blockedGfxCard'] I wonder if its the driver. 

The example website that you provided are mainly embedded youtube links, and the help to try again in 30 min may be due to the number of people viewing the video. Of course it works http://davidblaine.com/video/street-magic on my virtual machine.

However normally if I block flash the html5 player will play, this is not the case for this example.

The other guess is the supported codec: do you have openH264 Video Coded by cisco systems listed in your plugins?

Read this answer in context 👍 1

All Replies (11)

more options

Until you fix the problem, you are better off with the normal Firefox


Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153 Adobe Shockwave for Director Netscape plug-in, version 12.1.2.152

Having more than one version of a program may cause issues.


Start Firefox in Safe Mode by holding down the <Shift(Mac Options)> key, and then starting Firefox. Is the problem still there?

more options

(I'm off the beta channel now -- running v33.)

Sadly, your suggestion, restarting in Safe Mode, didn't solve the problem. Thank you for responding. I also experimented with disabling the older Shockwave for Director version by setting it to Never Activate. How come there's no evident means to just DELETE unwanted add-ons? Anyway, that didn't solve the issue either. I'm still hoping to resolve this somehow.

more options

There are two types of Add-ons. There are the Add-ons that you find and install. And there are also Plugins. These are from other programs that are on your system when Firefox starts. Like video players, anti-virus, and many more. You can disable normal Add-ons by going to the Add-ons Manager,

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

Select Extensions, locate the add-on. From here you can disable or remove it. Plugins, however, can only be set to Never or Ask. To remove it, you have to remove its program.

more options

Thanks, that is helpful. So I uninstalled Paypal Plugin using the Add/Remove Programs Control Panel because that add-on is clearly obsolete, but of course it has no bearing on video playback. Maybe I should remove some other plug-ins the same way. But some (such as OpenH264 Video Codec) do not show up in the Windows Add/Remove list. Also "Shockwave for Director" has no obvious match in that list either. I can fearlessly start paring my plug-ins until the playback issue resolves itself but I'm not sure exactly how to proceed or where to begin. Any advice?? Thank you!

more options

Open your Add-ons Manager. Go to the Plugins page. Set Everything to Ask To Activate. After, restart Firefox.

When you try to play something, you may get a pop-up asking if you want to use whatever plugin. Select Yes. How is it?

more options

Before playback it asks that I activate Adobe Flash. If I allow it, playback fails with the usual error message. Arggh.

more options
more options

No sorry but thank you for your efforts supreme. I've looked at all those citations of yours and still nothing fixes it. I've gotten rid of the TWO versions of Shockwave (for Director) and reinstalled just the latest one alone. I've set Java platform to Always Activate, in case it matters. Adobe site confirms I have the latest Flash. 'Guess I'll try removing the Flash Player program (incl. control panel) and reinstalling the entirety. Oh but first, there is one questionable: in the Flash CP Advanced tab it says I have NPAPI Plug-in (the latest) but PPAPI Plug-in is not installed. Is that copacetic do you suppose?? Y'know, everything works right in Chrome, but Adobe site says that plug-in is different ...it's a "Pepper-based Flash Player". Befuddled still.

Modified by joeybingo

more options

Chosen Solution

Is the issue related? What was interesting was that it looks like your Graphics driver is blocked. However hardware acceleration should disable this, did you try updating it? Upgrade your graphics drivers to use hardware acceleration and WebGL

direct2DEnabledMessage: [u'blockedGfxCard'] I wonder if its the driver. 

The example website that you provided are mainly embedded youtube links, and the help to try again in 30 min may be due to the number of people viewing the video. Of course it works http://davidblaine.com/video/street-magic on my virtual machine.

However normally if I block flash the html5 player will play, this is not the case for this example.

The other guess is the supported codec: do you have openH264 Video Coded by cisco systems listed in your plugins?

more options

Yes, guigs2, you've hit upon it, THANK YOU. I wasn't aware of that troubleshooting info page. Looking there, it clearly states that WebGL Rendering is blocked as well as Direct2D due to "unresolved driver issues". I'm currently using my default on-board VIA graphics adapter after a state-of-the-art graphics card I had installed died. I've just now tried updating the VIA's driver but Windows cannot find anything (new?) for it using the standard driver update wizard. I am making further inquiries about a possible update. I read in a pertinent forum that VIA quit driver support years ago. This is an older PC. I have another PCI graphics card that I could slip in there and try. I'll need a little time to make some display adapter improvements here. But I've went ahead and marked the question solved. This has been great and again many thanks! I'll post again hopefully to report if there is good news on this front.

[Edit: yes BTW I do have that OpenH264 Codec]

Modified by joeybingo

more options

I'll just add that I'm a mite disappointed in Firefox that it pegs my hardware with the ignominious "unresolved driver issues". That designation seems kinda arbitrary, heavy-handed and/or unwarranted; especially considering that I can watch all these videos under Chrome. I cannot find a newer driver than 2007 for my main-board's graphic adapter. And so what? ..the existing driver is alright! I guess I can't make Firefox my default browser unless I acquire a video card. The spare I had i couldn't get to work (inexplicably, as it worked Ok in another machine recently). And anyway, Firefox specs (rather I think it's Adobe Flash specs) says it demands a minimum 128MB card to have hardware acceleration enabled. I'm not spending no $70 -- bah!