Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I want PDF to open in the browser, not download. I can't find a setting to do this.

  • 4 replies
  • 8 have this problem
  • 31285 views
  • Last reply by Oran

more options

Other browsers open a pdf on the web inside the browser, which I like. Firefox wants to download it, which I do not like. The settings do not seem to allow me this choice for pdf. Other file types work.

Chosen solution

Hello,

Try renaming your mimetypes.rdf file in your profile folder - this file is where the file actions are stored so when it is missing, Firefox will recreate it. Hopefully when that happens, it will default so that PDFs will open in Firefox.

To go to your profile folder if Firefox is open:

  • Go to your Troubleshooting page, either:
    • Enter about:support in your address bar and press enter
    • Go to Help (or New Fx Menu > Help-29 ) > Troubleshooting Information
  • In the page that opens, click the "Show Folder" button
  • Exit Firefox ( New Fx Menu > Close 29 )

See the article Profiles - Where Firefox stores your bookmarks, passwords and other user data for more information, such as where to find the folder when Firefox is not open.

Rename the mimetypes.rdf file to mimetypes.old and then restart Firefox. If it works, you can delete the mimetypes.old file; if it doesn't and you want your application settings back you can rename the mimetypes.old file back to mimetypes.rdf (make sure you exit Firefox before doing that).

Articles for more information:

Let us know if that works!

Read this answer in context 👍 3

All Replies (4)

more options

Hello,

Check your settings for PDF files in:

  • Tools (or New Fx Menu ) > Options > Applications
  • For PDFs, set to "Preview in Firefox"

Also, you are using an outdated version of Firefox (current version is 33.0.3), you can update by going to:

  • Help (or New Fx Menu > Help-29 ) > About Firefox

Or download a fresh copy at:

more options

Thanks for your input. I did update to the latest version. But while Adobe Acrobat Forms and Adobe Acrobat XML Data Package show the Use Adobe Acrobat (in Firefox) choice, the Adobe Acrobat Document choices do not offer that selection. All I get are Always Ask Save As Use Adobe Acrobat None of these work to open in the browser. I have a Surface Pro 2 with 8.1 and the full pro version (Acrobat XI) IE opens in the browser as expected. Firefox does not. Oran

more options

Chosen Solution

Hello,

Try renaming your mimetypes.rdf file in your profile folder - this file is where the file actions are stored so when it is missing, Firefox will recreate it. Hopefully when that happens, it will default so that PDFs will open in Firefox.

To go to your profile folder if Firefox is open:

  • Go to your Troubleshooting page, either:
    • Enter about:support in your address bar and press enter
    • Go to Help (or New Fx Menu > Help-29 ) > Troubleshooting Information
  • In the page that opens, click the "Show Folder" button
  • Exit Firefox ( New Fx Menu > Close 29 )

See the article Profiles - Where Firefox stores your bookmarks, passwords and other user data for more information, such as where to find the folder when Firefox is not open.

Rename the mimetypes.rdf file to mimetypes.old and then restart Firefox. If it works, you can delete the mimetypes.old file; if it doesn't and you want your application settings back you can rename the mimetypes.old file back to mimetypes.rdf (make sure you exit Firefox before doing that).

Articles for more information:

Let us know if that works!

more options

That worked! I would never have figured that out. Thanks for the help. That was the only sticky point I had with Firefox. Oran