X
Tap here to go to the mobile version of the site.

Support Forum

Problem with google search bar in Firefox

Posted

Last week the google search bar started to conduct all searches via the google.nl dutch site. It has never done this before. I am in England and the search bar has always used google.co.uk by default. I do not know why this has changed. I have not altered any settings and I am using the most up to date version of Firefox on my Windows 8 laptop. Altering the settings for google via the google website does not help.

Last week the google search bar started to conduct all searches via the google.nl dutch site. It has never done this before. I am in England and the search bar has always used google.co.uk by default. I do not know why this has changed. I have not altered any settings and I am using the most up to date version of Firefox on my Windows 8 laptop. Altering the settings for google via the google website does not help.

Chosen solution

Well, Google thinks it knows better than us...

Perhaps it would work better to install a search plugin specific to Google UK. This page has a couple of options:

http://mycroftproject.com/google-search-plugins.html

Look for these:

  • Google UK (SSL)
  • Google UK - the UK (SSL)

After installation, you probably need to use the search bar drop-down list to select the new search plugin from the bottom of the list.


You might also double-check your connection setting here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default "Use system proxy settings" should piggyback on your Windows/IE LAN settings, but you also can try "No proxy" to see whether that changes anything.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Citrix URL-Redirection Helper Plugin
  • Citrix Receiver Plugin (Win32)
  • 5.1.30514.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.6
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • CANON iMAGE GATEWAY Mycamera Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

More Information

jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

Do you mean the built-in Firefox search bar set to Google (typically a small g icon at the left end), or a Google add-on? I will assume the built-in bar.

Google is known to check your IP address and choose a "local" sites on that basis. If you are using a proxy, perhaps that might explain the change?

A typical thing to try in this situation is to delete your Google cookies. In this case, you'll need to delete cookies for both sites.

You can call up the cookie viewer either of these ways:

  • right-click the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"

In the dialog that opens, the current site name should appear in the filter box at the top (presumably google.nl). You can remove that site's cookies individually, and then edit the filter value to google.co.uk to get the list for that site and remove those.

Then try the search bar again. Any improvement?

Do you mean the built-in Firefox search bar set to Google (typically a small g icon at the left end), or a Google add-on? I will assume the built-in bar. Google is known to check your IP address and choose a "local" sites on that basis. If you are using a proxy, perhaps that might explain the change? A typical thing to try in this situation is to delete your Google cookies. In this case, you'll need to delete cookies for both sites. You can call up the cookie viewer either of these ways: * right-click the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" In the dialog that opens, the current site name should appear in the filter box at the top (presumably google.nl). You can remove that site's cookies individually, and then edit the filter value to google.co.uk to get the list for that site and remove those. Then try the search bar again. Any improvement?
jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

A few other thoughts:

(1) If you click the "g" icon to the left of the search bar to drop down the list of search engines, are there multiple Google entries? If so, test the other ones.

(2) The built-in Google search engine plugin is located here by default:

C:\Program Files (x86)\Mozilla Firefox\browser\searchplugins\google.xml

If you paste that into the Firefox address bar on a new tab and press Enter, then scroll down past the gibberish image data to the line that starts

<Url type="text/html" method="GET" template=

Does it show the .co.uk site as the template address?

A few other thoughts: (1) If you click the "g" icon to the left of the search bar to drop down the list of search engines, are there multiple Google entries? If so, test the other ones. (2) The built-in Google search engine plugin is located here by default: C:\Program Files (x86)\Mozilla Firefox\browser\searchplugins\google.xml If you paste that into the Firefox address bar on a new tab and press Enter, then scroll down past the gibberish image data to the line that starts &lt;'''Url type'''="text/html" '''method'''="GET" '''template'''= Does it show the .co.uk site as the template address?

Question owner

Thanks very much for your help.

Unfortunately, this has not solved the problem.

At the end of the .xml file you refer to, I have the following entry:

<Url type="text/html" method="GET" template="https://www.google.com/" rel="searchform"/>

To the best of my knowledge, I am not using a proxy (my anti-virus and malware provider (Webroot) has confirmed that they are not using a proxy to provide that service) and a search of my IP address at www.whatismyip.com asserts that I am located in Great Britain (which I am!).

Still stumped.

Thanks very much for your help. Unfortunately, this has not solved the problem. At the end of the .xml file you refer to, I have the following entry: <Url type="text/html" method="GET" template="https://www.google.com/" rel="searchform"/> To the best of my knowledge, I am not using a proxy (my anti-virus and malware provider (Webroot) has confirmed that they are not using a proxy to provide that service) and a search of my IP address at www.whatismyip.com asserts that I am located in Great Britain (which I am!). Still stumped.
jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

Chosen Solution

Well, Google thinks it knows better than us...

Perhaps it would work better to install a search plugin specific to Google UK. This page has a couple of options:

http://mycroftproject.com/google-search-plugins.html

Look for these:

  • Google UK (SSL)
  • Google UK - the UK (SSL)

After installation, you probably need to use the search bar drop-down list to select the new search plugin from the bottom of the list.


You might also double-check your connection setting here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default "Use system proxy settings" should piggyback on your Windows/IE LAN settings, but you also can try "No proxy" to see whether that changes anything.

Well, Google thinks it knows better than us... Perhaps it would work better to install a search plugin specific to Google UK. This page has a couple of options: http://mycroftproject.com/google-search-plugins.html Look for these: * Google UK (SSL) * Google UK - the UK (SSL) After installation, you probably need to use the search bar drop-down list to select the new search plugin from the bottom of the list. ---- You might also double-check your connection setting here: "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button The default "Use system proxy settings" should piggyback on your Windows/IE LAN settings, but you also can try "No proxy" to see whether that changes anything.

Question owner

Many thanks for the help. The 'no proxy' setting didn't change how it worked, but I have added one of the mycroftproject plugins you suggested, which has worked.

Thank you.

Many thanks for the help. The 'no proxy' setting didn't change how it worked, but I have added one of the mycroftproject plugins you suggested, which has worked. Thank you.