X
Tap here to go to the mobile version of the site.

Support Forum

Javascript is not enabled according to a number of apps, including synch.

Posted

I am informed by a number of apps (including FireFox Synch) that JavaScript is not enabled. I am running FireFox 33.0 on an ASUS tablet running Windows 8.1. I have re-downloaded and un/re-installed FireFox a number of times. These apps have run on other windows machines with no issues.

I am informed by a number of apps (including FireFox Synch) that JavaScript is not enabled. I am running FireFox 33.0 on an ASUS tablet running Windows 8.1. I have re-downloaded and un/re-installed FireFox a number of times. These apps have run on other windows machines with no issues.

Chosen solution

It worked

Fixed.....re-extracted files from zip archive and it all runs now.

Thanks for the help!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology

Application

  • Firefox 33.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.0/WINNT/en-US/

Extensions

  • Framed Display 1.0.1 ({7012eec1-4f37-42d4-a2cd-26727494d248})
  • NoScript 2.6.9.3 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • QuickJava 2.0.4 ({E6C1199F-E687-42da-8C24-E7770CC3AE66})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Toolbar 3.2.6.20140805113039 ({635abd67-4fe9-1b23-4f01-e679fa7484c1})
  • Astromenda NT 11.0.2 ({424b0d11-e7fe-4a04-b7df-8f2c77f58aaf}) (Inactive)
  • Astromenda Search Addon 1.2 ({ad7ce998-a77b-4062-9ffb-1d0b7cb23183}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0f31
  • adapterDeviceID2:
  • adapterDrivers: igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 6-9-2014
  • driverDate2:
  • driverVersion: 10.18.10.3643
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141011015303
  • browser.startup.homepage_override.buildID: 20141011015303
  • browser.startup.homepage_override.mstone: 33.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 33.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • media.gmp-gmpopenh264.lastUpdate: 1414359384
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1414359384
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1414360102
  • places.history.expiration.transient_current_max_pages: 50677
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • privacy.sanitize.migrateFx3Prefs: True
  • security.disable_button.openDeviceManager: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1414028668

Misc

  • User JS: Yes
  • Accessibility: Yes
jscher2000
  • Top 10 Contributor
8792 solutions 71920 answers

You have the NoScript extension. By default, NoScript blocks scripts on a site-by-site basis until you indicate that you trust the site. Look for a toolbar button with a white circle-background and a blue S, which may be obscured by a red circle-slash symbol. If you do not want to be visiting this button constantly as you browse new sites, there might be a better extension for your needs (depending on the reason you installed it).

You have the NoScript extension. By default, NoScript blocks scripts on a site-by-site basis until you indicate that you trust the site. Look for a toolbar button with a white circle-background and a blue S, which may be obscured by a red circle-slash symbol. If you do not want to be visiting this button constantly as you browse new sites, there might be a better extension for your needs (depending on the reason you installed it).

Question owner

I did install NoScript as a last resort to try to gain some control over scripts hoping to be able to get my paws on JavaScript functionality. This problem existed before I installed it and it continues even when I allow sites to run scripts.

I did install NoScript as a last resort to try to gain some control over scripts hoping to be able to get my paws on JavaScript functionality. This problem existed before I installed it and it continues even when I allow sites to run scripts.

Modified by jazbutis

jscher2000
  • Top 10 Contributor
8792 solutions 71920 answers

I'm nervous seeing Astromenda in your system info. In case that or related malware is a factor, would you mind running through this procedure:

Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

Then, in Firefox, open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Finally, you can "mop up" remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware.

Does that help at all?

I'm nervous seeing Astromenda in your system info. In case that or related malware is a factor, would you mind running through this procedure: Open the Windows '''Control Panel''', Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here. Then, in Firefox, open the '''Add-ons page''' using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate". In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Finally, you can "mop up" remaining issues with the '''scanning/cleaning tools''' listed in our support article: [[Troubleshoot Firefox issues caused by malware]]. Does that help at all?

Question owner

Thanks, I will give it a shot. i did go through my installed programs and *thought* I had cleared out the riff-raff. I will go in there again.

Thanks, I will give it a shot. i did go through my installed programs and *thought* I had cleared out the riff-raff. I will go in there again.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159009 answers

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

See also:

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself. The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. See also: *http://kb.mozillazine.org/Preferences_not_saved

Question owner

Removing all questionable extensions/plugins/programs does not seem to help (all installed on one date) . NoScript has been disabled.

I have renamed and moved the user.js file as it only had Astromenda items in it.

Still no Javascript.

About:config shows as the first line of what seems to be the javascript block:

Javascript.enabled default Boolean True

Removing all questionable extensions/plugins/programs does not seem to help (all installed on one date) . NoScript has been disabled. I have renamed and moved the user.js file as it only had Astromenda items in it. Still no Javascript. About:config shows as the first line of what seems to be the javascript block: Javascript.enabled default Boolean True

Modified by jazbutis

cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159009 answers

Do you have security software that might be blocking JavaScript?

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Do you have security software that might be blocking JavaScript? Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Question owner

So this is a tablet running Win 8.1. Try as I might I cannot get F8 to work ...there is not boot screen that I can see and I have tried to push F8 during all phases of power up. There are references to Windows defender. The primary JavaScript app that I am concerned about is a local app that lives on the hard drive and does not access the outside world.

I did a "clean" reinstall; removed the installation folder, removed my personal FireFox App data folders (new machine so no much in the way of personal value there yet). I accepted nothing during the FireFox install.

Still no JavaScript.

So this is a tablet running Win 8.1. Try as I might I cannot get F8 to work ...there is not boot screen that I can see and I have tried to push F8 during all phases of power up. There are references to Windows defender. The primary JavaScript app that I am concerned about is a local app that lives on the hard drive and does not access the outside world. I did a "clean" reinstall; removed the installation folder, removed my personal FireFox App data folders (new machine so no much in the way of personal value there yet). I accepted nothing during the FireFox install. Still no JavaScript.
jscher2000
  • Top 10 Contributor
8792 solutions 71920 answers

JavaScript app that lives on the hard drive? Are you accessing it using a file: URL?

Firefox is somewhat more restrictive with external files called by local web pages: in particular, you may find that Firefox does not load .js files that are not in the same folder or in a subfolder relative to the .html page loading them.

However, if it works in Firefox on a different system, then that probably isn't the issue. Also, it wouldn't explain errors on http: URLs.

Puzzling.

Does JavaScript work for you on this page: https://jeffersonscher.com/res/jstest.php (if it's not working, the two lower sections will say so)

JavaScript app that lives on the hard drive? Are you accessing it using a file: URL? Firefox is somewhat more restrictive with external files called by local web pages: in particular, you may find that Firefox does not load .js files that are not in the same folder or in a subfolder relative to the .html page loading them. However, if it works in Firefox on a different system, then that probably isn't the issue. Also, it wouldn't explain errors on http: URLs. Puzzling. Does JavaScript work for you on this page: https://jeffersonscher.com/res/jstest.php ''(if it's not working, the two lower sections will say so)''

Question owner

I have invoked the local script by: - Associating .htm file type with FireFox and clicking on the file in a win explorer window, and - Opening FireFox and going to File->Open File-> browse to file location.

This script has worked on other machines in windows in FireFox....indeed FireFox works better than IE (where I need to give permission each time I run it). Don't recall if I've run it in Linux.

The link you posted does seem to work, at least there is nothing telling me that it failed?

Plugin listed are

   Name (Version): Intel® Identity Protection Technology (4.0.5.0)
   Description: Intel web components for Intel® Identity Protection Technology
   File name: npIntelWebAPIIPT.dll
   Name (Version): Intel® Identity Protection Technology (4.0.5.0)
   Description: Intel web components updater - Installs and updates the Intel web components
   File name: npIntelWebAPIUpdater.dll
   Name (Version): Java Deployment Toolkit 7.0.710.14 (10.71.2.14)
   Description: NPRuntime Script Plug-in Library for Java(TM) Deploy
   File name: npdeployJava1.dll
   Name (Version): Java(TM) Platform SE 7 U71 (10.71.2.14)
   Description: Next Generation Java Plug-in 10.71.2 for Mozilla browsers
   File name: npjp2.dll
I have invoked the local script by: - Associating .htm file type with FireFox and clicking on the file in a win explorer window, and - Opening FireFox and going to File->Open File-> browse to file location. This script has worked on other machines in windows in FireFox....indeed FireFox works better than IE (where I need to give permission each time I run it). Don't recall if I've run it in Linux. The link you posted does seem to work, at least there is nothing telling me that it failed? Plugin listed are Name (Version): Intel® Identity Protection Technology (4.0.5.0) Description: Intel web components for Intel® Identity Protection Technology File name: npIntelWebAPIIPT.dll Name (Version): Intel® Identity Protection Technology (4.0.5.0) Description: Intel web components updater - Installs and updates the Intel web components File name: npIntelWebAPIUpdater.dll Name (Version): Java Deployment Toolkit 7.0.710.14 (10.71.2.14) Description: NPRuntime Script Plug-in Library for Java(TM) Deploy File name: npdeployJava1.dll Name (Version): Java(TM) Platform SE 7 U71 (10.71.2.14) Description: Next Generation Java Plug-in 10.71.2 for Mozilla browsers File name: npjp2.dll

Modified by jazbutis

jscher2000
  • Top 10 Contributor
8792 solutions 71920 answers

Yes, you won't get a plugins list if JavaScript is disabled, so at least we know that inline scripts (not in an external document) worked for you on at least one site.

On your local .htm page, are the scripts in the document itself or in an external .js file?

If they are in an external file:

Is the file located in the same folder or a subfolder, or located in some other folder? For example:

Same folder: <script src="app.js" type="text/javascript"></script> Subfolder: <script src="scripts/app.js" type="text/javascript"></script> Other folder: <script src="../scripts/app.js" type="text/javascript"></script>

The Other folder in that example may trip a security block.

You might check Firefox's Browser Console (Ctrl+Shift+j) to see whether the .js file is loading or whether any reason is stated for it not loading.

Yes, you won't get a plugins list if JavaScript is disabled, so at least we know that inline scripts (not in an external document) worked for you on at least one site. On your local .htm page, are the scripts in the document itself or in an external .js file? ''If they are in an external file:'' Is the file located in the same folder or a subfolder, or located in some other folder? For example: Same folder: &lt;script src="app.js" type="text/javascript">&lt;/script> Subfolder: &lt;script src="scripts/app.js" type="text/javascript">&lt;/script> Other folder: &lt;script src="../scripts/app.js" type="text/javascript">&lt;/script> The Other folder in that example may trip a security block. You might check Firefox's Browser Console (Ctrl+Shift+j) to see whether the .js file is loading or whether any reason is stated for it not loading.

Question owner

Interesting, when I go to the browser console, I get:

ReferenceError: chapters is not defined HTML.js:6 ReferenceError: version is not defined eASLRB.htm:71 The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol. eASLRB.htm

The files eASLRB.htm, HTML.js, are in the folder in question. Never seen this before, but it sounds like a non-trivial error. Possibly a corruption of some sort when I copied from DropBox?

It looks like all the scripts being invoked are in a subfolder of the program folder nameded Scripts

<META http-equiv="Content-Script-Type" content="text/javascript"> <script language="JavaScript1.3" src="Script/util.js"></script> <script language="javascript" src="Script/globals.js"></script> <script language="javascript" src="Script/HTML.js"></script> <script language="JavaScript1.3" src="Script/nav.js"></script> <script language="javascript" src="Script/settings.js"></script> <script language="javascript" src="Script/search.js"></script> <script language="JavaScript1.3" src="Script/ToC.js"></script> <script language="JavaScript1.3" src="Script/text.js"></script> <script language="javascript" src="Script/qa.js"></script> <script language="javascript" src="Script/index.js"></script> <script language="javascript" src="Script/asop_settings.js"></script> <script language="javascript" src="Script/cookies.js"></script> <script language="javascript" src="Script/addendum.js"></script> <script language="javascript" src="prefs.js"></script>

Interesting, when I go to the browser console, I get: ReferenceError: chapters is not defined HTML.js:6 ReferenceError: version is not defined eASLRB.htm:71 The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol. eASLRB.htm The files eASLRB.htm, HTML.js, are in the folder in question. Never seen this before, but it sounds like a non-trivial error. Possibly a corruption of some sort when I copied from DropBox? It looks like all the scripts being invoked are in a subfolder of the program folder nameded Scripts <META http-equiv="Content-Script-Type" content="text/javascript"> <script language="JavaScript1.3" src="Script/util.js"></script> <script language="javascript" src="Script/globals.js"></script> <script language="javascript" src="Script/HTML.js"></script> <script language="JavaScript1.3" src="Script/nav.js"></script> <script language="javascript" src="Script/settings.js"></script> <script language="javascript" src="Script/search.js"></script> <script language="JavaScript1.3" src="Script/ToC.js"></script> <script language="JavaScript1.3" src="Script/text.js"></script> <script language="javascript" src="Script/qa.js"></script> <script language="javascript" src="Script/index.js"></script> <script language="javascript" src="Script/asop_settings.js"></script> <script language="javascript" src="Script/cookies.js"></script> <script language="javascript" src="Script/addendum.js"></script> <script language="javascript" src="prefs.js"></script>

Modified by jazbutis

Chosen Solution

It worked

Fixed.....re-extracted files from zip archive and it all runs now.

Thanks for the help!

It worked Fixed.....re-extracted files from zip archive and it all runs now. Thanks for the help!

Modified by Noah_SUMO