Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Javascript is not enabled according to a number of apps, including synch.

  • 13 replies
  • 19 have this problem
  • Last reply by jazbutis

more options

I am informed by a number of apps (including FireFox Synch) that JavaScript is not enabled. I am running FireFox 33.0 on an ASUS tablet running Windows 8.1. I have re-downloaded and un/re-installed FireFox a number of times. These apps have run on other windows machines with no issues.

Chosen solution

It worked files from zip archive and it all runs now.

Thanks for the help!

Read this answer in context 👍 1

All Replies (13)

more options

You have the NoScript extension. By default, NoScript blocks scripts on a site-by-site basis until you indicate that you trust the site. Look for a toolbar button with a white circle-background and a blue S, which may be obscured by a red circle-slash symbol. If you do not want to be visiting this button constantly as you browse new sites, there might be a better extension for your needs (depending on the reason you installed it).

more options

I did install NoScript as a last resort to try to gain some control over scripts hoping to be able to get my paws on JavaScript functionality. This problem existed before I installed it and it continues even when I allow sites to run scripts.

Modified by jazbutis

more options

I'm nervous seeing Astromenda in your system info. In case that or related malware is a factor, would you mind running through this procedure:

Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

Then, in Firefox, open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Finally, you can "mop up" remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware.

Does that help at all?

more options

Thanks, I will give it a shot. i did go through my installed programs and *thought* I had cleared out the riff-raff. I will go in there again.

more options

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

See also:

more options

Removing all questionable extensions/plugins/programs does not seem to help (all installed on one date) . NoScript has been disabled.

I have renamed and moved the user.js file as it only had Astromenda items in it.

Still no Javascript.

About:config shows as the first line of what seems to be the javascript block:

Javascript.enabled default Boolean True

Modified by jazbutis

more options

Do you have security software that might be blocking JavaScript?

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

So this is a tablet running Win 8.1. Try as I might I cannot get F8 to work ...there is not boot screen that I can see and I have tried to push F8 during all phases of power up. There are references to Windows defender. The primary JavaScript app that I am concerned about is a local app that lives on the hard drive and does not access the outside world.

I did a "clean" reinstall; removed the installation folder, removed my personal FireFox App data folders (new machine so no much in the way of personal value there yet). I accepted nothing during the FireFox install.

Still no JavaScript.

more options

JavaScript app that lives on the hard drive? Are you accessing it using a file: URL?

Firefox is somewhat more restrictive with external files called by local web pages: in particular, you may find that Firefox does not load .js files that are not in the same folder or in a subfolder relative to the .html page loading them.

However, if it works in Firefox on a different system, then that probably isn't the issue. Also, it wouldn't explain errors on http: URLs.


Does JavaScript work for you on this page: (if it's not working, the two lower sections will say so)

more options

I have invoked the local script by: - Associating .htm file type with FireFox and clicking on the file in a win explorer window, and - Opening FireFox and going to File->Open File-> browse to file location.

This script has worked on other machines in windows in FireFox....indeed FireFox works better than IE (where I need to give permission each time I run it). Don't recall if I've run it in Linux.

The link you posted does seem to work, at least there is nothing telling me that it failed?

Plugin listed are

   Name (Version): Intel® Identity Protection Technology (
   Description: Intel web components for Intel® Identity Protection Technology
   File name: npIntelWebAPIIPT.dll
   Name (Version): Intel® Identity Protection Technology (
   Description: Intel web components updater - Installs and updates the Intel web components
   File name: npIntelWebAPIUpdater.dll
   Name (Version): Java Deployment Toolkit 7.0.710.14 (
   Description: NPRuntime Script Plug-in Library for Java(TM) Deploy
   File name: npdeployJava1.dll
   Name (Version): Java(TM) Platform SE 7 U71 (
   Description: Next Generation Java Plug-in 10.71.2 for Mozilla browsers
   File name: npjp2.dll

Modified by jazbutis

more options

Yes, you won't get a plugins list if JavaScript is disabled, so at least we know that inline scripts (not in an external document) worked for you on at least one site.

On your local .htm page, are the scripts in the document itself or in an external .js file?

If they are in an external file:

Is the file located in the same folder or a subfolder, or located in some other folder? For example:

Same folder: <script src="app.js" type="text/javascript"></script> Subfolder: <script src="scripts/app.js" type="text/javascript"></script> Other folder: <script src="../scripts/app.js" type="text/javascript"></script>

The Other folder in that example may trip a security block.

You might check Firefox's Browser Console (Ctrl+Shift+j) to see whether the .js file is loading or whether any reason is stated for it not loading.

more options

Interesting, when I go to the browser console, I get:

ReferenceError: chapters is not defined HTML.js:6 ReferenceError: version is not defined eASLRB.htm:71 The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol. eASLRB.htm

The files eASLRB.htm, HTML.js, are in the folder in question. Never seen this before, but it sounds like a non-trivial error. Possibly a corruption of some sort when I copied from DropBox?

It looks like all the scripts being invoked are in a subfolder of the program folder nameded Scripts

<META http-equiv="Content-Script-Type" content="text/javascript"> <script language="JavaScript1.3" src="Script/util.js"></script> <script language="javascript" src="Script/globals.js"></script> <script language="javascript" src="Script/HTML.js"></script> <script language="JavaScript1.3" src="Script/nav.js"></script> <script language="javascript" src="Script/settings.js"></script> <script language="javascript" src="Script/search.js"></script> <script language="JavaScript1.3" src="Script/ToC.js"></script> <script language="JavaScript1.3" src="Script/text.js"></script> <script language="javascript" src="Script/qa.js"></script> <script language="javascript" src="Script/index.js"></script> <script language="javascript" src="Script/asop_settings.js"></script> <script language="javascript" src="Script/cookies.js"></script> <script language="javascript" src="Script/addendum.js"></script> <script language="javascript" src="prefs.js"></script>

Modified by jazbutis

more options

Chosen Solution

It worked files from zip archive and it all runs now.

Thanks for the help!

Modified by NoahSUMO