X
Tap here to go to the mobile version of the site.

Support Forum

this site is frustrating. have reset firefox 8 times today!! Help

Posted

Firefox runs slow, freezes up a lot, crashes. I reset firefox about 8 times today/tonight. Very frustrated. I do play a lot of games which freeze up a lot but it is various games, along with gmail and the normal facebook usage. I'm not totally computer savvy but can do some trouble shooting. Note that I have a Dell laptop which is about 9 years old.

Firefox runs slow, freezes up a lot, crashes. I reset firefox about 8 times today/tonight. Very frustrated. I do play a lot of games which freeze up a lot but it is various games, along with gmail and the normal facebook usage. I'm not totally computer savvy but can do some trouble shooting. Note that I have a Dell laptop which is about 9 years old.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • McAfee MSC FF plugin DLL
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:33.0) Gecko/20100101 Firefox/33.0

More Information

user669794 59 solutions 672 answers

Helpful Reply

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu: *In Firefox 29.0 and above, click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. *In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on ''Help'' (or click on ''Help'' in the Menu bar, if you don't have a Firefox button) then click on ''Restart with Add-ons Disabled''. If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode".<br> [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

Thank you. for responding. I will give this a try. I'm not totally computer savvy but am ok at it however I am hesitant to try certain things. I will give this a try and advise of the outcome.

Thank you. for responding. I will give this a try. I'm not totally computer savvy but am ok at it however I am hesitant to try certain things. I will give this a try and advise of the outcome.

Helpful Reply

Additionally, if I open Firefox in Safe Mode do I continue or is Safe Mode only for trouble shooting and should be closed and Firefox re-opened as per usual operation?

Additionally, if I open Firefox in Safe Mode do I continue or is Safe Mode only for trouble shooting and should be closed and Firefox re-opened as per usual operation?
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157372 answers

Yes. Safe Mode is meant for troubleshooting and not for permanent usage.


You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.


If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

Yes. Safe Mode is meant for troubleshooting and not for permanent usage. ---- You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ---- If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes