Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ran firefox update and now firefox does not run correctly.

  • 6 replies
  • 1 has this problem
  • 61 views
  • Last reply by ronaldr

more options

I ran the latest firefox update 9Firefox Setup Stub 33.0). Now when I start firefox the browser opens and inside of it is black. I cannot see anything to use the browser. I have uninstalled and reinstalled with no luck. I have also restarted my computer. I have taken a screen shot of what it looks like.

Chosen solution

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode". Make sure that you do not click Reset Firefox

Read this answer in context 👍 0

All Replies (6)

more options

Currently in version 33, Firefox has implemented a new, faster way of loading webpages. This new feature is called OMTC. However, there are still some tweaks Mozilla developers are making to this.

There is a known issue that Mozilla works on very hard to fix: if you are experiencing black webpages on some sites, here's what you can do to avoid the problem in the meantime:

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

To disable Hardware Acceleration

  • Click the menu button New Fx Menu and select Options.
  • In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.

Now, exit Firefox, wait a few seconds, and then start it normally.

Please let us know if this solves the problem. Engineering is also gathering more information about the issue would request that you fill out this survey

I should also mention that other users with this problem had an embedded intel hd graphics card with an old driver present. Until Mozilla comes up with a fix, if you want Hardware Acceleration in Firefox, you can try to update your driver through the appropriate link below to see if that helps: Intel HD 2000/3000: 32bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23763 64bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23764

Intel HD 4000: 32bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24328 64bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24329

Thank you!

more options

Cory,

It's not black on some pages. The whole browser window is black. I cannot see any webpages.

Ron

more options

Hi Ron,

Other users have had similar problems and can only see the elements inside the window (including the menu bar and address bar) when in Safe Mode. They then disabled Hardware Acceleration while in Safe Mode, and restarted Firefox normally.

If you have tried it and doesn't work, let us know.

more options

Cory,

I cannot access any function inside the browser to even go into safe mode. My firefox browser window looks just like my attachment I sent before.

Ron

more options

Chosen Solution

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode". Make sure that you do not click Reset Firefox

more options

Cory,

That worked!

Thanks, Ron