Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Language packs seem to break spell-check language selection

  • 2 replies
  • 5 have this problem
  • 5 views
  • Last reply by rkimmel

more options

I suspect this is a bug, but maybe I am doing something wrong, so I'll ask here before submitting a bug report.

I have Thunderbird 31.2.0 installed on OS X Mavericks. I am pretty sure it is the en-GB version, but I have several language packs installed, including the (presumably redundant) en-GB pack. I also have installed (and sometimes uninstalled) the add-ons "Quick Locale Switcher" and "Simple Locale Switcher" at various times to switch the user interface language. (The reason I have included the two is, I had the "Quick" switcher first, and suspected what I was seeing might be a bug in the add-on, so I switched to the other.)

Now, the symptom. When the user interface language is set as en-GB, the spell-checker language choice in the "Preferences" menu (I guess "Options" in Windows, and I don't know what in Linux) is respected - I can type an email in one language, stop, switch the spell-checker language half way through, and the real-time spell-checking is then by the new language exactly as I would have expected. But, when the user interface language is anything other than en-GB (I haven't tried en-US, but I have tried German and Russian), the spell-check language follows the user interface language, and changing the spell-check language option in the "Preferences" menu has no effect whatsoever on anything.

This problem persisted even after I removed the two language-switching add-ons. Then, I removed all the language packs (which forced my user interface back into en-GB), and magically the spell-check language selection started working again.

So I am thinking the problem is driven by the user interface being from a language pack. When the user interface language matches the original install language, the spell-check language selection works; when the user interface language is something else, the spell-check language selection is ignored, and the actual spell-check language follows the user interface language.

The "Simple Locale Switcher" does not seem to allow the user interface language and the spell-check language to be switched independently, but "Quick Locale Switcher" does. However, this feature doesn't seem to work, nor does switching the spell-check language through the Thunderbird Preferences rather than the add-on (unless the user interface language is the default en-GB).

Has any one else seen a problem like this? Is there a way to fix it? (Maybe futz with the language settings on the other side of the "Here Be Dragons" warning?)

I suspect this is a bug, but maybe I am doing something wrong, so I'll ask here before submitting a bug report. I have Thunderbird 31.2.0 installed on OS X Mavericks. I am pretty sure it is the en-GB version, but I have several language packs installed, including the (presumably redundant) en-GB pack. I also have installed (and sometimes uninstalled) the add-ons "Quick Locale Switcher" and "Simple Locale Switcher" at various times to switch the user interface language. (The reason I have included the two is, I had the "Quick" switcher first, and suspected what I was seeing might be a bug in the add-on, so I switched to the other.) Now, the symptom. When the user interface language is set as en-GB, the spell-checker language choice in the "Preferences" menu (I guess "Options" in Windows, and I don't know what in Linux) is respected - I can type an email in one language, stop, switch the spell-checker language half way through, and the real-time spell-checking is then by the new language exactly as I would have expected. But, when the user interface language is anything other than en-GB (I haven't tried en-US, but I have tried German and Russian), the spell-check language follows the user interface language, and changing the spell-check language option in the "Preferences" menu has no effect whatsoever on anything. This problem persisted even after I removed the two language-switching add-ons. Then, I removed all the language packs (which forced my user interface back into en-GB), and magically the spell-check language selection started working again. So I am thinking the problem is driven by the user interface being from a language pack. When the user interface language matches the original install language, the spell-check language selection works; when the user interface language is something else, the spell-check language selection is ignored, and the actual spell-check language follows the user interface language. The "Simple Locale Switcher" does not seem to allow the user interface language and the spell-check language to be switched independently, but "Quick Locale Switcher" does. However, this feature doesn't seem to work, nor does switching the spell-check language through the Thunderbird Preferences rather than the add-on (unless the user interface language is the default en-GB). Has any one else seen a problem like this? Is there a way to fix it? (Maybe futz with the language settings on the other side of the "Here Be Dragons" warning?)

All Replies (2)

more options

Before chasing dragons, right click in the body of a mail in the compose window and set the spell check language there. I have no idea if it will work, but it might add to the over all body of knowledge for a bug report.

Please post a link to any bug report you make.

more options

Well how about that. It works - sort of.

I now notice the same behaviour in en-GB, which I had earlier noticed to behave differently than the other interface languages. At the time, I attributed that to the fact that en-GB was (probably) the original install language. But I've since uninstalled all the language packs, and then reinstalled, and now en-GB is behaving just like all the others.

So, what I am seeing now - changing the user interface language (using "Simple Locale Switcher") causes the spell-checker to change to the same language (which I think is by design). Changing the spell-check language through the "Preferences" menu (Mac OS X) then seems to have absolutely no effect on anything whatsoever. However, changing it by the right-click method you suggest does - it correctly changes the spell-check language to the one chosen. The language shown in the "Preferences" menu changes to match whatever was chosen in the right-click method, and the change is persistent - it applies to all future emails, not just the current one.

Thanks for the tip - I'd say there is still a bug somewhere, but this changes it from a giant pain in the <insert whatever you prefer here>, to one that is only mildly annoying.

Modified by rkimmel