X
Tap here to go to the mobile version of the site.
IMPORTANT ANNOUNCEMENT: We’re going through some system changes, that may have slowed responses to your questions. If you had asked a question in the last couple of months, please re-post it and the community will help you as soon as we can. If you’ve registered after February 7th, please register again, the accounts on the previous site were not migrated to this temporary site. If you joined us before February 7, please reset your password if you have trouble logging into this temporary site.

Support Forum

FireFox launches a black screen after 33 update

Posted

After Firefox updated my version to 33, the application launches to a black screen. I've tried uninstalling my version and reinstalling the current version (33) and it (Firefox) still launches to a black full sized window. No other issues with other applications.

After Firefox updated my version to 33, the application launches to a black screen. I've tried uninstalling my version and reinstalling the current version (33) and it (Firefox) still launches to a black full sized window. No other issues with other applications.

Chosen solution

Could you try starting Firefox in its Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

With Firefox fully closed, you can hold down the Shift key when starting Firefox.

A small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

If Firefox is visible, go ahead and disable Firefox's use of hardware acceleration as a workaround for a possible graphics card driver software incompatibility.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

That will be in effect the next time you exit and start Firefox back up.

Read this answer in context 712

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E; .NET CLR 1.1.4322; MS-RTC LM 8; rv:11.0) like Gecko

More Information

jscher2000
  • Top 10 Contributor
5955 solutions 48882 answers

Chosen Solution

Could you try starting Firefox in its Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

With Firefox fully closed, you can hold down the Shift key when starting Firefox.

A small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

If Firefox is visible, go ahead and disable Firefox's use of hardware acceleration as a workaround for a possible graphics card driver software incompatibility.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

That will be in effect the next time you exit and start Firefox back up.

Could you try starting Firefox in its Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. With Firefox fully closed, you can hold down the Shift key when starting Firefox. A small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference? If Firefox is visible, go ahead and disable Firefox's use of hardware acceleration as a workaround for a possible graphics card driver software incompatibility. "3-bar" menu button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" That will be in effect the next time you exit and start Firefox back up.
jscher2000
  • Top 10 Contributor
5955 solutions 48882 answers

Another thought: if Firefox is restoring preview windows and tabs, it could be a full screen media player. The Esc key might help restore its normal size (at least for Flash). The standard key to toggle web pages between full screen and regular view is the F11 function key.

Another thought: if Firefox is restoring preview windows and tabs, it could be a full screen media player. The Esc key might help restore its normal size (at least for Flash). The standard key to toggle web pages between full screen and regular view is the F11 function key.

Question owner

Thanks... Issue resolved...

Thanks... Issue resolved...
jscher2000
  • Top 10 Contributor
5955 solutions 48882 answers

John, thank you for reporting back.

You may get video card updates with your monthly Windows updates or at other intervals, so you could try switching hardware acceleration back on after your next update. It mostly affects 3D and animations.

John, thank you for reporting back. You may get video card updates with your monthly Windows updates or at other intervals, so you could try switching hardware acceleration back on after your next update. It mostly affects 3D and animations.
NCEDAUS 0 solutions 9 answers

THANK YOU!

Turning off hardware acceleration fixed it for one of my client's computers too.

THANK YOU! Turning off hardware acceleration fixed it for one of my client's computers too.
philipp
  • Top 10 Contributor
  • Moderator
4424 solutions 19851 answers

Helpful Reply

hello, other users with this problem all had an embedded intel hd graphics card with an old driver present. in case this also applies to you, here would be a link to update the driver, which in turn should also address the black firefox problem.

Intel HD 2000/3000: 32bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23763 64bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23764

Intel HD 4000: 32bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24328 64bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24329

hello, other users with this problem all had an embedded intel hd graphics card with an old driver present. in case this also applies to you, here would be a link to update the driver, which in turn should also address the black firefox problem. '''Intel HD 2000/3000: ''' 32bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23763 64bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23764 '''Intel HD 4000: ''' 32bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24328 64bit https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24329
aujpoj 1 solutions 3 answers

What if you can't see any menus? See screenshot.

What if you can't see any menus? See screenshot.
philipp
  • Top 10 Contributor
  • Moderator
4424 solutions 19851 answers

aujpoj, i've answered that in your question at https://support.mozilla.org/en-US/questions/1025733 you can launch into firefox save mode by pressing the shift-key while firefox is launching...

aujpoj, i've answered that in your question at https://support.mozilla.org/en-US/questions/1025733 you can launch into firefox save mode by pressing the shift-key while firefox is launching...
amysovereign 0 solutions 5 answers

Mine is doing that today too. Black screen upon startup.

Internet Explorer works fine though.

Have tried uninstalling & reinstalling. No luck

Mine is doing that today too. Black screen upon startup. Internet Explorer works fine though. Have tried uninstalling & reinstalling. No luck
Emma99 0 solutions 1 answers

Perfect solution! Thanks so much!

Perfect solution! Thanks so much!
jscher2000
  • Top 10 Contributor
5955 solutions 48882 answers

Hi amysovereign, try using Firefox's Safe Mode to disable Firefox from using hardware acceleration, as described in this post: https://support.mozilla.org/questions/1025438#answer-640569

Or if you update your graphics card driver software, that may fix it. See: https://support.mozilla.org/questions/1025438#answer-641090

Note that in order to do that update, you may need to first research which Intel chipset is in your system.

Hi amysovereign, try using Firefox's Safe Mode to disable Firefox from using hardware acceleration, as described in this post: https://support.mozilla.org/questions/1025438#answer-640569 Or if you update your graphics card driver software, that may fix it. See: https://support.mozilla.org/questions/1025438#answer-641090 Note that in order to do that update, you may need to first research which Intel chipset is in your system.
amysovereign 0 solutions 5 answers

The safe mode solved the problem-thanks!

The safe mode solved the problem-thanks!
juraL 0 solutions 2 answers

When I start firefox black screen come up. Restarting did not help. When tried to start firefox in safe mode by clicking shift and forefox. Safe mode did not start. - Solved when installed Intel update

When I start firefox black screen come up. Restarting did not help. When tried to start firefox in safe mode by clicking shift and forefox. Safe mode did not start. - Solved when installed Intel update

Modified by juraL