Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Non SSL website on port 443

more options

Hi, I have a non-SSL website running on port 443. When I access this website using Chrome or IE it works just fine, but Firefox can't seem to accept what I have done. All browsers on the same machine and using the same web proxy.

I access the website as http://xyz:443.

Just a bit of background info as to why I need this. Where I work I can only access ports 443 and 80 via the web proxy. I have two distinct websites running on a couple of devices at home behind a very config-wise limited router which has ports 80 and 443 redirected to these hosts. There is no way for me to setup two port forward rules on port 80 to two different devices. I cannot setup SSL on either of the websites.

Regardless of options that could exist to overcome my particular issue, I would like to check if you guys know how to make Firefox work with a website running on port 443 whilst not having a certificate assigned to it.

Firefox 32.0.3 Error message: The connection was reset

The connection to the server was reset while the page was loading.

   The site could be temporarily unavailable or too busy. Try again in a few moments.
   If you are unable to load any pages, check your computer's network connection.
   If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

All Replies (2)

more options

What type of ssl are you running? https://blog.mozilla.org/security/201.../the-poodle-attack-and-the-end-of-ssl-3-0/

You can somehow remove the Strict-Transport-Security header or if there is a feature that forced encryption but by default https uses 443 for encryption. I do not know if this is possible.

more options

Hi guigs2, thanks for taking the time to reply.

As I said this website is NOT running on SSL and that is the problem, I need it to run on port 443 but it needs to run on HTTP.

This is working fine, IE and Chrome can browse this website with no problem whatsoever. It is only Firefox that complains.