X
Tap here to go to the mobile version of the site.

Support Forum

I would like to remove the arrows when scrolling down a search page.

Posted

When I do a search in firefox and the results turn up I get an arrow as I scroll page down and it skips a few lines. I would like to remove the arrows and control the page myself.

When I do a search in firefox and the results turn up I get an arrow as I scroll page down and it skips a few lines. I would like to remove the arrows and control the page myself.

Chosen solution

Are you scrolling with your mouse, or with the scroll bar, or with the keyboard?

I'm having trouble picturing the arrow that you're seeing. Would it be possible to post a screen shot? If it is a change to the mouse pointer, the screen shot probably won't include that, but if it is an element of the page, then it should.

This article has tips on screen shots. Please remove any personal/confidential information before posting (you can attach an image to a reply).

How do I create a screenshot of my problem?


Not sure it's relevant, but Firefox has an accessibility feature named caret browsing that moves the cursor through the document. You can turn this off in the Preferences dialog. Please see this article for more information: Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox (it's the first item on the General mini-tab, "Always use the cursor keys to navigate within pages").

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

jscher2000
  • Top 10 Contributor
8643 solutions 70721 answers

Chosen Solution

Are you scrolling with your mouse, or with the scroll bar, or with the keyboard?

I'm having trouble picturing the arrow that you're seeing. Would it be possible to post a screen shot? If it is a change to the mouse pointer, the screen shot probably won't include that, but if it is an element of the page, then it should.

This article has tips on screen shots. Please remove any personal/confidential information before posting (you can attach an image to a reply).

How do I create a screenshot of my problem?


Not sure it's relevant, but Firefox has an accessibility feature named caret browsing that moves the cursor through the document. You can turn this off in the Preferences dialog. Please see this article for more information: Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox (it's the first item on the General mini-tab, "Always use the cursor keys to navigate within pages").

Are you scrolling with your mouse, or with the scroll bar, or with the keyboard? I'm having trouble picturing the arrow that you're seeing. Would it be possible to post a screen shot? If it is a change to the mouse pointer, the screen shot probably won't include that, but if it is an element of the page, then it should. This article has tips on screen shots. Please remove any personal/confidential information before posting (you can attach an image to a reply). [[How do I create a screenshot of my problem?]] ---- Not sure it's relevant, but Firefox has an accessibility feature named caret browsing that moves the cursor through the document. You can turn this off in the Preferences dialog. Please see this article for more information: [[Advanced settings for accessibility, browsing, system defaults, network, updates, and encryption]] (it's the first item on the General mini-tab, "Always use the cursor keys to navigate within pages").

Question owner

I'm scrolling down with my page down button on my macbook. If you look at the screen shot you'll see the arrow under the wiki entry. If I use the "page down" on my keyboard it arrows down the page but does it in groups of 3 or 4 whereas I used to just scroll down and had no arrows. Hope this makes sense. Thanks for your reply.

I'm scrolling down with my page down button on my macbook. If you look at the screen shot you'll see the arrow under the wiki entry. If I use the "page down" on my keyboard it arrows down the page but does it in groups of 3 or 4 whereas I used to just scroll down and had no arrows. Hope this makes sense. Thanks for your reply.
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

You may have switched on caret browsing.

You can toggle caret browsing on/off by pressing F7 (Mac: fn + F7).

  • Firefox > Preferences > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages"

Note that this is an accessibility feature of Firefox.

You may have switched on caret browsing. *http://kb.mozillazine.org/accessibility.browsewithcaret You can toggle caret browsing on/off by pressing F7 (Mac: fn + F7). *Firefox > Preferences > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages" Note that this is an accessibility feature of Firefox. *http://kb.mozillazine.org/Scrolling_with_arrow_keys_no_longer_works *http://kb.mozillazine.org/Accessibility_features_of_Firefox
jscher2000
  • Top 10 Contributor
8643 solutions 70721 answers

Helpful Reply

Oh, the blue triangle to the left of the result that moves between results when you use the arrow keys? I see that, too.

Based on threads on Google's support forum:

  • The blue arrow appears when you are not logged in to a Google account (I didn't test logged in)

I an not aware of any other way to disable it other than to log in or turn off instant results. It's always possible someone created an add-on to do that.

Oh, the blue triangle to the left of the result that moves between results when you use the arrow keys? I see that, too. Based on threads on Google's support forum: * The blue arrow appears when you are not logged in to a Google account (I didn't test logged in) * It is linked to Google Instant Prediction results, which you can disable in Search Settings: https://www.google.com/preferences I an not aware of any other way to disable it other than to log in or turn off instant results. It's always possible someone created an add-on to do that.
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

Maybe modify this extension to include the VK_UP (0x26) and VK_DOWN (0x28) keys.

Maybe modify this extension to include the VK_UP (0x26) and VK_DOWN (0x28) keys. *free-control: https://addons.mozilla.org/firefox/addon/free-control/
Figgerty 6 solutions 92 answers

I had this problem too.

I turned carat browsing on and off and still the blue triangle appeared. The same applied to being signed in and out of Google. I think this may be linked to the scrolling selections under Options and Browsing. I deselected "Autoscrolling" and the blue triangle disappeared and the same happened when I deselected "Use Smooth Scrolling". The browsing seems OK without the distracting blue triangle.

I had this problem too. I turned carat browsing on and off and still the blue triangle appeared. The same applied to being signed in and out of Google. I think this may be linked to the scrolling selections under Options and Browsing. I deselected "Autoscrolling" and the blue triangle disappeared and the same happened when I deselected "Use Smooth Scrolling". The browsing seems OK without the distracting blue triangle.

Modified by Figgerty

cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

Helpful Reply

This is done by Google and not a Firefox issue.

This is a new feature on the Google results page to allow navigation via the keyboard when Google Instant predictions is enabled. This arrow will appear once you use the cursor Up/Down keys. You can consider to disable Google Instant predictions on the Google Search Settings page.

This is done by Google and not a Firefox issue. This is a new feature on the Google results page to allow navigation via the keyboard when Google Instant predictions is enabled. This arrow will appear once you use the cursor Up/Down keys. You can consider to disable Google Instant predictions on the Google Search Settings page. *https://www.google.com/preferences *Google Instant predictions -> Never
bug78 0 solutions 2 answers

This happened to me also. It seems to go away if you add a "complete=0" item to the URL query string, eg. http://www.google.co.uk/search?q=TEST&complete=0. I didn't know how to add custom search engines to firefox so I installed the Add to Search Bar extension and used that to add it. It creates an xml file in the searchplugins folder which you can edit by hand.

This happened to me also. It seems to go away if you add a "complete=0" item to the URL query string, eg. [http://www.google.co.uk/search?q=TEST&complete=0 http://www.google.co.uk/search?q=TEST&complete=0]. I didn't know how to add custom search engines to firefox so I installed the [https://addons.mozilla.org/en-US/firefox/addon/add-to-search-bar/ Add to Search Bar] extension and used that to add it. It creates an xml file in the searchplugins folder which you can edit by hand.