X
Tap here to go to the mobile version of the site.

Support Forum

Mozilla Firefox no longer allows me to visit google.com; it claims it can't confirm the connection is secure.

Posted

Last week, my anti virus software (bitdefender) expired, and I was without one for a couple of days. By now I have reinstalled the updated version and it is fully operational, with no security issues or messages or updates waiting to be installed. It might be a coincidence (but I think not), but since a couple of days, Mozilla firefox no longer allows me to visit google.com/be (I'm Belgian); it claims it can't confirm that the connection is secure. I most often use the search engine duckduckgo, but would still like to be able to use google if need be!

I have tried running Mozilla Firefox without add-ons and there was no difference. Every time, I get this message:

"This Connection is Untrusted You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. ..."

Please can someone help me? I run Windows 7. According to the action center, everything is running normally, and internet security settings are "set to their recommended levels". That's as far as my internet problem solving abilities go..

Thank you so much!

Last week, my anti virus software (bitdefender) expired, and I was without one for a couple of days. By now I have reinstalled the updated version and it is fully operational, with no security issues or messages or updates waiting to be installed. It might be a coincidence (but I think not), but since a couple of days, Mozilla firefox no longer allows me to visit google.com/be (I'm Belgian); it claims it can't confirm that the connection is secure. I most often use the search engine duckduckgo, but would still like to be able to use google if need be! I have tried running Mozilla Firefox without add-ons and there was no difference. Every time, I get this message: "This Connection is Untrusted You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. ..." Please can someone help me? I run Windows 7. According to the action center, everything is running normally, and internet security settings are "set to their recommended levels". That's as far as my internet problem solving abilities go.. Thank you so much!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NPWLPG
  • VASCO Card Reader Plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

Question owner

Ok, I think I more or less understand the issue. I agree. But then what do I do? If I change the settings in Bitdefender, I might not be able to visit google.com again?

Ok, I think I more or less understand the issue. I agree. But then what do I do? If I change the settings in Bitdefender, I might not be able to visit google.com again?
christ1
  • Top 25 Contributor
2168 solutions 15868 answers

I guess you'll have to try to find out.

I guess you'll have to try to find out.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Hi TineG, did you use the Add Exception feature for Google? If so, you can remove the exception so that Firefox handles the site's certificate normally to see whether that gets you back in.

"3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab > "View Certificates" button

Check the Servers tab. You will see some with * for the server and Permanent lifetime; those are built-in blocks on bad issuers so you can ignore those and look for the servers you care about.

Hi TineG, did you use the Add Exception feature for Google? If so, you can remove the exception so that Firefox handles the site's certificate normally to see whether that gets you back in. "3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab > "View Certificates" button Check the Servers tab. You will see some with * for the server and Permanent lifetime; those are built-in blocks on bad issuers so you can ignore those and look for the servers you care about.