X
Tap here to go to the mobile version of the site.

Support Forum

When printing Firefox does not open the Print Dialog window

Posted

When printing at our office we often need to print to multiple printers and not just the default printer. When printing in Firefox, however, the print automatically gets sent to the default printer and I do not get a print dialog window. I have reset Firefox's printer options, changed the prefs.js file, and launched Firefox from safe mode to check if an add-on is affecting printing - all to no avail. When I print from Chrome, or (shudder) Internet Explorer I get a dialog box giving me printer options. Your help and responses will be appreciated.

When printing at our office we often need to print to multiple printers and not just the default printer. When printing in Firefox, however, the print automatically gets sent to the default printer and I do not get a print dialog window. I have reset Firefox's printer options, changed the prefs.js file, and launched Firefox from safe mode to check if an add-on is affecting printing - all to no avail. When I print from Chrome, or (shudder) Internet Explorer I get a dialog box giving me printer options. Your help and responses will be appreciated.

Chosen solution

There is a hidden preference to bypass the dialog, but it definitely is not set by default. To check for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste print. and pause while the list is filtered

(3) If you discover a preference named print.always_print_silent there's your trouble.

Next question would be, where did it come from?! Some possibilities:

(A) A user.js file that overrides prefs.js at startup. See: How to fix preferences that won't save.

(B) A lock file in the program folder. See: http://kb.mozillazine.org/Locking_preferences

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

More Information

jscher2000
  • Top 25 Contributor
7245 solutions 58968 answers

Chosen Solution

There is a hidden preference to bypass the dialog, but it definitely is not set by default. To check for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste print. and pause while the list is filtered

(3) If you discover a preference named print.always_print_silent there's your trouble.

Next question would be, where did it come from?! Some possibilities:

(A) A user.js file that overrides prefs.js at startup. See: How to fix preferences that won't save.

(B) A lock file in the program folder. See: http://kb.mozillazine.org/Locking_preferences

There is a hidden preference to bypass the dialog, but it definitely is not set by default. To check for that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''print.''' and pause while the list is filtered (3) If you discover a preference named '''print.always_print_silent''' there's your trouble. Next question would be, where did it come from?! Some possibilities: (A) A user.js file that overrides prefs.js at startup. See: [[How to fix preferences that won't save]]. (B) A lock file in the program folder. See: http://kb.mozillazine.org/Locking_preferences

Question owner

Thank you jscher2000. Changing always_print_silent to "false" solved the issue. It seems that was enough to save the preference as well. (we'll see what happens when I log in again next week...) Again - can't thank you enough.

Thank you jscher2000. Changing always_print_silent to "false" solved the issue. It seems that was enough to save the preference as well. (we'll see what happens when I log in again next week...) Again - can't thank you enough.