X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 32 always gives "Document expired" every single time I hit the Back key to return to search results. Firefox 31 did not. Why?

Posted

Ever since the update for Firefox 32.0 installed, doing a search that uses a post (which I have done for many years with no trouble with any other browser OR with Firefox 31) yields "Document Expired" whenever I hit the Back button to return to my search results. Since I use my browser to, like, search fairly often, obviously this utterly destroys the user experience. I have not done anything at all to about:config settings. How can I make this version function correctly?

To reproduce: go to startpage.com, search for anything; click on a result. Hit Back. You will see the Document Expired message (and then have to interact with a popup as well!). Every. Single. Time.

Again: This behavior is *new* with version 32. I am running Windows 7.

Thanks for reading.

Ever since the update for Firefox 32.0 installed, doing a search that uses a post (which I have done for many years with no trouble with any other browser OR with Firefox 31) yields "Document Expired" whenever I hit the Back button to return to my search results. Since I use my browser to, like, search fairly often, obviously this utterly destroys the user experience. I have not done anything at all to about:config settings. How can I make this version function correctly? To reproduce: go to startpage.com, search for anything; click on a result. Hit Back. You will see the Document Expired message (and then have to interact with a popup as well!). Every. Single. Time. Again: This behavior is *new* with version 32. I am running Windows 7. Thanks for reading.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

jscher2000
  • Top 10 Contributor
8768 solutions 71705 answers

Thankfully I am not getting that problem on Startpage.com myself.

Have you customized anything about Firefox's history settings?

Thankfully I am not getting that problem on Startpage.com myself. Have you customized anything about Firefox's history settings?
jscher2000
  • Top 10 Contributor
8768 solutions 71705 answers

More generally: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

More generally: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: "3-bar" menu button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?

Question owner

Thanks for the reply. Removing all the site's cookies did not have any effect. However, regarding your first suggestion, I did notice something interesting: I tried the Ctrl+Shift+r on startpage's search results page (not its introductory search screen), and when I clicked on a search result and went Back, I didn't get the Document Expired message. Clicked on another, went Back, still no Document Expired. So, that was promising.

However, when I went to startpage.com again and did a new search, I was back at square one: clicking on a search result and hitting Back again gave me the Document Expired message.

Let me ask: I know you said it worked for you -- but (and only bother with this if you don't use startpage often) if you did your first search at startpage to test for my problem, go back and do another search. Do you see the problem now?

Thanks for looking into it.

(Oh, and to answer your first question - no, I have done nothing whatsoever to customize anything about my History)

Thanks for the reply. Removing all the site's cookies did not have any effect. However, regarding your first suggestion, I did notice something interesting: I tried the Ctrl+Shift+r on startpage's search results page (not its introductory search screen), and when I clicked on a search result and went Back, I didn't get the Document Expired message. Clicked on another, went Back, still no Document Expired. So, that was promising. However, when I went to startpage.com again and did a new search, I was back at square one: clicking on a search result and hitting Back again gave me the Document Expired message. Let me ask: I know you said it worked for you -- but (and only bother with this if you don't use startpage often) if you did your first search at startpage to test for my problem, go back and do another search. Do you see the problem now? Thanks for looking into it. (Oh, and to answer your first question - no, I have done nothing whatsoever to customize anything about my History)
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

Are you using a bookmark to open that page initially?

If you do then try to open the main page by typing the URL in the location/address bar and bookmark that page. It is usually (never) a good idea to bookmark pages that were reached by sending a (possibly hidden) form with POST data. Such a bookmark will give problems if you use the Back key.

Are you using a bookmark to open that page initially? If you do then try to open the main page by typing the URL in the location/address bar and bookmark that page. It is usually (never) a good idea to bookmark pages that were reached by sending a (possibly hidden) form with POST data. Such a bookmark will give problems if you use the Back key.

Question owner

There is no possibility that bookmarks are involved, especially since the troubles are centered around a search results page.

The problem happens regardless of how I navigate to startpage.com -- typing it in, using it has my built-in search engine, anything.

There is no possibility that bookmarks are involved, especially since the troubles are centered around a search results page. The problem happens regardless of how I navigate to startpage.com -- typing it in, using it has my built-in search engine, anything.
jscher2000
  • Top 10 Contributor
8768 solutions 71705 answers

I probably use the search bar plugin more than the startpage.com home page, but I am not getting the POST warning when going Back either way. I wonder why the difference?

I probably use the search bar plugin more than the startpage.com home page, but I am not getting the POST warning when going Back either way. I wonder why the difference?

Question owner

Er, yes, I wonder why the difference too. :-) Seriously, you may have been on to something with the cache issue you mentioned in your first reply. So what could be different between users that would change that behavior? Is there some flag in my settings that I need to do something with? People used to say to change some browser.sessionstore.postdata flag, but I don't see it in my settings.

Er, yes, I wonder why the difference too. :-) Seriously, you may have been on to something with the cache issue you mentioned in your first reply. So what could be different between users that would change that behavior? Is there some flag in my settings that I need to do something with? People used to say to change some browser.sessionstore.postdata flag, but I don't see it in my settings.
jscher2000
  • Top 10 Contributor
8768 solutions 71705 answers

You can find a list of the most important customized preferences on the page that opens when you use either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

There is a button in the upper left corner to copy the page to the clipboard for pasting here. Although usually there is no personal information in that text, please use "Preview Reply" and check for any email addresses or other sensitive data before posting.

You can find a list of the most important customized preferences on the page that opens when you use either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter There is a button in the upper left corner to copy the page to the clipboard for pasting here. Although usually there is no personal information in that text, please use "Preview Reply" and check for any email addresses or other sensitive data before posting.
fireattack 0 solutions 6 answers

Try to clear your disk cache and see if it works.

Myself have very similar problem with POST and back, but not in startpage.com.

However I do have problem on lots of other sites that using POST... check my bugzilla report: https://bugzilla.mozilla.org/show_bug.cgi?id=1060082

Try to clear your disk cache and see if it works. Myself have very similar problem with POST and back, but not in startpage.com. However I do have problem on lots of other sites that using POST... check my bugzilla report: https://bugzilla.mozilla.org/show_bug.cgi?id=1060082
fireattack 0 solutions 6 answers

Oh, I can reproduce it on startpage.com too now!

In my case, you need to at least search two keywords (i.e. send POST twice), then back - then document expired happens.

As I mentioned in bugzilla, this problem could be reproduced on two of my computers, both with beta or nightly, CLEAR profile (you need to reduce disk cache to very small in order to reproduce it faster).

Oh, I can reproduce it on startpage.com too now! In my case, you need to at least search two keywords (i.e. send POST twice), then back - then document expired happens. As I mentioned in bugzilla, this problem could be reproduced on two of my computers, both with beta or nightly, CLEAR profile (you need to reduce disk cache to very small in order to reproduce it faster).

Modified by fireattack

jscher2000
  • Top 10 Contributor
8768 solutions 71705 answers

Hi fireattack, you wrote:

Oh! I can reproduce it on startpage.com too now!

In my case, you need to at least search two keywords (i.e. send POST twice), then back - then document expired happens!

Okay, now I see that, too.

Hi fireattack, you wrote: <blockquote>Oh! I can reproduce it on startpage''.''com too now! <br><br>In my case, you need to at least search two keywords (i.e. send POST twice), then back - then document expired happens!</blockquote> Okay, now I see that, too.

Modified by jscher2000

Question owner

Huh. In my case, it happens regardless of how many keywords (I tried one search term just now, and had the same thing happen).

fireattack, were you talking about the *browser cache* when you asked if I'd cleared my cache? Sorry, just confirming ... seems like everybody's got a cache. :-)

Huh. In my case, it happens regardless of how many keywords (I tried one search term just now, and had the same thing happen). fireattack, were you talking about the *browser cache* when you asked if I'd cleared my cache? Sorry, just confirming ... seems like everybody's got a cache. :-)
Uncle-Jed 0 solutions 1 answers

Helpful Reply

For those using startpage.com this worked for me… on the “startpage” home screen go into settings, (top right of page) uncheck “Use POST vs GET”

Make sure to save your setting!

  • Note: startpage.com description for this option: For additional privacy - keeps your search terms out of the logs of webmasters of sites that you reach from our results.
For those using startpage.com this worked for me… on the “startpage” home screen go into settings, (top right of page) uncheck “Use POST vs GET” Make sure to save your setting! *Note: startpage.com description for this option: For additional privacy - keeps your search terms out of the logs of webmasters of sites that you reach from our results.

Modified by Uncle-Jed

jscher2000
  • Top 10 Contributor
8768 solutions 71705 answers

Hi Uncle-Jed, yes, that's right, the Document Expired message only affects pages returned when you use POST.

Hi jakff, yes, the cache is Firefox's cache. There is further discussion of possible changes to cache settings in this thread: https://support.mozilla.org/questions/1018237

Hi Uncle-Jed, yes, that's right, the Document Expired message only affects pages returned when you use POST. Hi jakff, yes, the cache is Firefox's cache. There is further discussion of possible changes to cache settings in this thread: https://support.mozilla.org/questions/1018237
peggyn 0 solutions 1 answers

Helpful Reply

i am on startpage. i get this problem 5 to 7 times a day. from what i have seen on these forums there are multiple "fixes" which do not effing work. firefox treats this as if it were not a problem. it is a huge problem. i do not like being online anymore. i get 'document fucking expired' then delete all cookies and have to re-sign in for every account i have and perform two other recommended rituals that do not work for more than five minutes. firefox is fucked up. that is what i am not seeing on these stupid threads. firefox was not fucked up a month ago. but it is now and now i have to try all these different fixes myself, some of which i do not even understand, while firefox remains unaccountable. fuck this. either tell me what to do to fix this permanently or tell me what the best alternative to firefox is. this is insane.

i am on startpage. i get this problem 5 to 7 times a day. from what i have seen on these forums there are multiple "fixes" which do not effing work. firefox treats this as if it were not a problem. it is a huge problem. i do not like being online anymore. i get 'document fucking expired' then delete all cookies and have to re-sign in for every account i have and perform two other recommended rituals that do not work for more than five minutes. firefox is fucked up. that is what i am not seeing on these stupid threads. firefox was not fucked up a month ago. but it is now and now i have to try all these different fixes myself, some of which i do not even understand, while firefox remains unaccountable. fuck this. either tell me what to do to fix this permanently or tell me what the best alternative to firefox is. this is insane.
jscher2000
  • Top 10 Contributor
8768 solutions 71705 answers

Hi peggyn, it turns out this has nothing to do with cookies. It is somehow related to how Firefox manages a full cache (it does not cache the results page when the cache is full, so Firefox cannot go back to it).

Did you try the steps to clear Firefox's cache or manually set a different size? Start by calling up the Options/Preferences dialiog:

For Windows:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab

For Mac:

"3-bar" menu button (or Firefox menu) > Preferences > Advanced > Network mini-tab

On that tab, in the second section, which should be labeled Cached Web Content, you can try either:

  • Clear Now (if you have a large hard drive, this may lock up Firefox for a couple minutes)
  • Check the box for "Override automatic cache management" and, if desired, increase the cache size from the default of 350 megabytes
Hi peggyn, it turns out this has nothing to do with cookies. It is somehow related to how Firefox manages a full cache (it does not cache the results page when the cache is full, so Firefox cannot go back to it). Did you try the steps to clear Firefox's cache or manually set a different size? Start by calling up the Options/Preferences dialiog: ''For Windows:'' "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab ''For Mac:'' "3-bar" menu button (or Firefox menu) > Preferences > Advanced > Network mini-tab On that tab, in the second section, which should be labeled Cached Web Content, you can try either: * Clear Now (if you have a large hard drive, this may lock up Firefox for a couple minutes) * Check the box for "Override automatic cache management" and, if desired, increase the cache size from the default of 350 megabytes